Uitleg: port forwarding instellen

  • 2 september 2016
  • 173 reacties
  • 67203 Bekeken


Toon eerste reactie

173 reacties

@Poco-Locao: hahahaha, nee, ik snap wat je bedoelt met DMZ hoor 🙂
ALLE poorten domweg doorzetten naar de Fritz op de Huawei.

OpenVPN op TCP..... ook een leuke suggestie... ga ik ook testen!
Eerst op poort 1194 uiteraard en anders op een andere "known" poort.

Ik WEET dat 22 werkt tenslotte.....
En als ik toch kan kiezen die dan via VPN te benaderen dan doe ik dat liever dan een servertje direct naar buiten open te zetten op poort 22.
Dat bewuste servertje wist me namelijk te vertellen dat er in 1 nacht al ruim 100 mislukte inlogpogingen waren geweest....
Vandaar dat ik hem ook al weer uitgezet had via poort 22 😉
Ohw ja.... tenzij je er echt niks op hebt staan, niet open zetten 😃
Arch......

Allereerst de NAS op TCP gezet voor OpenVPN, de Fritzbox op TCP gezet v.w.b.. portforwarding op poort 1194 EN de Huawei op TCP gezet v.w.b. port-forwarding op poort 1194.
Portscannetje gedaan en ook die gaf nu aan dat de poort 1194 reageerde :-D
Blij verheugd een poging gedaan om via mijn mobieltje te verbinden naar mijn 4G voor thuis........ nada....:'(

Afijn.... om een lang verhaal kort te maken. Als je op de Huawei dingen aanpast v.w.b. port-forwarding, helpt het niet voldoende om ok te klikken bij de forwarding-regel en de settings (van alle port-forwardingen te "apply'en".
Je moet OOK nog even de Huawei herstarten om alles netjes actief te laten worden.....

DAARNA...... werkte alles probleemloos! Ik kan nu, zoals gewenst, van buitenaf via OpenVPN verbinding maken naar mijn lokale netwerkje achter 4G voor thuis!
DynDNS zorgt er voor dat ik dat op hostname kan doen, dus I'm a happy camper!

Overigens heb ik ook nog een soort van geprobeerd alles weer op UDP te laten verlopen en dat werkte niet. Maar...... dat kan ook komen omdat ik niet het certificaat van de NAS opnieuw op mijn laptop had geladen.

Dusch..... voor iedereen die ook tegen vergelijkbare trubbels aanloopt met de Huawei E5186s-22a (de standaardmodem die momenteel door T-Mobile geleverd wordt bij 4G voor thuis).
Je moet je pas ongerust maken als je gereboot hebt en het werkt daarna NOG niet ;-)
En..... ik verdenk UDP er van sowieso niet te werken via de Huawei E5186s-22a v.w.b. port-forwarding maar ik heb geen zin dat nog uit te puzzelen.

@T-Mobile: Misschien een aardig plan deze bevindingen met de Huawei E5186s-22a eens uitgebreider te testen en dan eventueel door te zetten naar Huawei?! Mogelijk komt er dan een firmwareversie uit waarin dit opgelost wordt.

Ik had overigens hiervoor een Huawei 5172 die zich vergelijkbaar gedroeg. Die is/was echter van een paar jaar eerder dan deze Huawei. Hierbij heb ik dit hele feestje met uiteindelijk een reboot NIET geprobeerd (wel vermoedelijk de modem gebrickt omdat ik er een niet officiele firmwareversie opgezet heb vanwege dit probleem). Dus ook voor andere Huawei's geldt mogelijk bij port-forwardingen..... pas gaan twijfelen aan jezelf als je de modem gereboot hebt en het werkt nog steeds niet.
Met speciale dank aan Poco-Loco die me het idee van TCP aan de hand deed.
Reputatie 5
Badge +11
@spithost Super om te lezen dat het gelukt is, bedankt Poco-Loco voor je hulp!!

Allereerst de NAS op TCP gezet voor OpenVPN, de Fritzbox op TCP gezet v.w.b.. portforwarding op poort 1194 EN de Huawei op TCP gezet v.w.b. port-forwarding op poort 1194.
Voor de toekomst is het wellicht slimmer om, zoals Poco-Loco al aangaf, inderdaad DMZ in te stellen op het Huawei modem naar je Fritzbox. Je neemt dan een stukje complexiteit weg; het is in ieder geval al één factor minder die voor problemen kan zorgen.

@T-Mobile: Misschien een aardig plan deze bevindingen met de Huawei E5186s-22a eens uitgebreider te testen en dan eventueel door te zetten naar Huawei?! Mogelijk komt er dan een firmwareversie uit waarin dit opgelost wordt.
Goed punt. Er komt echter een nieuw modem van Huawei aan met nieuwe firmware, wellicht dat het daarin wél goed werkt. Het huidige modem gaat helaas geen firmware updates meer krijgen. Ik heb een aantal samples opgevraagd van het nieuwe modem zodat we e.e.a. kunnen testen, daar zou dit mooi bij kunnen passen.

Bedankt voor het delen van jullie ervaringen hier, keep 'em coming!!! 😃
is het al duidelijk wanneer we een vast ip adres kunnen krijgen
Reputatie 7
Badge +20
Hi Bartaal,

Daarover wordt alles gedeeld in het topic over work in progress. Op het moment wordt er begonnen met testen, dus het is nog even afwachten!
Dennis is er al meer bekent wanneer DDNS mogelijk is met het HUAWEI ?
ik wil zelf direct de controle willen hebben over mijn eigen gehoste web-omgeving van mijn thuis server.
heb vandaag wel wat vorderingen gemaakt
werk op een iMac die is aangesloten op de Huawei
op de Huawei heb ik onder settings virtual server verschillende protocollen aangezet met de bij behorende poorten en het LAN ip adres van mijn iMac
heb in de iMac settings onder sharing mijn filesharing aan voor de webpagina met bijbehorende user en password net als remote login met bijbehorende user en password
verder zet ik via node een server.js script aan waar een website op draait en die me vertelt op welke poort.
en het werkt als ik met een vodafone iPhone in mijn webbrowser het WAN ip adres ingeef van de iMac xxx.xxx.xxxx.xxx met bijbehorende poort : 8081 en mijn /index.html laad de desbetreffende webpage.
wat ook werkt is remote connecten via SSH via UNIX Reflection software op de vodafone iPhone hierin geef ik het WAN ip adres van mijn iMac via poort 22 stel verder username en password in die bekend is onder filesharing remote login van mijn iMac en boem ik zit gelijk in de terminal omgeving van de iMac. morgen doorstoeien met FTP en DNS, verder wil ik uitvinden hoe ik de iMac een remote wakeup call kan geven als het in slaapstand is en ik remote wil connecten.
Badge +2
Dennis is er al meer bekent wanneer DDNS mogelijk is met het HUAWEI ?
ik wil zelf direct de controle willen hebben over mijn eigen gehoste web-omgeving van mijn thuis server.


Hallo spalburg,


Excuses voor de late reactie op jouw post
Dennis kan je vraag momenteel niet beantwoorden.

ik heb vernomen dat het de bedoeling is dat dit beschikbaar is op het nieuwe type modem van Huawei.

Heb je zo antwoord op je vraag?
Dennis is er al meer bekent wanneer DDNS mogelijk is met het HUAWEI ?
ik wil zelf direct de controle willen hebben over mijn eigen gehoste web-omgeving van mijn thuis server.


Hallo spalburg,


Excuses voor de late reactie op jouw post
Dennis is kan je vraag momenteel niet beantwoorden.

ik heb vernomen dat het de bedoeling is dat dit beschikbaar is op het nieuwe type modem van Huawei.

Heb je zo antwoord op je vraag?


Jou reactie is meer een zoethoudertje maar je geeft geen antwoord op mijn vraag jammer
Badge +2
@spalburg

Haha nee dat was niet de bedoeling 🙂.

Volgens mij heeft dennis al eerder gecommuniceerd dat er geen veranderingen meer in de software van het huidige modem zouden plaatsvinden omdat er werd gekeken naar een ander type.

Dat betekent dus ook dat deze optie meegenomen. Deze optie zal dus beschikbaar zijn op het nieuwe modem.

Ik hoop dat ik zo wel antwoord heb gegeven op je vraag.
en nog steeds geef je geen antwoord op mijn vraag wanneer DDNS beschikbaar komt. Dat het niet op het splinternieuwe modem is dat ik nog geen drie maanden geleden heb aangeschaft wist ik al. vraag me wel af of ik weer een modem moet aanschaffen of deze dan kan inruilen als het zover is? en of er nog steeds sprake is dat ik een statisch ip krijg of dat dit idee door DDNS komt te vervallen?
verder vind ik het super dat je me zo klantvriendelijk te woord staat alleen heb ik er pas wat aan als je je dan ook inspant om mijn vragen daadwerkelijk te beantwoorden. als je het niet weet geen man overboord maar zeg me dan gewoon dat je het niet weet.
vriendelijke groet M.
Badge +2
@spalburg

Ik zal me dan maar wat meer inspannen :P

Ik begrijp nu dat je wil weten wanneer het nieuwe modem kan worden geleverd. We hebben nog geen precieze datum. Ik kan je daarom geen toezeggingen doen of concrete data geven.

Ik zal jouw feedback wel meenemen, Bedankt voor je post 😉
Beste,

Ik ondervind het zelfde als Johannesje 5 maanden geleden.
Als ik inlog bij noip zie ik daar bij ip/target het wan adres van de fritzbox welke ik gebruik, namelijk: 192.168.8.2 in plaats van het wan ip van de Huawei.
Zoals eerder genoemd werd dan bij de dns instellingen het wan ip verandert in het internet ip, echter begrijp ik nu niet wat ik hier moet instellen.
Is er iemand die hier raad mee weet?

Ik hoor het graag 🙂
Je moet wel de NAT optie aanzetten bij de config van de no-ip tool. Als dat ingebouwd is in de Fritzbox, dan zou het weleens lastig kunnen worden (de Fritzbox gaat er natuurlijk van uit dat ie rechtstreeks op het internet zit).

Ik heb het no-ip tooltje draaien op het linux systeem dat ik als router gebruik, en de DDNS updates zijn dan wel correct, met NAT optie aanstaan (anders krijg ik hetzelfde probleem als jij).
Momenteel ben ook ik aan het worstelen om het voor elkaar te krijgen dat bijvoorbeeld No-Ip werkt op mijn systeem.
Heb dus de Huawei router ingesteld zoals aan het begin van dit draadje. waar ik over twijfel is of ik de Ethermet setting wel goed het staan met LAN only.

Als ik met ipscanner.nl scan op poorten dan krijg ik geen enkel resultaat.
De cameras die ik heb kan ik ook nog steeds niet benaderen.
Ik heb een Fritzbox achter de huawei hangen om mijn eigen netwerk in tact te houden.
Ik heb alles namelijk in de 10.0. range.

Bij internet connection heb ik gekozen voor "Connect to a cable modem"
Bij connection settings heb ik gekozen voor configure the ip address manually en als volgt ingevuld.
IP address 192 .168. 8. 2
Subnet mask 255.255.255.0
Default gateway 192.168.8.1
Primary DNS server 192.168.8.1
Secondary DNS server 0.0.0.0
Bij ïf your internet provider expects a special MAC address, enter it here"
staat een mac adres vooringesteld.

De internet verbinding werkt prima met deze instellingen, ik kan alleen verder nog niets.
Bij portforwarding heb ik trouwens nog niets ingevuld.
Bij Dynamic DNS heb ik mijn No=Ip account informatie ingevuld die goed werkte onder de verbinding via adsl.

Heeft iemand een idee wat ik over het hoofd zie?
Het lukt me inmiddels trouwens niet meer om met mijn telefoon via wifi verbinding te maken.
Hij blijft hangen op IP adres op vragen.
Reputatie 6
Badge +11
@arnoldscustoms
In de E5186s-22a moet je bij ethernet niet 'LAN only' maar 'auto' selecteren. 'LAN only' wekt de indruk dat de 4G module er niet toe doet, dus in feite totaal geen verbinding naar buiten over 4G.
Volgens verkoopadvertenties kan de E5186s-22a ook puur als router fungeren (dus met werkende WAN op poort4), maar met de huidige firmware (die niet meer ge-update wordt), werkt dit niet dus vooral niet aankomen zou ik zeggen.
Ok, ingesteld op Auto. en na een reboot nog geen verbinding extern.
Internet werkt goed.
Hieronder een aantal printscreens die ik heb gemaakt van zowel de huawei als mijn fritz.



Ik vraag me wel af welke account gegevns ik hier in moet vullen en hoe belangrijk dit is.







En de belangrijkste instellingen van de fritz, althans dat denk ik.







De ip adressen bij de kruisjes heb ik hier gelijk.

Ik dacht dat ik me aardig kon redden op dit gebied, maar ik krijg het nu toch niet voor elkaar.
Ik moet iets over het hoofd zien.
Reputatie 6
Badge +11
@arnoldscustoms
In de Fritzbox onbreken bij "Permit Access" nog de portforwarding voor je camera etc. Verder zie ik geen hiaten en bij PPPoE hoef je niks in te vullen, authenticate gaat anders, dit is een vergissing van google chrome browser weet ik uit ervaring, maar doet in dit geval geen kwaad.

Dat DDNS (wellicht) niet werkt kan liggen aan een mogelijke optimalistie in de Fritzbox m.b.t. dir: Veronderstel dat een modem in bridgemode aan de Fritzbox hangt dan kan de Fritzbox als event een nieuw public IP adres waarnemen, zonder via via van buitenaf dat vast te stellen m.b.v. noIP b.v.. Maar de Fritzbox heeft een vast adres 192.168.8.2 dus dat werkt niet. Je kan een ander apparaat dan de Fritzbox DDNS laten doen, b.v. app op smartphone of camera of computer, of iets bij noIP op site instellen. Ik ken noIP niet. Of een setting in de Fritzbox veranderen (als die er is) zodat de DDNS in de Fritzbox ook gaat pollen b.v. elke 10 minuten wat het publieke adres van je 4GvT is.

Ik zou ook alle WiFi van de E5186s-22a uitzetten en die van de Fritzbox gebruiken.
Bedankt voor je reactie, ik ga eens wat verder testen.
Ik was eerst namelijk helemaal geen portforwarding nodig omdat ik die No-Ip had ingesteld.

Dat ik nu niet meer via wifi kan verbinden met de huawei komt dan denk ik omdat dhcp uit staat? vind ik aan de ene kant wel jammer want ik kan dan niet met de laptop meer rechtstreeks met de huawei verbinden.

Ik heb in de camera ook de No-Ip ingesteld, en dat ook weer op mijn telefoon. toch krijg ik geen enkele verbinding met de cameras. Maar ik ga weer ff verder stoeien.
Reputatie 6
Badge +11
Het testen van toegang tot je camera werkt niet van 4GvT huis netwerk,alleen van buitenaf. Je kan op je telefoon even WiFi uitzetten en dan via de mobile internet verbinding van je telefoon de camara benaderen. Of bij de buren o.i.d.
@tmoesel, nogmaals bedankt.
Ik heb de cameras nu idd goed werkend met portforward.
Dit was eerst niet nodig, vandaar dat ik dacht dat dit niet nodig was.

Nu verder met mijn domotica 🙂
Toch nog 1 dingetje wat ik me af vraag.
Volgens mij zou ik best dhcp aan kunnen laten staan in de Huawei router.
In mijn geval zit de rest van het netwerk op een heel andere range en zal dan toch geen problemen veroorzaken in mijn netwerk.
Want dan zou ik namelijk ook weer mijn wifi kunnen gebruiken van de Huawei.

Update, dit werkt inderdaad(voor nu) heb net dhcp in de Huawei weer aan gezet.
Ik heb een fritzbox 6840 LTE met firmware 6.83 en die draait zonder problemen op T-Mobile datasimkaart.
Echter wat je hier beschrijft met het aanpassen van het profiel om het portforwarding te kunnen laten werken werkt niet. ik krijg dan in de log de melding: LTE connection could not be established Reason:ESM_Failure en de volgende melding is:
The LTE PGW rejected the connection. Check the entries on the APN used. If these are correct, contact your LTE Internet provider.

Bij internet service provider heb ik staan T-Mobile en bij APN fms. geen user of password ingevoerd..
Enig idee hoe dit op te lossen?
Reputatie 6
Badge +11
@Golden Ton
De fms APN werkt alleen met een 4G voor Thuis SIMkaart. Wellicht is de "T-Mobile datasimkaart" dat niet?

Reageer