Beantwoord

no service abroad (South Africa)

  • 19 december 2020
  • 3 reacties
  • 441 Bekeken

My service was working abroad all the time, receiving calls and SMS outside Europe. But since I have arrived to South Africa it went permanently on voicemail, calls and SMSes no longer coming through. I need my phone to be active, not on voicemail with SMSes being blocked. I have restarted phone, checked SMS center number, manually checked different providers in South Africa, and nothing has worked. How to solve this?

icon

Beste antwoord door David 21 december 2020, 10:34

Hi @afrovera,

Is it possible that the coverage in your area is not optimal? This could explain why you don't have any service at that moment. If there is already a spotty coverage in the area, then foreign sim cards can experience problems already and on top of that local sim cards get priority on the available network.

Another possible explanation could be that there are unpaid bills and a barring has been placed on your sim card. I can't check this for you, since you haven't registered on our Community with your My T-Mobile account. If this is the case, then the open invoices have to be paid and then the barring will be removed automatically. 

If you have any further questions, let us know!

Bekijk origineel

3 reacties

Reputatie 7
Badge +20

Hi @afrovera,

Is it possible that the coverage in your area is not optimal? This could explain why you don't have any service at that moment. If there is already a spotty coverage in the area, then foreign sim cards can experience problems already and on top of that local sim cards get priority on the available network.

Another possible explanation could be that there are unpaid bills and a barring has been placed on your sim card. I can't check this for you, since you haven't registered on our Community with your My T-Mobile account. If this is the case, then the open invoices have to be paid and then the barring will be removed automatically. 

If you have any further questions, let us know!

I have connected to MTN manually and it’s working now. Thanks.

Reputatie 7
Badge +20

@afrovera,

Good to know it has been resolved! Have a good week! :thumbsup:

Reageer