Beantwoord

Gebruik thuisserver vanaf het internet

  • 12 mei 2017
  • 5 reacties
  • 667 Bekeken

Beste lezer,

Thuis heb ik een mac mini server verbonden aan een airport. De toegang tot de server vanaf het internet kun je configureren en controleren op de server met de bijbehorende software. Dit werkte zonder problemen in de voorgaande situatie waarbij het airport gekoppeld was aan een kabelmodem in bridge mode.

In de nieuwe situatie is de kabelmodem vervangen door de G4 modem van G4 voor thuis. Internet, email, etc. werkt maar de server is niet meer beschikbaar vanaf het internet. Dit geeft de server ook aan op basis van het in gebruik zijnde IP adres.

Het thuisnetwerk is niet veranderd en geeft ook geen problemen. De g4 modem is met port forwarding geconfigureerd, dus met fms als APN. Volgens de documentatie staan dan alle poorten open. Daarnaast meldt het airport dat er nog steeds dubbel gebruik van NAT. Dat had ik hiervoor ook maar het gebruik van fms zou ook NAT vanuit de G4 modem moeten stopzetten.
Op de 4g modem kun je een virtuele server configureren maar hiervan is weinig documentatie en mijn pogingen hebben niets opgeleverd.

Heeft iemand ervaring met een server icm een airport en het 4G modem? Nog beter, wat moet ik doen om vanuit het internet mijn thuisserver te kunnen benaderen?
icon

Beste antwoord door tmoesel 12 mei 2017, 16:34

Je kan het beste deze thread doornemen:
https://forum.t-mobile.nl/installatie-andere-technische-vragen-480/uitleg-port-forwarding-instellen-270716

DMZ instellen voor de 4G modem is kort gezegd een oplossing.

De 4G modem kan niet in bridgemode, ook met fms APN doet de modem nog steeds NAT en ook je airport.
Bekijk origineel

5 reacties

Reputatie 6
Badge +11
Je kan het beste deze thread doornemen:
https://forum.t-mobile.nl/installatie-andere-technische-vragen-480/uitleg-port-forwarding-instellen-270716

DMZ instellen voor de 4G modem is kort gezegd een oplossing.

De 4G modem kan niet in bridgemode, ook met fms APN doet de modem nog steeds NAT en ook je airport.
tmoesel dank je voor dit antwoord, maar ik heb al een aantal uurtjes configureren en internetten achter de rug. De thread waarna je verwijst geeft duidelijk aan dat met fms er geen NAT is dus wie heeft er gelijk. DMZ is ingesteld en het werkt dus. Ik kan alleen de server niet vanuit het internet benaderen.
Reputatie 6
Badge +11
@X-mobile
Met fms is er geen 'Carrier NAT', dwz er vindt niet ook nog een keer NAT in het TMO netwerk plaats.

In geval van Carrier NAT is je publieke adres van je modem b.v. 10.x.x.x

Met fms is het publieke adres van je modem 91.141.x.x en vanaf internet benaderbaar. Het interne adres is 192.168.8.1 en interne adressen van apparaten zijn 192.168.8.0/24 voor range zie DHCP server settings. Dus vandaar 'modem NAT' van 91.141.x.x naar 192.168.8.0/24. Verder heb je in je airport nog NAT.

De servers / portmapping zal je op de airport moeten doen wat je wellicht al had. Ik ken de airport niet in detail, maar voor kabelmodem bridgemode naar 4gmodem NAT moet er wellicht nog iets aangevinkt worden. Wellicht geven fritzbox screenshots hints.

Andere zaken:
- een powercycle van de modem soms nodig.
- het kan zijn dat de mac mini server niet met 2x NAT kan of wil omgaan, maar dit is gissen voor mij.
tmoesel weer bedankt voor je tijd en antwoord.

Dit is de tekst uit de thread:

Bij 4G voor Thuis kun je een publiek beschikbaar IPv4 adres krijgen met onze nieuwe APN (fms), je zit dan dus niet meer achter een NAT.

Ik begrijp uit jouw uitleg dat we het hier hebben over de NAT van T-mobile. De NAT van het thuisnetwerk en de NAT van de 4G modem blijven dus bestaan. Dat is op zich geen probleem, deze melding had ik ook bij het kabel modem.

De poorten van het thuisnetwerk zijn niet het probleem. Dit wordt simpel opgelost door de configuratie van de server die ook het airport aanpast. De server weet welke poorten open gezet moeten worden bij het selecteren van de diensten (agenda, web, etc.).

Het probleem is dat ik niet vanuit het thuisnetwerk niet mijn eigen IP adres kan testen. Dit kon ik vroeger wel. Naar aanleiding van je bericht heb ik vanuit een ander netwerk met dus een ander IP adres verbinding gemaakt met 91.141.x.x. Dit werkte dus wel. Ik ga ervan uit dat alle diensten op de server dus alleen via een extern netwerk werken. Dat is wel lastig want dan moeten de IP adressen voor de server van de mobile apparaten die thuis op wifi gezet zijn worden aangepast van het externe IP adres naar het interne IP adres. Ook zal de test op de server nooit werken.

Ik ga nu verder met het opzetten van DDNS. Misschien werkt het dan wel zonder de IP adressen te moeten veranderen vanwege de kleine omweg.
Reputatie 6
Badge +11
@X-mobile
Gelukkig dat het toch werkt. Ik had niet gedacht aan inerne/externe IP euvel. De Huawei ondersteunt deze routing niet.

Reageer