Beantwoord

Huawei E5186s-22a MTU 9000

  • 2 december 2016
  • 8 reacties
  • 1284 Bekeken

Reputatie 6
Badge +11
  • is een legendarische user
  • 1758 reacties
Ook al hebben zowel de 'Huawei E5186s-22a' als 'FRITZ!Box 6490 Cable (kdg)' 4 gigabit ethernet poorten, vraag ik me af of een MTU > 1500 wordt ondersteund. De laatste in ieder geval niet, ben ik een tijd geleden na veel testen en ompluggen tegengekomen in een AVM forum.

Er zijn een aantal ethernet settings in de Huawei die het 1 en ander suggeren maar aangezien bridgemode en een aantal andere zaken m.b.t. RJxx connectoren niet werkt vraag ik mij af of datapaketten met een MTU van 9000 wel ongeschonden de WiFi sectie naar mijn Nexus9 passeren. Het blijkt na ontwaken van de tablet het vaak niet lukt om binnen en minuut en goede internet connectie te verkrijgen. Pas na heel veel DHCPOFFERs komt dan soms een DHCPACK

Als ik de MTU van server terugzet op 1500 blijft er nog maar 1/3 van de throughput van Ata-over-Ethernet over.

De vraag is dus: Ondersteunt de Huawei MTU 9000 zonder dat ik de ethernetsetting aanpas?

De Huawei HW/SW:

Hardware version: CL1E5175HM
Software version: 21.313.01.00.00
Web UI version: 16.100.02.00.03
icon

Beste antwoord door DennisAmeling 2 december 2016, 15:46

@tmoesel
Het is alleen mogelijk om de MTU aan te passen in de Ethernet Settings van het Huawei modem, maar ik begrijp uit je bericht dat dit niet gewenst is.
Kun je iets meer uitleg geven over waarom je zo'n hoge MTU wil? Dit verhoogt namelijk ook de kans dat datapakketten corrupt raken. Merk je nog een verschil tussen de 2.4GHz en 5GHz wifi banden op je Nexus?
Bekijk origineel

8 reacties

Reputatie 5
Badge +11
@tmoesel
Het is alleen mogelijk om de MTU aan te passen in de Ethernet Settings van het Huawei modem, maar ik begrijp uit je bericht dat dit niet gewenst is.
Kun je iets meer uitleg geven over waarom je zo'n hoge MTU wil? Dit verhoogt namelijk ook de kans dat datapakketten corrupt raken. Merk je nog een verschil tussen de 2.4GHz en 5GHz wifi banden op je Nexus?
Reputatie 6
Badge +11
Ik gebruik af en toe Ata-over-Ethernet (Linux AoE), dus harde schijven (lawaai) in 1 computer in berging en de bestandssystemen (SoftWare RAID) op een andere computer, in 1 LAN/switch en lange ethernetkabel. Met MTU=1500 bleek transfer ~30MBps en met MTU=9000 ~110MBps (= max GBit LAN snelheid), zeer stabiel. (iSCSI bleek wel ~100MBps te kunnen halen met MTU=1500, maar is ongewenst en onnodig complex).

Dit alles heeft in beginsel niks met de MTU van de DSL/Cable/4G link te maken maar wel als je de RJ45 poorten deel uit laat maken van dezelfde LAN/switch. Dit probleem had ik bij een Fritzbox6490 en heb mede daarom voor de Huawei maar 1 ethernet kabel aangesloten. 5G WLAN had ik nog niet, vandaar dat ik WLAN van de Huawei gebruik, maar daarmee is de Huawei niet meer aleen maar een 2punts vebinding tussen 4G en LAN.

Performance van WLANs is goed en zoals verwacht: in zelfde ruimte kiest zowel Nexus9 als GalaxyS5 voor 5G, maar achter het huis in de schuur natuurlijk voor 2.4G.

Ik zal de ethernet settings aanpassen en kijken of het haperende ontwaken/verbinden van Nexus9 WLAN te verhelpen is. Het kan een scala aan oorzaken hebben. Nexus9 met standaard uptodate Android N is soms iets te vooruitstrevend, o.a. hardnekkig IPv6 voorkeur geven. Dat kan er ook aan de hand zijn. XS4ALL heeft IPv6 goed werkend, daar had/heb ik geen problemen. Bij KabelDeutschland had ik een Fritzbox6360 en daar zit een IPv6 probleem in, was altijd connectie/DHCP problemen aan einde van lease-tijd. Heb nu een Fritzbox 6490, daar werkt IPv6 wel naar behoren.

De WPA key voor 2.4G in de Nexus9 is gewist, zodat heen en weer hoppen tussen 2.4G en 5G niet de oorzaak van falende DHCP process kan zijn.

Nog een oorzaak zou kunnen zijn dat de Nexus9 via-via de externe DNS van T-Mobile eerst checkt en daar dan geregeld een timeout krijgt. Ik zie namelijk bij succes soms eerst even 'Connected, no internet'. Maar lijkt me niet de meest waarschijnlijke.
Reputatie 6
Badge +11
Als je in de Huawei bij Settings -> Network Setting -> MTU size: 9000 probeert in te vullen komt de melding: "The MTU size must range from 576 to 1500." in rood. Op welke ethernet poort(en) of link(s) deze setting van toepassing is, is mij niet helemaal duidelijk. MTU=9000 kan dus niet volgens de instellingen.

Als ik 2 PCs met beide MTU=9000 aansluit op resp ethernetpoort 2 en 3 gaat in eerste instantie de verbinding wel OK, b.v. alleen ssh inloggen. Met 'grotere' acties via ssh blijft het dan 'ergens in het midden' compleet hangen. (De ethernet kabel doorknippen zou als effect hebben dat de gebruiker wel een melding/timeout krijgt)
Uitsluitsel geeft ping (tussen de 2 linux PC met kernel 4.8.11)

$ ping -f -s 1504
0% packet loss

$ ping -f -s 1505
100% packet loss

Als ik dezelfde PCs in 2 poorten van een TL-SG108E_2.0 switch plug:
$ ping -f -s 9000
0% packet loss

Deze TL-SG108E_2.0 heeft in datasheet bij Performance: Jumbo frame: 15kB.

Een laptop krijg ik via WiFi niet op MTU=9000, ook al stel ik dat in, de uiteindelijke setting meldt MTU=1500. WiFi (2.4G) lijkt wel stabiel als de ethernetbekabeling maar statisch blijft na reboots.

Bij het ompluggen van kabels raakt de Huawei in de problemen (ook als er alleen maar MTU=1500 in gebruik is). Wat er precies aan de hand is weet ik niet, maar zag laatst met wireschark wel opmerkelijk ARP (address resolution protocol) verkeer. Bij andere routermodems heb ik nooit degelijke problemen opgemerkt.

Om grip te krijgen op het oorspronkelijke probleem met Nexus9 WiFi verbindingsopbouw heb ik alle WiFi in de Huawei uitgezet en een TL-WA901ND (300Mbps wirelessN router) aan de TL-SG108E_2.0 switch aangesloten en zelfde SSID/WPA als Huawei. De Nexus9 had nu direct contact, en ik zie maar 1 DHCP sequentie: DISCOVER+REQUEST+OFFER+ACK

Ik zal dit een aantal dagen zo aanschouwen, morgen komt de buitenantenne, dat is belanrijker.
Reputatie 5
Badge +11
@tmoesel
Dank voor de toelichting. Ik vrees dat we niet veel verder gaan komen met het aanpassen van de MTU op het Huawei modem als deze gelimiteerd is op max. 1500 :(
Wél zijn we aan het kijken naar een nieuw modem van Huawei, die wat meer features, en - belangrijker - 4G+ op het T-Mobile netwerk ondersteunt. Huawei zit uiteraard ook niet stil in de ontwikkeling van hun firmware en mogelijk wordt het aanpassen naar een hogere MTU in een nieuwer model wel mogelijk.
Mocht je het idee hebben dat er écht iets mis is met het modem, geef even een seintje. Dan ruilen we deze voor je om.

Kijk het vooral even aan en we zijn benieuwd naar je ervaringen! 🙂
Reputatie 6
Badge +11
Ik heb nu 29 uur de extra TL-WA901ND WiFi router uitgeschakeld en daarna alle MTU's van apparaten op max 1500 (of default) en alleen Huawei 2.4G WiFi aangezet. Dus 5G WiFi staat uit en ook DHCP server van Huawei staat uit. Ik gebruik dezelde, eigen DHCP server (dnsmasq). De routers staan vrijwel naast elkaar in dezelfde kamer op zolder

Gisteren en vanochtend, dus sowieso korter dan 24 uur na de WiFi omwisseling, was geen lange hapering in het tot stand komen van WiFi connectie van Nexus9. Het duurde nog wel steeds iets langer dan met de TL-WA901ND, maar ruim binnen en minuut.
Nu echter is het probleem weer terug; Als ik tablet ga gebruiken: 'No connection' en dnsmaq log laat alleen maar lange reeks DHCPDISCOVER en DHCPOFFER zien en geen DHCPACK. Zowel WiFi toggle als reboot van Nexus9 helpen niet. Een Huawei power cycle wel. Bij Statistics zie ik nu 1 lijstje met 4 WLAN clients en niet 2 lijstjes.

Helaas blijkt nu dat andere WiFi apparaten er erg lang over te doen om volledige internet connectie te krijgen, minuten later dan de Huawei LTE internet connectie. 1 android apparaat komt en verdwijnt weer uit het WLAN clients lijstje. Uiteindelijk is er wel verbinding.

Mijn huidige conclusie: Na een disconnect/connect van de 4GvT verbinding op OSI layer3 (IP connectie) verandert er iets in de interne packethandling van de Huawei (met hier genoemde instellingen) waardoor o.a. Nexus9 geen internet connectie meer kan of wil krijgen. Ik kan de geforceerd updaten naar versie 7.1.1., maar lijkt me onwaarschijnlijk dat dit het probleem verhelpt.
Reputatie 6
Badge +11
Het uit- en weer aanzetten van WLAN in de Huawei zorgt ervoor dat de Nexus9 wel direct verbinding heeft, zo'n 200 milliseconden van CONNECTING naar CONNECTED in de logcat van AndroidDebugBridge. Doe ik geen WLAN reset van de Huawei, dan krijgt de Nexus9 gewoon geen verbinding nadat WiFi voor langer dan 5 to 15 disconnected was (door b.v. de WiFi van Nexus9 uit en wer aan te zetten of de hele tablet in sleep/standby te laten gaan.

Het probleem lijkt dus niet direct te maken te hebben met het al dan niet aanwezig zijn van jumboframes (MTU=9000 ethernet packetten).
Reputatie 5
Badge +11
@tmoesel
Dank voor je uitgebreide analyse. Als ik het zo hoor klinkt het alsof de Nexus9 en het Huawei modem niet lekker samen gaan. Zou je toch eens willen proberen of je Android kan updaten op je Nexus9? Soms zitten in die updates ook netwerkoptimalisaties.
Heb je ook al eens een volledige reset van het Huawei modem geprobeerd?

Mocht dit ook niet helpen, dan blijft mijn eerdere aanbod om je modem om te ruilen staan. Ik kan niet met zekerheid zeggen of dat het probleem wel zou verhelpen, maar we kunnen het altijd proberen!
Reputatie 6
Badge +11
De Nexus9 is al ruim een week geleden ge-update naar 7.1.1, maar ik heb alle WiFi van de Huawei al 3 weken uitstaan en gebruik mijn eigen losse WiFi accesspoint. Het geheel draait nu na ruim 2 maanden dat ik 4GvT heb voldoende stabiel en ik ga niet expliciet tijd besteden aan het WiFi subsysteem in de Huawei. Heb ook geen broncode en/of debugmogelijkheden voor de Huawei.

Door o.a. electriciteits(net) werkzaamheden heeft de Huawei nog steeds niet langer dan ca. 2 weken zonder powercycle of reboot gewerkt, dus de echte duurtest/vergelijking met ADSL Fritzbox moet de komende maanden gebeuren.

Reageer