Conflicting Country Codes: Mac, Wifi

  • 17 november 2019
  • 2 reacties
  • 2027 Bekeken

Hi there,

I would like to ask if anyone at T-mobile knows how to fix the “conflicting country codes” problem experienced on MacBook Pro, MacOS Catalina, Wifi 5gHz and 2.4gHz, fibre optic, 200Mbit connection, Huawei HG659 router.

Last week Wednesday, 6th November, T-Mobile did a maintenance switch (according to their customer service line) that directed the web traffic through Germany. I was informed that the connections would be returned in batches and that the issue would go away by the 14th. They also submitted a technical support ticket for me, which sadly, has gone unnoticed.

My country code that shows up under my Wifi network on my Mac reads DE, instead of NL and upon factory resetting the router, it shows CN (China) for some time before switching back to DE. Unfortunately, this is causing me connection issues, where other networks i’ve tester over the last week connect problem free (including using my T-mobile iPhone hotspot - which has country code NL).

I have also noticed that under the advanced online settings for my router (Huawei HG659), there is a greyed out explanation for changing the country code manually. I have searched the entire online settings for the router, there is no option that allows me to do this. In some suggestions it is stated to ensure your computers location is set correctly, mine is set to Netherlands.

I have tried factory resetting, changing the channels, changing DNS settings, adjusting Hardware to capped MTU numbers, refreshed the DCHP Lease. Nothing works. The problem persists.

I have made 9 phone calls to T-mobile about this issue and I was told there is nothing that I can do on my side, that the issue lies with the modem (which I don’t have access to - Fibre is managed externally). The problem has still not been fixed, and I have still not heard from the technical team. 

I am open to ideas on how to fix this, I did notice that the issue was raised 2 months ago, though the thread had no conclusive evidence on a fix.

Kind regards,

Mark

 


This topic has been closed for comments

2 reacties

Reputatie 5
Badge +11

@Sam_Mark 

That's a very annoying problem! Happened to us as well when one of our neighbors was using country code TW (Taiwan) and our 5GHz WiFi network simply wouldn't show up anymore.

Please let me clarify that the routing of traffic through DE (which T-Mobile has rolled back now) has nothing to do with the country code that your Huawei modem is broadcasting (as far as I'm aware of). This is a separate setting that is done in the modem itself, although it could be that T-Mobile has hidden that setting for us (customers) as they customize the modem firmwares.

Unfortunately, this is causing me connection issues, where other networks i’ve tester over the last week connect problem free (including using my T-mobile iPhone hotspot - which has country code NL).

Could you explain “connection issues” a bit further? Could you test the following things?

  • Does the MacBook connect to your WiFi network at all? I know that when the country code is wrong, and your WiFi is on a specific 5GHz band that is not supported in that country (DE in this case), then your WiFi network simply won't show up in the list of available networks. You mentioned that you changed network channels already, may I ask which channels you used? Non-DFS channels (36, 40, 44, 48) work best in my experience
  • When doing a speed test at speedtest.net, what speeds are you getting?
  • When you run a ping test on your MacBook (let it run for about 1 minute), do you see any ping spikes or timeouts (packet loss)?

This will help T-Mobile's support agents to assist you better :) 

Hi @DennisAmeling,

Thank you for commenting to help us out. What I have noticed from logging in to the IP address is that the is no option for the user to change the country - which in turn would affect the country code. I don’t think the traffic switch caused the issue per se, but I do think it confused the router to a point where it could no longer rectify itself.

 

The connection issues I vaguely referred to there is connecting to Riot’s League of Legends game. What struck me as bizarre is that my Partner sitting next to me, using Wifi on 2.4gHz network, Windows 8.1, had no issues connecting, though I with MBP, wifi, 5gHz had massive delays and connectivity issues despite being on the same network. It would connect initially, but then lose all sense of connection before exiting and spitting our errors. 

 

The only thing that had changed the night it all stopped working was 

A) T-mobiles traffic

B) the game’s update

 

I have been in contact with the league of legend’s customer support for 10 days now and have tried every conceivable network suggestion they gave. Yesterday (Wednesday 20th Nov) they patched the game and I tried again. No change, still connection issues. To clear my head on where the fault lay, I went to my parents’ house last week (Ziggo fibre optic, 5gHz band, country code NL/EU) and connected to the game with zero connectivity issues or errors, leading me to believe the problem lies with my T-mobile connection. 

 

Yesterday evening T-Mobile replaced our router to a Zyxel T-50, the ping for the MBP on both networks, sits around 9ms, the download speed varies between 150-190mbps. But here is the other issue, now the Windows averages 49mbps download, with similar uploads (same ping as MBP).

 

Not only that, the new router reads that the country code is Italy. The game works, albeit with some latency, but the country code is still conflicting and causing sporadic latency spikes with the game connection. 

 

What’s more is that it read as Italy right out the box, which is confusing, you would think a new one would be coded correctly. The new router also seems to have a dodgy WAN port, as the network keeps disconnecting, the IP gateway login shows there is no WAN signal when the cable is plugged in. 

 

Never mind that for now, the channels I used were set to automatic, and I would check timely which it chose. Usually 100, or 116 for the 5gHz or 1, 4, 5 for the 2.4gHz. The Mac would still connect just fine to both network bands. 

 

How did you “fix” your country code problem? Did it ever rectify itself from Taiwan?