[Glasvezel] Draytek vervangen met je eigen router (met VLAN)


Reputatie 7
Badge +10
Draytek vervangen met je eigen Router

Wat heb je nodig?

Draytek 2132Fvn
TP-Link MC2200L
TP-Link Acher C7 (1750Mbit)
T-Mobile Thuis Glasvezel



Waarschuwing:
Kijk nooit direct in de connecor. Dit kan permanente oogschade veroorzaken!
Maak nooit zelf de glasvezel aansluiting open. Mocht hier schade aan ontstaan, zal dit door Reggefiber moeten worden hersteld. De kosten hiervan zijn minimaal 300 euro, maar kan nog hoger uitpakken!


Installatie:


Haal de blauwe connector uit de Draytek SFP, vervolgens kan je de SFP er uit halen door het blauwe hendeltje naar achter te trekken.


Installeer vervolgens de SFP in de TP-Link MC220L en stop de blauwe connector er weer in.

Plug nu de UTP kabel in de TP-Link MC220L en de andere kant in de WAN van de TP-Link Acher C7.
Configuratie:
Sluit je Laptop aan op poort 1 van de TP-Link Acher C7
ga naar http://192.168.1.1 en login

Ga naar Advanced
Ga naar Network
Ga naar IPTV/VLAN

Settings
code:
IGMP Snooping: uitschakelen
IGMP Proxy: uitschakelen
IGMP Version: V2

IPTV/VLAN inschakelen
Mode Custom
Internet Vlan ID: 300 Priority 0
802.1Q tag inschakelen.
IP-Phone vlan: 35
IPTV Vlan ID: 640







Je kan nu zelf kiezen op welk poort je internet of tv wil hebben.
IP-Phone vlan word niet gebruikt en is op vlan 35 gezet omdat deze anders moet zijn.
Het is niet mogelijk T-Mobile thuis Telefoon te gebruiken met een ander modem dan de Draytek.
Klaar!

Je krijgt vanuit T-Mobile GEEN ondersteuning op deze setup, maar gelukkig zijn er genoeg mensen op het forum te vinden die je willen helpen. Mocht je problemen hebben dan moet je eerst het oude modem weer gebruiken voordat T-Mobile je ondersteuning kan geven.

De handleiding is gemaakt met een TP-Link C7 maar dit werkt het zelfde op de volgende TP-Link Routers: (met dank aan Jibbewillem)
TL-WR1043N (2,4Ghz 450Mbit)
Archer C1200 V2, V3 (2,4Ghz + 5Ghz 1200Mbit)
Archer C7 V4, V5 (2,4Ghz + 5Ghz 1750Mbit)
Archer C9 V3, V4, V5 (2,4Ghz + 5Ghz 1900Mbit)
Archer C2300 V1 (2,4Ghz + 5Ghz 2300Mbit)
Archer C3150 V2 (2,4Ghz + 5Ghz 3150Mbit)
Archer C3200 V2 (2,4Ghz + 5Ghz 3200Mbit)
Archer C5400 V2 (2,4Ghz + 5Ghz 5400Mbit)



Vond je dit topic nuttig en wil je meer van dit soort topics geef dan een Like!

276 reacties

Reputatie 6
Badge +2
@Eddy1980

Uit de Mediaconverter kun je eigenlijk een aanleveraar zien van de TRUNK, hier zitten VLAN 300 & 640 in.

Deze sluit je zo te zien aan op poort 1, maar poort 1 is in geen enkel setting een member van welke andere poort.

Wat doe je met die VLAN 100?
En hoe ziet je PVID er uit?

Je TAGGED komt binnen op 1 en die zal dus ook een member moeten worden van de andere poorten.

VLAN Settings;

VLAN | VLAN name | member | tagged | untagged
1 ------| -----Default-- |--- 1-5 ----|--------- | --- 1-5
300 ---| -----Internet- |--- 1-3---- |---- 1 ---| --- 2-3
640 ---| ---- TV ------- | - 1,4-5 --| --- 1 ---- |-- 4-5
(streepjes zijn nodig voor goede layout)

PVID settings;

Port | PVID
port 1 | 1
port 2 | 300
port 3 | 300
port 4 | 640
port 5 | 640

Kijk eens of je er zo uit komt, maar je grootste error zit hem in de TAGGED poort nergens een member van te laten zijn

Een beetje referentie is te vinden in dit topic
Volgens de website van TP-Link beschikken de volgende modellen over de VLAN/IPTV instellingen, gesorteerd op prijs (van laag naar hoog):


Internationale modellen zijn niet meegenomen in dit lijstje.

Let erop dat je een model met minstens de bovengenoemde versienummers aanschaft. Het liefst altijd de nieuwste versie, omdat deze op andere vlakken ook verbetering met zich meebrengen.
Reputatie 6
Badge +13
In het gebied Wijchen werkt het helaas niet.
getest met TP-LINK met ASUS router en direct op SFP van de Mikrotik HAPac en RB3011.

Hardware Link is er maar ik krijg geen DHCP ip adres.

Iemand in deze buurt waar het wel is gelukt ?

Ik heb de Asus RT-AC5300 en hiervoor een RT-AC68U gehad. Op beide apparaten heb ik het werkend gekregen. Je moet dan de volgende instellingen gebruiken om een verbinding te krijgen.


Daarnaast moet de router in ‘Wireless router mode’ staan. WAN > internet connection moet op Automatic IP staan.

Ik heb enkele weken geleden wel problemen gehad. Hierdoor kreeg ik bedraad wel internet en tv, maar wifi wilde met geen mogelijkheid functioneren. De oplossing was dat ik de instellingen van IPTV (die altijd goed hebben gewerkt) moest veranderen naar zowel poort 3 als 4 op VID 640.

Hopelijk lukt het zo! 🙂
Reputatie 6
Badge +2
@Eddy1980

Ja, jouw opzet is inderdaad iets afwijkend van wat de meeste mensen meestal opzetten.
Maar dit werk op zich ook goed om zo een scheiding te maken, alleen zal je er dus wel een router achter moeten zetten i.v.m. DHCP en firewall.
Dat neemt dat MESH systeem van jou voor zijn rekening neem ik aan hopelijk.

Heb nog even een klein plaatje gemaakt van de opzet van de SG105E , wat ook eventueel eenvoudig is te vertalen naar een SG108E ... alleen meer poorten.



Veel plezier er mee zou ik zeggen.
@Will Wang it is true that you won't have an internet connection out of the box. You need to configure the VLAN's first. But to do this you need to access the web GUI.

Maybe your ethernet drivers on your laptop are not functioning properly. You could try using a wireless connection.

What error message do you get when you try to reach the router?

Hi @jibbewillem,

I managed to get connected using tplinkwifi.net, now everything works! Thank you very much for your help. And also thank OP for this post.
Hope my TP LINK gives me more stable internet than Draytek😉
Dan gaan we daar even naar kijken @ericjanvanputten !

Het is alleen een klein beetje lastig, omdat ik mijn Netgear niet meer heb. Maar ik zal je proberen te helpen.

Ik vermoed dat de fout hem zit in het feit dat je een nieuwe VLAN-regel toegevoegd hebt, terwijl je een bestaande genaamd "internet" aan had moeten passen. Deze staat al zo voorgeïnstalleerd dat hij vanaf de WAN-kant richting de LAN-kant gaat.

Hieronder nog een link van Netgear zelf:

Netgear router configureren

Ik hoop dat je er uit gaat komen, maar daar heb ik alle vertrouwen in!
Na nog maar 1 dag geprobeerd te hebben, lijkt het erop dat de koe de haas heeft weten te vangen 🙂

De Draytek 2132 vervangen voor een TP link MC220L icm mijn Netgear R7000, na even prutsen was het eigenlijk pluggen en werken.

Vandaag heeft spotify connect op meerdere echo dots v2's vele uren (totaal >10) het prima en zonder problemen gedaan. Het is wellicht wat vroeg, maar ben zeker positief 🙂

Alvast een grote dank aan @jibbewillem
Reputatie 7
Badge +10
Voor een eigen modem zonder vlan ondersteuning heb ik even een ander topic aangemaakt.
eigen modem zonder vlan
Reputatie 6
Badge +2
Hallo allemaal. vertel me hoe ik dit WLAN-netwerk moet configureren? Ik heb TP-link MC220L en asus rt-ac3200. Ik verbind alles met elkaar, log in asus. Ik kies voor een snelle configuratie en wat moet ik kiezen? statisch of dynamisch IP-adres? Wat dan? Ik heb nu twee dagen internet gelezen en ik werk met deze router. Ik kan het niet configureren. Ik vraag om hulp



@Tomek63
Hopelijk heb je iets aan deze bovenstaande informatie
Na een tip in een ander draadje over de uitblijvende Draytek Firmware updates werd ik attendeert op de mogelijkheden om zelf een glasvezel router/modem aan te schaffen.

Sinds gistermiddag het ik aldus een Ubiquiti Edgerouter X SFP werkend op mijn T-Mobile 750mbit aansluiting.

Televisie gebruik ik niet, dus ook niet in verdiept.
Telefoonnummer heb ik wel, maar staat/stond niet aangesloten. Alles gaat direct naar voicemail en ik luister af via het geluidsbestand welke ik via email ontvang.

Het was eigenlijk allemaal simpeler dan verwacht, enige waar ik even naar moest zoeken was dat ik de oude snelheid niet haalde. Bleef steken net onder de 450mbit.
Via het ubiquiti forum de oplossing gevonden dat 'hwnat offloading' ingeschakeld moet worden voor de hogere gasvezel snelheden. Nu netjes 750+mbit up en down.

Laatste firmware/software updates van 4 maart j.l. Eindelijk een router die me vertrouwen geeft.

Dank voor de vele tips op dit forum en in dit draadje.

Bij het volgen van de stappen is het belangrijk om VLAN 640 aan je ene poort toe te wijzen en de VLAN tag in te schakelen. Als dat allemaal goed staat moet je de box even een reset geven.

Trek de stroomstekker en internetkabel uit de tv box. Stop na een minuutje de stroomstekker er weer in. Wacht tot je een foutmelding krijgt en sluit dan pas weer de internetkabel aan.

Als alles goed staat zou je nu beeld moeten krijgen. Lukt het niet, kun je dan vertellen wat je te zien krijgt? Foutmelding? Wel menu geen tv? Succes!
Onwijs bedankt.
De Draytek vervangen voor jouw configuratie.

nu een TP-Link Archer 7 v4 hangen. Met een TP-Link MC220L Media converter.
En eindelijk door het hele huis weer WiFi. Ook kan ik mijn eigen dingen doen.

Top stukje!!

gr,

Aldwin

Draytek vervangen met je eigen Router

Wat heb je nodig?

Draytek 2132Fvn
TP-Link MC2200L
TP-Link Acher C7
T-Mobile Thuis Glasvezel

Reputatie 7
Badge +10
Hallo Rambo,

je moet vlan 640 bridge vanaf je wan door zetten naar je tv. server connection completed betekend verkeerde vlan of een routerd verbinding.
Reputatie 7
Badge +10
sluit eens een laptop aan. als je een 10.x.x.x ip krijgt is het ip tv. als de wan down is hoor je ook geen ip te krijgen.
Reputatie 7
Badge +10
Je krijgt van T Mobile een media convertor van fiber naar utp zonder losse sfp. je kan nu dus gewoon een utp kabel gebruiken voor je installatie.
De monteur plaatst de koppelbus in het ftu. als je de kabel heb liggen dan kan de monteur deze voor je koppelen. je mag helaas niet zelf het ftu openen.

ik zal de openings post aanpassen zodat het duidelijk is hoe het zit met nieuwe klanten.
Mooi om te lezen hoe dit topic een goudmijn aan informatie bevat! 😁 @twc is het nog gelukt met de opstelling?

Zeker is het gelukt. Alles werkt prima!
Reputatie 7
Badge +10
@eddy je moet de poort van de media convertor zetten op trunk met tagged vlan 300 en 640 deze zet je op poort 2 untagged op vlan 300, je kan maar 1 untagged 300 poort gebruiken
Het draait ondertussen al 2 dagen stabiel, dus ik denk dat het aan die uPnP danwel DHCP routes setting lag.😅
Reputatie 7
Badge +10
op de mediaconvertor hoef je niets in te stellen.
@Eddy1980

Uit de Mediaconverter kun je eigenlijk een aanleveraar zien van de TRUNK, hier zitten VLAN 300 & 640 in.

Deze sluit je zo te zien aan op poort 1, maar poort 1 is in geen enkel setting een member van welke andere poort.

Wat doe je met die VLAN 100?
En hoe ziet je PVID er uit?

Je TAGGED komt binnen op 1 en die zal dus ook een member moeten worden van de andere poorten.

VLAN Settings;

VLAN | VLAN name | member | tagged | untagged
1 ------| -----Default-- |--- 1-5 ----|--------- | --- 1-5
300 ---| -----Internet- |--- 1-3---- |---- 1 ---| --- 2-3
640 ---| ---- TV ------- | - 1,4-5 --| --- 1 ---- |-- 4-5
(streepjes zijn nodig voor goede layout)

PVID settings;

Port | PVID
port 1 | 1
port 2 | 300
port 3 | 300
port 4 | 640
port 5 | 640

Kijk eens of je er zo uit komt, maar je grootste error zit hem in de TAGGED poort nergens een member van te laten zijn

Een beetje referentie is te vinden in dit topic

Hoi Pieter_B

Helemaal top! het werkt nu.
De uitleg was helder, zeker met je voorbeeld!
Ik gebruik het nog dus naar mijn mening zou dat gewoon nog steeds moeten werken. Maar volgens mij zeggen ze dat gewoon aan de telefoon om ze het gewoon niet willen hebben
Ook maar de stap gewaagd en de Draytek eruit gegooid en vervangen voor een TP-Link MC220-L en een ASUS-AC828. Instellingen die ik hier heb gevonden m.b.t. VLAN ingevoerd en werkt als een zonnetje. Het WiFi bereik is wel een stuk beter, maar het dikke beton in onze nieuwbouwwoning geeft ook hier problemen, dus maar besloten om een WiFi mesh op te zetten met Asus Lyra. Loze leidingen hadden we toch genoeg liggen en EUR 42 voor 50m CAT7A is goed te doen 😉 Kunnen we in de toekomst ook naar 10Gbit/s 😉
@ericjanvanputten in combinatie met de R7000 werkt het. Ik heb zelf een korte tijd een R7800 aangesloten gehad. Netgear apparaten zijn heel makkelijk in te stellen en bij moeilijkheden helpen we je graag. Hou er wel rekening mee dat je geen telefonie hebt zonder de Draytek.

@jibbewillem thanks! vandaag komt de MC220L binnen en zal direct een poging wagen, hierbij ga ik in de netgear naar VLAN instellingen en zal daar een poging doen om de instellingen van de topicstarter in te kloppen (maar als je nog tips hebt hoe wat waar ;))

Ik denk hier bezig te moeten:



Verder zal telefonie & tv me op dit moment een rotzorg zijn 😉
hmmm @jibbewillem gevalletje opnieuw inpluggen en zelfde gedaan als voorheen (behalve dat IGPM aangezien ik dat eerder ook niet gedaan had) maar nu wel werken lijkt het ... hopelijk dat het hele netwerk internet heeft maar ik kan mijn spotify test gaan doen 🙂
Reputatie 6
Badge +2

@Viveutvivas 

Hier is een document (pdf) van Draytek.nl dat gaat over IPTV opzetten op een Draytek. Dit document is volgens mij voor een KPN aansluiting, maar kun je denk ik wel wat info uit betrekken.

Begrijp ik het goed, dat je de 802.1q Multi-VLAN un-tagging op je WAN over wil slaan, waarop dus 300/640 zitten?

 

Reageer