Beantwoord

[Glasvezel] Huawei HG659 vervangen door Edgerouter X

  • 22 februari 2020
  • 12 reacties
  • 2027 Bekeken

Goedendag Community.

Ik ben nieuw op het forum alhoewel ik al geruime tijd meelees bij dit onderwerp.

Zelf heb heb ik gekozen voor T-mobile omdat ik bij mijn zoon de Draytek heb gezien waarbij de benadering van de router nog kon worden omgezet naar andere poorten dan 80 en 443.

Helaas heb ik ondanks toezeggingen een Huawei router gekregen en deze werd niet meer omgeruild.

Nu draait mijn netwerk al weer een tijd met een Pfsense Firewall in de DMZ van Huawei.

Ik krijg daar alles zoals ik graag heb, met uitzondering van de Servers die ik graag zowel van uit mijn netwerk als van buitenaf moet kunnen benaderen.

Meelezend heb ik dan ook besloten om een poging te wagen om mijn Huawei router te vervangen door een Edgerouter X.

Tot zover gaat dat voorspoedig.

Ik heb de basic setup van de wizard gevolgd

Eth0 als WAN connectie en eth1 t/m 4 als switch voor het LAN

De router met eth0 aangesloten op mijn media coverter met een VLAN 300.

Ik krijg keurig een 31.XX.XX.XX adres.

Op de switch heb ik ook een VLAN 640 en een VLAN 300 geconfigureerd

Beide voorzien van DHCP met verschillende subnets.

2 poorten van de switch voor VLAN 300 aangemerkt (VID)

2 poorten van de switch voor VLAN 640 aangemerkt (PVID)

 

Mijn PC heeft Internet en de speedtest duidt er op dat mijn snelheid t.o.v. Huawei ruim verdubbeld is.

Ik krijg echter de topboxen niet aan de praat (opstarten stopt bij: box met server verbinden)

Hieruit leidt ik af dat de topbox geen ip toegewezen krijgt of deze niet accepteert.

Kan het zijn dat bij de VLANs de verkeerde DNS servers zijn opgegeven?

 

Kan iemand mij hier op het goede spoor zetten.

 

Als mijn tv’s weer beeld hebben wordt de volgende stap ingezet, het aansluiten van de mijn PFsense firewall.

icon

Beste antwoord door rbode1904 26 februari 2020, 11:07

Dank aan alle meedenkers.

We zijn succesvol.

Mijn Edgerouter-X heeft mijn Huawei HG659 vervangen.

De laatste hobbel was PVID1 ook aan de WAN te hangen.

het ziet er nu als volgt uit:

eth0 VID 300 naar de Huawei voor de vaste telefonie

eth1 WAN PVID 1 VID 300,640

eth2 PVID 640 voor IPTV woonkamer

eth3 PVID 640 voor IPTV slaapkamer

eth4 PVID 1 naar het netwerk (PFSense box)

waar ik kan helpen om dit voor anderen ook mogelijk te maken, zal ik dat graag doen.

Speciale dank aan RobinvanBruggen voor zijn uitleg en configuratiefile.

Bekijk origineel

12 reacties

Reputatie 7
Badge +17

Hi @rbode1904 

Heb je iets aan dit topic?

https://www.robinvanbruggen.nl/2018/07/t-mobile-thuis-fiber-with-edgerouter-x-sfp/

Hi @Waqqas 

Dank voor het toesturen van het topic.

Ik heb het bestudeerd en gebruikt voor mijn edgerouterX.

Dus kleine aanpassingen aangebracht.

Verbinding lijkt goed te zijn want IPTV werkt.

Ik kan alleen het internet niet benaderen.

Waarschijnlijk een firewall rule die niet goed staat of moet worden aangepast.

Is robinvanbruggen ook in de community te bereiken?

 

Hij heeft een mailadres gepost, robin (a) vanbruggenict (.) nl. Zou het hem zelf vragen.

Reputatie 5
Badge +2

@rbode1904 

Beetje dubbelop. pfSense is niet alleen een firewall maar ook een (zeeeer) uitgebreid in te stellen router. Helaas geen plug en play en door de vele mogelijkheden soms niet alles te overzien. Een OpenVpn module kan op pfSense ook geconfigureerd worden. Makkelijk om vanuit een “vreemde” locatie in het thuis netwerk aan te melden. Mij lukt het alleen nog niet goed om een thuisnetwerk brede adblocker in te stellen. Wel wat tijd aan besteed maar “iets” in de browser installeren ging wat makkelijker :rolling_eyes:

Beetje vreemd dat je met de Huawei ondanks de DMZ doorschakeling niet bij je interne servers kan komen.

in pfSense

services => DHCP server van pfSense actief? ipadressen van server(s) fixed instellen

firewall => NAT en daar wat poorten instellen naar de vast ingestelde server adressen.

Maar ….. op al die modems van TmT zit een “eigen” firmware en dat blijkt wel eens rare resultaten op te leveren.

Zelf heb ik een glas aansluiting met alleen internet (geen TV of telefoon) en een Zyxel modem in DMZ en daar werken al mijn gewenste instellingen. De Zyxel wifi/usb/netwerk wordt soms geactiveerd om te testen als er hier op het forum wat andere digitale worstelaars een uitdaging hebben en dat probeer ik dan te tackelen.

@yalerta 

Dank voor het meedenken. Ik ben altijd in voor eenvoudiger oplossingen, maar na lange tijd worstelen met de Huawei probeer ik deze oplossing.

PfSense is tot dusver de beste en gebruiksvriendelijke router/firewall die ik ben tegengekomen.

De Huawei vangt bij alle SSL (Let's Encrypt) installaties de initiële uitvraag af op poort 80.

En omdat de poorten van de Huawei vergrendeld zijn, probeer ik nu de omweg.

Als het lukt met de Edgerouter-X wil ik nog bezien of het geheel over te zetten in naar mijn PFSense box.

 

 

Reputatie 5
Badge +2

Ik heb hier ook een Microtik Hex liggen die de Zyxel mag gaan vervangen. Baas in eigen huis of eigen huisbaas, maar net hoe je het bekijkt. Al een keer aangesloten gehad, niet snel genoeg aan de gang gekregen omdat het “mijn Netflix doet het niet” alarm aansloeg, dus aansluit test maar weer onderbroken en wachten op een gunstiger moment.

Ja, dat wordt dan ook een dubbelop situatie, maar mijn netwerkexpert heeft gezegd dat die opstelling wat voordelen bied.

Vandaag weer aan het testen.

Mijn TV's draaien prima inclusief Netflix en Disney.

Zelfs mijn vaste telefoon doet het via een vid 300 poort naar de Huawei router.

Internet??? Destination NET Unreachable.

iemand een oplossing??

Reputatie 7
Badge +2

@rbode1904 

Weet niet of je eens de “interfaces” sectie uit de config kan posten van de Edge X ter vergelijk?

@Pieter_B 

Pieter, bijgaand de interfaces sectie

interfaces { 
ethernet eth0 {
address 192.168.10.1/24
description "LAN - Management"
duplex auto
speed auto
}
ethernet eth1 {
description "WAN - Mediaconverter"
duplex auto
speed auto
}
ethernet eth2 {
description "IPTV - Living Room"
duplex auto
speed auto
}
ethernet eth3 {
description "IPTV - Master Bedroom"
duplex auto
speed auto
}
ethernet eth4 {
description "LAN - PFSense"
duplex auto
poe {
output off
}
speed auto
}
loopback lo {
}
switch switch0 {
description Switch
mtu 1500
switch-port {
interface eth1 {
vlan {
vid 300
vid 640
}
}
interface eth2 {
vlan {
pvid 640
}
}
interface eth3 {
vlan {
pvid 640
}
}
interface eth4 {
vlan {
pvid 1
}
}
vlan-aware enable
}
vif 1 {
address 192.168.1.1/24
description "Switch - VLAN - Local"
}
vif 300 {
description "Switch - VLAN - Internet"
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
mtu 1500
}
vif 640 {
description "Switch - VLAN - IPTV"
mtu 1500
}
}
}

 

Reputatie 7
Badge +2

@rbode1904

Even kijken hoe ik denk dat het is aangesloten;

eth0 = geen aansluiting (meestal gekozen als WAN ingang internet door de meeste gebruikers)

eth1 = vebonden met Mediaconverter (i.p.v. eth0) => VID 300 & 640

eth 2 = IPTV living room => PVID 640

eth 3 = IPTV bedroom => PVID 640

eth 4 = verbonden met de WAN van de Huawei??? PVID = 1 (VID 300 & 640 ??? )

De Huawei kan alleen maar werken als hij op een uitgang is aangesloten waarop dus blijkbaar meerdere TAGGED VLAN’s aanwezig zijn, want de Huawei zal alleen maar internet geven als er een VLAN 300 op die lijn aanwezig is. En zoals je aangeeft, werkt internet wel via je mobiel .. maar dan via de Huawei

NOTE: PVID poort is UNTAGGED & VID poort is TAGGED

Ik denk dat in deze video een beetje naar voren komt waar je probleem zou kunnen liggen.

Nog iets, het IP adress onder interfaces => eth0 .. hoe en waarom is die ontstaan?

EDIT nog een video Quick Configs Ubiquiti - VLANs & Switch Interface

EDIT 2: Nog iets gevonden en het kan zijn dat je DNS association incorrect is, dus aan de verkeerde intrface is gekoppeld zie dit filmpje (9 min en later). Als je DNS verwijst denk ik naar gewoon switch0.

@Pieter_B 

eth0 = apart subnet 192.168.10.1 zodat ik mijzelf niet kan buitensluiten.

eth1 = vebonden met Mediaconverter (i.p.v. eth0) => VID 300 & 640

eth 2 = IPTV living room => PVID 640

eth 3 = IPTV bedroom => PVID 640

eth 4 = LAN voor de overige switches en apparatuur.

Huwaei is in deze situatie niet in gebruik.

Als test op de et4 een VID300 signaal gezet naar de Huawei, dan werkt vaste telefonie ook nog.

De meeste instructievideos gaan uit van verschillende subnetten op de diverse VLANs en maken de situatie daarmee moeilijk vergelijkbaar.

Destination NET Unreachable. : wat moet ik doen om te zorgen dat VLAN1 ook het internet kan bereiken??

 dns { 
forwarding {
cache-size 1500
listen-on switch0.1
listen-on switch0.300
listen-on switch0.640
listen-on switch0
options localise-queries
options expand-hosts
options bogus-priv
options domain-needed
}
}

DNS is ook conform RobinvanBruggen. om te testen heb ik switch0 verwijderd maar dat maakt geen verschil.

Dank aan alle meedenkers.

We zijn succesvol.

Mijn Edgerouter-X heeft mijn Huawei HG659 vervangen.

De laatste hobbel was PVID1 ook aan de WAN te hangen.

het ziet er nu als volgt uit:

eth0 VID 300 naar de Huawei voor de vaste telefonie

eth1 WAN PVID 1 VID 300,640

eth2 PVID 640 voor IPTV woonkamer

eth3 PVID 640 voor IPTV slaapkamer

eth4 PVID 1 naar het netwerk (PFSense box)

waar ik kan helpen om dit voor anderen ook mogelijk te maken, zal ik dat graag doen.

Speciale dank aan RobinvanBruggen voor zijn uitleg en configuratiefile.

Reageer