Beantwoord

Blokkade tussen T-Mobile Thuis IP adressen

  • 12 november 2018
  • 22 reacties
  • 797 Bekeken

Ik post dit topic na aanleiding van Ticket#2018110211017431, welke niet serieus genomen wordt. Buiten het feit dat ik af en toe bepaalde websites niet kan benaderen (https://www.vvosc.nl) is er ook een blokkade actief tussen verschillende T-Mobile thuis klanten.

Zo kunnen mijn ouders (85.146.149.111) en mijn broertje (85.146.151.31), beide T-Mobile Thuis klanten, geen backups maken naar mijn IP adres 85.146.146.110.

Ook wordt er op Tweakers =85.x.x.x&fbclid=IwAR18WUhkhqLgRUk__e5w9g0TyfYCWuNdShbY4lCVqOLUN9Pmy4dSoFeFKZY]wat meldingen gemaakt van dit probleem. Ik hoop dat dit nu opgepakt wordt en jullie mij kunnen helpen, anders zal ik helaas 3 abonnementen moeten opzeggen.

Alvast bedankt,
Sander de Wildt
icon

Beste antwoord door Brian 22 november 2018, 11:10

Hi Sander, onze netwerkpartner Huawei heeft vannacht aanpassingen gedaan aan het netwerk (dus toch), we hebben het vanochtend getest en jullie zouden nu verbinding moeten kunnen maken! Laat nog even weten of alles nu inderdaad naar behoren werkt!
Bekijk origineel

22 reacties

Reputatie 6
Badge +11
Dit lijkt op het regelmatig voorkomende probleem, n.l. dat internetverkeer m.b.t. de T-Mobile Thuis infrastuctuur niet aankomt of niet wordt doorgelaten. Of er sprake is van een blokkade weet ik niet, mijn vermoeden is eerder dat routing problemen zijn. Vaak werkt het wel als er een toalla ander netwerkverbinding bij betrokken wordt, dus een ander provider, VPN of dedicated server in een datacenter o.i.d.
Maar hoe werkt die backup?
Als je duidelijk kan maken dat er geen TCP dataverbinding mogelijk is van b.v. 85.146.151.31:1234 naar 85.146.146.110:1234 (dus in jouw modem een portforward m.b.t. poort 1234) dan heb je een punt en blijft T-Mobile in gebreke.
Reputatie 6
Badge +2
@sanderdw
Zoals @tmoesel ook al aangeeft, komt er soms een adres bovendrijven die onbereikbaar blijkt.
De door jou aangegeven vvosc is hier gewoon bereikbaar op het glasnetwerkt Amsterdam.

Heb ook even gekeken wat er zoals draait achter/op je modem/router en dit is het resultaat van de responce



Zoals je ziet zijn er responces op poort 80 (webserver) en poort 443 (https), dus er draait wel degelijk iets bij jou.
Allereerst dank voor jullie reacties.

@Pieter_B vvosc.nl was een voorbeeldje en is niet zozeer 'het' probleem (aangezien dat voornamelijk extern geblokt wordt). Ik heb daarvoor contact opgezocht met dat hosting bedrijf en zij hebben de blokkade opgelost. Het lijkt in iedergeval sporadisch voor te komen dat ik een bepaald externe (dus buiten T-Mobile Glas) ip/website niet kan benaderen wat vervelend is maar te overzien (wellicht zit ik in een 'malafide' IP range die overgenomen is door T-Mobile).

Betreft mijn kernprobleem: Ja er draait zeker iets bij mij dat is ook de bedoeling. Alleen wat bij mij draait is dus niet te bereiken vanuit (bepaalde?) andere T-Mobile glas klanten zoals mijn ouders (85.146.149.111) en mijn broertje (85.146.151.31). Extern is deze wel te benaderen, bijvoorbeeld vanuit mijn telefoon of bij mijn vriendin thuis. Andersom geldt het probleem ook, dus ik kan ook geen dingen bereiken bij mijn ouders. Bij mijn broertje draait niets dus om dat te testen zou ik er iets neer moeten zetten.

@tmoesel Ja het kan ook zeker een routering probleem zijn ipv een blokkade, dat is voor mij natuurlijk lastig te beoordelen. Routering probleem lijkt idd wel wat aannemelijker aangezien ik vermoed dat dit niet met opzet is gedaan.

Ik kan zeker aangeven dat bepaalde poorten niet werken, maar het makkelijkste voorbeeld is de standaard ssl poort 443 die bij mij en mijn ouders gewoon open staat. Vanuit internet (dus buiten T-mobile glas) is eenvoudig te zien dat dit ook klopt. Vanuit mij naar mijn ouders en ouders naar mij is er gewoon geen verkeer mogelijk.
Reputatie 6
Badge +11
@sanderdw Je zou eens een traceroute kunnen doen zowel UDP als ICMP gebaseerd. UDP gaat bij mij vaak niet (4GvT) en ICMP ontbreken er een aantal hops m.b.t. het interne TMO NL netwerk.
Eerdere traces bij een dergelijk probleem m.b.t. TMT lieten locale IP adressen zien (dus 10.x.x.x ) wat NAT betekend. Dat kan een reden zijn dat routering op ongebruikelijke poorten niet werkt omdat portmapping maar beperkt is en niet uitputtend 64k in aantal is voor alle in gebruik zijnde TMT IP adressen. Dit is theorie, maar past nog steeds voor een aantal gemelde problemen.
@tmoesel Heb even verschillende traces uitgevoerd, op Windows en Linux. Mijn kennis houdt bij UDP vs ICMP een beetje op maar volgens mij is dit hetgene wat je vraagt?

Windows ouders (ICMP?):
code:
tracert dewildt.dsmynas.net

Tracing route to dewildt.dsmynas.net [85.146.149.111] over a maximum of 30 hops:

1 1 ms 1 ms 1 ms Vigor.router undefined92.168.100.1]
2 * * * Request timed out.
3 * * * Request timed out.
4 * * * Request timed out.
5 * * * Request timed out.
6 * * * Request timed out.
7 * * * Request timed out.
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
etc



Windows broertje(ICMP?):
code:
tracert 85.146.151.31

Tracing route to 31-151-146-85.ftth.glasoperator.nl [85.146.151.31]
over a maximum of 30 hops:

1 1 ms 1 ms 1 ms Vigor.router undefined92.168.100.1]
2 * * * Request timed out.
3 * * * Request timed out.
4 * * * Request timed out.
5 * * * Request timed out.
etc



Windows test tweakers.net:
code:
tracert tweakers.net

Tracing route to tweakers.net undefined.239.154.31] over a maximum of 30 hops:

1 1 ms 1 ms 1 ms Vigor.router undefined92.168.100.1]
2 3 ms 3 ms 3 ms 1-144-146-85.ftth.glasoperator.nl [85.146.144.1]
3 3 ms 4 ms 4 ms 10.10.10.205
4 3 ms 3 ms 3 ms 10.10.10.197
5 6 ms 6 ms 7 ms et-0-0-0-0.eun-spine-01.true.nl [87.233.21.1]
6 4 ms 7 ms 6 ms et-0-0-48-0.eun-leaf-03.true.nl [87.233.21.16]
7 4 ms 15 ms 16 ms 87.233.231.90
8 4 ms 4 ms 4 ms tweakers.net undefined.239.154.31]
Linux ouders (UDP?):
code:
traceroute dewildt.dsmynas.net
traceroute to dewildt.dsmynas.net (85.146.149.111), 30 hops max, 60 byte packets
1 Vigor.router (192.168.100.1) 0.333 ms 0.230 ms 0.294 ms
2 * * *
3 * * *
4 * * *
5 * * *
etc




Linux broertje (UDP?):
code:
 traceroute 85.146.151.31
traceroute to 85.146.151.31 (85.146.151.31), 30 hops max, 60 byte packets
1 Vigor.router (192.168.100.1) 0.366 ms 0.206 ms 0.284 ms
2 * * *
3 * * *
4 * * *
5 * * *
etc
Reputatie 6
Badge +2
@sanderdw

code:
curl -s -w '\nLookup time:\t%{time_namelookup}\nConnect time:\t%{time_connect}\nPreXfer time:\t%{time_pretransfer}\nStartXfer time:\t%{time_starttransfer}\n\nTotal time:\t%{time_total}\n' -o /dev/null 85.146.146.110



Result:
code:
Lookup time:	0,000017
Connect time: 0,007470
PreXfer time: 0,007483
StartXfer time: 0,131075

Total time: 0,131154



code:
curl -s -w '\nLookup time:\t%{time_namelookup}\nConnect time:\t%{time_connect}\nPreXfer time:\t%{time_pretransfer}\nStartXfer time:\t%{time_starttransfer}\n\nTotal time:\t%{time_total}\n' -o /dev/null dewildt.dsmynas.net

Result:
Lookup time: 0,060442
Connect time: 0,068305
PreXfer time: 0,068357
StartXfer time: 0,194232

Total time: 0,194313



code:
curl -s -w '\nLookup time:\t%{time_namelookup}\nConnect time:\t%{time_connect}\nPreXfer time:\t%{time_pretransfer}\nStartXfer time:\t%{time_starttransfer}\n\nTotal time:\t%{time_total}\n' -o /dev/null 85.146.149.111

Lookup time: 0,000014
Connect time: 0,008061
PreXfer time: 0,008074
StartXfer time: 0,132646

Total time: 0,132738




De reactie vanuit je broer zijn Ip is inderdaad nill.

Blijkbaar heeft het hiervoor wel gewerkt

EDIT

Neem aan dat het een synology NAS is, want de mastername is dan wel dsmynas, maar de real name is synology
Hoe heb je je external access geregeld?

http://dewildt.dsmynas.net ====>>> Google.com
https:// dewildt.dsmynas.net =====>>>> Google.com

Heb je ergens white list aangelegd, want de DNS service (dsmynas) die tussen al je gebruikers en je Ip zitten komen uit op .... Google.com
@Pieter_B Ja klopt, op 17 oktober heeft alles nog gewerkt en op 19 oktober kreeg ik de eerste fout binnen. Ik heb in die tijd ook een nieuw adres gekregen (85.145.51.194->85.146.146.110) en mijn ouders ook (85.145.57.130 -> 85.146.149.111).
Reputatie 6
Badge +2
@sanderdw



Staat dit dan nog wel goed????

EDIT

Neem aan dat het een synology NAS is, want de mastername is dan wel dsmynas, maar de real name is synology
Hoe heb je je external access geregeld?

http://dewildt.dsmynas.net ====>>> Google.com
https:// dewildt.dsmynas.net =====>>>> Google.com

Heb je ergens white list aangelegd, want de DNS service (dsmynas) die tussen al je gebruikers en je Ip zitten komen uit op .... Google.com


Ja er staat in beide gevallen een Synology maar gebruik eigenlijk een handmatige DNS die ik zelf instel: sanwil.net (bij mij) & dewildt.sanwil.net (mijn ouders ip). Het google.com verhaal is een simpele .htacces redirect die op het hoofddomein staat (staat dus los van resolving).

Je kan bijvoorbeeld gewoon naar https://sanwil.net/check/check.html gaan waarbij je een stukje tekst ziet, maar dit lukt bijvoorbeeld niet vanuit mijn ouders omdat hij het adres al niet vind.

@sanderdw



Staat dit dan nog wel goed????


Ja dat staat er dus los van, dat is een DDNS service waarmee je aangeeft aan Synology.com dat hij de A record van bijv dewildt.dsmynas.net automatisch update.
Reputatie 6
Badge +2
@sanderdw

Je kan bijvoorbeeld gewoon naar https://sanwil.net/check/check.html gaan waarbij je een stukje tekst ziet, maar dit lukt bijvoorbeeld niet vanuit mijn ouders omdat hij het adres al niet vind.


Deze kan ik dus inderdaad netje bekijken vanuit mijn locatie binnen het netwerk (AMS)
Dat zou dus vanuit je ouders ook gewoon moeten kunnen, voelt dus inderdaad aan als een routing probleem.

Zal denk ik toch door de IT-afdeling van T-Mobile naar moeten worden gekeken bij welke hop het fout gaat.
@Sander Kan jij zorgen dat dit op één of andere manier bij IT komt?
Reputatie 6
Badge +11
De traceroute is compleet leeg dus. Onder linux een ICMP traceroute doe je met:

code:
traceroute --icmp hostname_of_ip_adres


Maar waarschijnlijk levert dat ook niks op.
@tmoesel Nogmaals een trace via dat specifieke commando:
code:
pi@hassio2:~ $ sudo traceroute --icmp 85.146.149.111
traceroute to 85.146.149.111 (85.146.149.111), 30 hops max, 60 byte packets
1 Vigor.router (192.168.100.1) 0.319 ms 0.245 ms 0.237 ms
2 * * *
3 * * *
4 * * *
5 * * *
etc



code:
pi@hassio2:~ $ sudo traceroute --icmp 85.146.151.31
traceroute to 85.146.151.31 (85.146.151.31), 30 hops max, 60 byte packets
1 Vigor.router (192.168.100.1) 0.424 ms 0.308 ms 0.272 ms
2 * * *
3 * * *
4 * * *
5 * * *
etc



tweakers.net
code:
pi@hassio2:~ $ sudo traceroute --icmp tweakers.net
traceroute to tweakers.net (213.239.154.31), 30 hops max, 60 byte packets
1 Vigor.router (192.168.100.1) 0.283 ms 0.258 ms 0.270 ms
2 * * *
3 * * *
4 * * *
5 et-0-0-0-0.eun-spine-01.true.nl (87.233.21.1) 7.108 ms 7.051 ms 6.995 ms
6 et-0-0-48-0.eun-leaf-03.true.nl (87.233.21.16) 11.749 ms 8.664 ms 8.611 ms
7 87.233.231.90 (87.233.231.90) 10.326 ms 6.708 ms 6.668 ms
8 tweakers.net (213.239.154.31) 4.685 ms 4.933 ms 4.896 ms



Dus hetzelfde resultaat (al zie ik op windows de 10.10.10.* hops er tussen zitten bij de tweakers test.
Reputatie 6
Badge +2
@sanderdw

Inderdaad de traceroute --icmp blijft ook behoorlijk leeg, was gestopt na 34.

Een wilde gok hoor, maar probeer het eens vanuit een VPN omgeving als dat mogelijk is.

Reputatie 6
Badge +2
@sanderdw


REF: https://mxtoolbox.com/problem/dns/dns-primary-server-listed-at-parent

Bovenstaande output voor zowel http als https met dewildt.dsmynas.net
@sanderdw



REF: https://mxtoolbox.com/problem/dns/dns-primary-server-listed-at-parent

Bovenstaande output voor zowel http als https met dewildt.dsmynas.net


Je bent hiermee de DNS structuur van dsmynas.net aan het testen, dit is van Synology en heb ik geen invloed op. Dit probleem is niet DNS gerelateerd, sterker nog, ik had nooit DNS adressen moeten noemen want dat wekt alleen maar misvattingen op. Waardeer natuurlijk wel je hulp 🙂.

@sanderdw



Inderdaad de traceroute --icmp blijft ook behoorlijk leeg, was gestopt na 34.

Een wilde gok hoor, maar probeer het eens vanuit een VPN omgeving als dat mogelijk is.


@Pieter_B Vanuit Google Cloud:
code:
info@unifi:~$ sudo traceroute --icmp 85.146.149.111
traceroute to 85.146.149.111 (85.146.149.111), 30 hops max, 60 byte packets
1 72.14.238.115 (72.14.238.115) 5.219 ms 5.233 ms 5.437 ms
2 216.239.40.134 (216.239.40.134) 5.431 ms 5.606 ms 5.692 ms
3 108.170.241.164 (108.170.241.164) 6.136 ms 7.453 ms 7.460 ms
4 80.249.211.184 (80.249.211.184) 8.176 ms 8.178 ms 8.178 ms
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *





en

code:
info@unifi:~$ sudo traceroute --icmp 85.146.151.31
traceroute to 85.146.151.31 (85.146.151.31), 30 hops max, 60 byte packets
1 72.14.234.215 (72.14.234.215) 5.163 ms 5.452 ms 5.448 ms
2 209.85.253.112 (209.85.253.112) 5.165 ms 5.164 ms 5.440 ms
3 108.170.241.166 (108.170.241.166) 5.439 ms 5.903 ms 5.904 ms
4 ams-ix1.glasoperator.nl (80.249.211.171) 6.141 ms 6.224 ms 6.496 ms
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *
Reputatie 7
Badge +7
Hi allemaal, goed om te zien dat er zo goed meegedacht wordt! @sanderdw In jouw specifieke geval heeft onze netwerkpartner al onderzoek gedaan, en zij geven aan dat er geen belemmeringen op het netwerk zijn waardoor je geen verbinding zou kunnen maken. De volgorde is normaal gesproken Klantenservice (of in dit geval social media/Community) > Back office > onze netwerkspecialisten > de netwerkpartner. Deze laatste kan alles netwerk breed bekijken maar heeft dus niets kunnen vinden. Zou je mij via een privéberichtde klantnummers van je ouders en je broertje door willen sturen? Dan laat ik mijn collega's er met de informatie in dit topic opnieuw naar kijken!
@Brian Ik heb de informatie in een privé bericht verstuurd, ben benieuwd. Zeker omdat verschillende tests wel uitwijzen dat dit buiten deze t-mobile glas adressen wel gewoon werkt (en ook allemaal gewerkt heeft voor 17 oktober).
Reputatie 7
Badge +7
Hi Sander, onze netwerkpartner Huawei heeft vannacht aanpassingen gedaan aan het netwerk (dus toch), we hebben het vanochtend getest en jullie zouden nu verbinding moeten kunnen maken! Laat nog even weten of alles nu inderdaad naar behoren werkt!
Het gaat er om dat het uiteindelijk opgelost is, dat is het belangrijkst. Bedankt voor de info en ga het vandaag gelijk checken.
Het werkt allemaal weer, gelukkig! Heb alleen nog niet kunnen controleren of het vanuit/terug mijn broertje werkt maar dat geloof ik dan wel.
@tmoesel @Pieter_B bedankt voor jullie aandacht en hulp!

@Brian wel jammer dat het zoveel moeite gekost heeft om in ieder geval duidelijk te krijgen dat het probleem bij jullie lag. Hopelijk gaan jullie daar nog iets mee doen.

Reageer