Beantwoord

Eigen VOIP verbinding

  • 24 mei 2019
  • 18 reacties
  • 775 Bekeken

Ik kom van Telfort en die hadden een modem dat mij toeliet om een VOIP verbinding op te zetten. Nu ben ik bij T-Mobile en hun modem HG659 blokkeert die mogelijkheid. Wat moet ik doen om die mogelijkheid te activeren?
icon

Beste antwoord door Pieter_B 25 mei 2019, 10:37

Hallo @HAL Berkers

Denk dat er iets meer uitleg nodig is bij het verhaal "VoIP opzetten".

Heb je een router (bijv. FritzBox) waarin je een verbinding probeert te maken met een VoIP provider,of heb je een losse ATA?

Als je gebruik maakt van een externe VoIP provider, kun je poort 5060 niet gebruiken.
Dit, omdat TMT in zijn eigen modem hierop werkt met VoIP.

Daar is bij veel VoIP providers al een oplossing voor, om een alternatieve poort voor het registreren aan te bieden. Je zal dan even moeten aankloppen bij je VoIP provider voor deze alternatieve poort .. als hij die heeft.
Bekijk origineel

18 reacties

Reputatie 3
Badge +2
Lees deze thread: https://community.t-mobile.nl/t-mobile-thuis-internet-492/welke-poorten-worden-geblokkeerd-of-zijn-gereserveerd-297428 en dan vooral wat Pieter B zegt over SIP ALG
Mijn indruk is dat in de nieuwere HG659 de firmware van T-mobile heeft en niet de originele. In de afbeelding heb ik een voorbeeld van de originele software. Dqaar is wel de mogelijkheid gegeven om te editten.

Reputatie 7
Badge +10
Klopt op modems van T Mobile draait T Mobile firmware. hierop zijn sommige instellingen uitgeschakeld. je heb dus niet volledige rechten op het modem. het modem is niet in bridge mode te plaatsen. standaard voip word gebruikt door het modem zelf.
Reputatie 6
Badge +2
Hallo @HAL Berkers

Denk dat er iets meer uitleg nodig is bij het verhaal "VoIP opzetten".

Heb je een router (bijv. FritzBox) waarin je een verbinding probeert te maken met een VoIP provider,of heb je een losse ATA?

Als je gebruik maakt van een externe VoIP provider, kun je poort 5060 niet gebruiken.
Dit, omdat TMT in zijn eigen modem hierop werkt met VoIP.

Daar is bij veel VoIP providers al een oplossing voor, om een alternatieve poort voor het registreren aan te bieden. Je zal dan even moeten aankloppen bij je VoIP provider voor deze alternatieve poort .. als hij die heeft.
Dank voor de inbreng. Mijn VOIP-provider heeft geen alternatieve poort. Ik ga eens op onderzoek of een ATA met dit modem werkt ( HG659 )

Reputatie 6
Badge +2
@HAL Berkers

Heb hier zelf eens gekeken of de HG659 mijn ATA N300A IP kastje zou willen registeren bij mijn providers, kan kort zijn ... op de default poort 5060 niet, maar ook een alternatieve poort 5070 bij mijn providers wil de HG659 niet echt meewerken.

Vroeger ook een Huawei gehad en met die had ik ook in het begin problemen om mijn VoIP provider geregistreerd te krijgen. De oplossing bij die Huawei was toen SIP ALG uit te zetten.
Zou mij niet verbazen dat bij deze Huawei hetzelfde probleem zich voordoet, alleen kan je in dit modem de SIP ALG niet uitzetten.

Daarintegen het nieuwe Zyxel modem wat nieuwe klanten krijgen sinds medio mei, daar heb je wel weer controle over deze SIP ALG



Alleen heb ik hem hier aan en uit gezet, maar de registratie van mijn ATA is en blijft geen probleem.


Hmm, kom nu net een post tegen dat ergens verborgen in de Huawei toch SIP ALG beschikbaar zit .... even onderzoeken ....

EDIT 14.58



Hij heeft inderdaad dus wel die optie om SIP ALG aan of uit te zetten, maar de registratie bij de providers blijft nog steeds niet gelukken welke setting ik ook gebruik.

Sluit ik daarna de Zyxel weer aan, dan gaat de registratie gelijk.

Een optie is om een eigen modem te gaan gebruiken, daar is een topic voor aangemaakt
Reputatie 6
Badge +2
Hier nog iets meer informatie over SIP ALG en de slechte implementatie in heel veel commerciele modems.
Met dank aan @tmoesel uit dit topic
Ik ben nu heel benieuwd welk modem dat was kan bijna alleen de Zyxel zijn geweest.
Poort 5060 is ook bij Telfort geblokkeerd voor de eigen voip dienst in de Experia's
Mijn oude modem was een Zyxel. VOIP werkte perfect, bellen en gebeld worden.
Reputatie 6
Badge +2
Het is dus het tweede Huawei product wat ik heb/had, dat hetzelfde probleem laat zien.
Alleen was het bij die andere Huawei op te lossen door SIP ALG er tussenuit te halen door het op disable te zetten.

De soft client krijgt men achter een Huawei dus blijkbaar niet aan de praat, dat dus wijzt op een brakke impementatie van de SIP ALG forwarding.

Ga de Zyxel er even tussenuit gooien en nog wat meer klooien om te kijken of ik iets werkend kan krijgen, mocht dat zo zijn hoor je dat zeker ... T.B.C.
Reputatie 6
Badge +2
@HAL Berkers

Goed na veel testen port fowarding diverse ALG settings ON/OFF, werkt er eigenlijk maar 1 manier.
De registratie lukt alleen maar als je de ATA in de DMZ brengt, dan bijpassed hij alle restricties.

Dus sluit je VoIP kastje rechtstreeks aan op LAN 2 van de Huawei en ga naar Internet - Internet Security.
Open de DMZ sectie en selecteer nu jouw Host address (MAC) van jouw VoIP kastje en Enable DMZ.
Klik vervolgens op Save en ... nu zou het moeten werken.

Dank voor de heldere work-out. Ga volgende week kijken of ik er iets mee kan.
Reputatie 2
Ik heb ook een voipbuster account dat via een Gigaset C 530 achter de Draytek had hangt. Maar...... om mijn voipbuster account te gebruiken, kan ik alleen voipdiscount.com gebruiken!

Dus domein voipdiscount.com
sip.voipdiscount.com
poort: 5060 (ook al zegt men dat het niet kan)


En drie andere accounts werken met 'use DHCP option 120 "SipServer". Dat laatste klinkt me als magie in de oren maar het werkt wel.
En nee ik heb niet per ongeluk toch een voipdiscount account.
Reputatie 6
Badge +2
@lemonkid

Inderdaad achter de Draytek is het bij mij ook nooit een probleem geweest om mijn eigen VoIP ATA te gebruiken, zelfs op poort 5060.
De problemen spelen rond de Huawei, die blijkbaar slordig omgaat met andere SIP's dan zijn eigen.

Had je optie met "Use DHCP Option 120 "SIP Server" ook nog even getest via de Huawei, maar ook dan werkt de ATA nog steeds niet.
Reputatie 2
En slaan met een hamer? helpt dat ook niet?
Reputatie 6
Badge +2
Evewn @lemonkid, ik zit niet met het probleem, maar we zoeken naar een oplossing voor @HAL Berkers.

Zelf heb ik hier het nieuwe Zyxel modem, wat zonder problemen met de ATA samenwerkt.
Iemand ervaring met deze ATA in combinatie met de HG659 ?: GRANDSTREAM HANDYTONE HT801
Reputatie 6
Badge +2
@HAL Berkers , heb je iets aan deze YT instructie voor de setup?

Wat bedoel je nu met in combinatie met de HG659?
Heb hier zelf de N300A IP ATA en deze kreeg ik alleen maar aan de praat op een HG659 door hem op LAN 2 (of LAN 1) aan te sluiten en hem dan in een DMZ te plaatsen.

Reageer