Beantwoord

Ik krijg geen IP-adres achter switch


  • is een Top Poster
  • 6 reacties
Hallo,

Ik heb sins kort T-Mobile home Fibre. Ik heb best wel wat netwerk apparatuur thuis (PC's printer etc)
dus 2 LAN poorten is niet genoeg om alles aan te sluiten. Ik heb op ieder LAN poort een switch aangesloten en daar achter de pc's en de rest.
Maar ik krijg een IP van de DHCP achter de switch wel als ik direckt mijn laptop op de Draytek Vigoor 2132F aansluit.
Wat kan ik doen en hoe?
icon

Beste antwoord door Brian 10 januari 2019, 14:34

Hi @Moony we zijn altijd bereid om met je mee te denken maar we kunnen geen ondersteuning bieden op het gebruik van eigen apparatuur. Het is onmogelijk om kennis te hebben van alle switches, routers en andere netwerkapparatuur dus de klantenservice kan je hier inderdaad niet altijd mee helpen. Maar we hebben hier op de Community een aantal knappe koppen en vaak komen we er uiteindelijk wel uit! 😉

Bekijk origineel

25 reacties

Reputatie 7
Badge +15
Dat is wel heel apart Moony,

Welk type switch heb je?
En heb je op beide lan poorten hetzelfde type switch?
En is de laptop de enige die geen IP adres krijgt achter de switch?
  • Ik heb Netgear en een linksys switchen unmanaged
  • Nee verschillende
  • Nee ik heb 2pc 's van de kids en nog andere apparatuur die gebruik maakt van Internet.
Mijn opstelling thuis werkte altijd bij Ziggo
Reputatie 5
Badge +2
Hallo @Moony ,

Met de 2 LAN poorten bedoel je LAN 1 en LAN 2 neem ik aan en niet LAN 3 of LAN 4 (alleen TV)

Type switch zou niet uit mogen maken, zijn in principe vrij domme dingen.
Een soort van doorgeefluik naar de juiste onderdelen die aangesloten zijn.

Maar ik krijg een IP van de DHCP achter de switch wel als ik direckt mijn laptop op de Draytek Vigoor 2132F aansluit.



Deze zin snap ik niet helemaal.
Je zit op een switch aangesloten (achter de switch) en tevens direct ook nog een op de Draytek?

Of moet ik lezen dat de DHCP server pas IP's gaat uitdelen in je netwerk als jij je laptop direct aansluit op de Draytek?

Voor alle duidelijkheid, LAN 1 & 2 voeren internet en geen TV en LAN 3 & 4 voeren TV maar geen internet.

Nog iets, er zijn gen apparaten met een Fixed IP op de router/switch aangesloten?
Als dat zo is, zouden ze wel eens in het verkeerde subnet kunnen hangen.
Hallo Pieter,
Dank je voor reactie.

Deze zin snap ik niet helemaal.
Als ik mijn laptop direct op de Draytek LAN poort 1 of 2 dan krijg een IP vanaf de DHCP en ik kan gewoon de internet op.
Als ik ipv mijn laptop een (domme) switch aansluit op de Draytek LAN poort 1 of 2 dan krijg en mijn laptop op de switch, dan krijg ik geen IP vanaf de DHCP server (Draytek).
Ook als ik mijn laptop achter de switch een Fix ip geef in de zelfde range kan ik niet op de internet.

Ik heb T-mobile gebeld en ze zeggen we hebben geen oplossing hiervoor maar ze geven ook geen admin rechte op de modem en config willen ze ook niet aanpassen.
Reputatie 4
Badge +2
Hallo Moony,

Welke typen switches van linksys en netgear zijn het?
Ik neem aan dat je het modem al een fabrieks reset hebt gegeven e.d. ?

Mvg.
Marcel
Reputatie 5
Badge +2
@Moony

Draytek => Laptop = internet OK
Draytek => switch => Laptop = geen internet

De switch is in deze dan natuurlijke het enige wat er tussen is gekomen.
Nu neem ik aan dat je al eens met je switches bezig bent geweest om even om te ruilen, om te kijken of die betreffende switch het probleem zou kunnen zijn.

Die switches, zijn dat wel van het managed type (iets slimmer) of inderdaad gewoon switches?

Deze laptop heeft neem ik aan ook Wifi, doet die het wel gewoon of is dat ook niet goed?
Pieter_B schreef:

@Moony

Draytek => Laptop = internet OK
Draytek => switch => Laptop = geen internet

Die switches, zijn dat wel van het managed type (iets slimmer) of inderdaad gewoon switches?

Deze laptop heeft neem ik aan ook Wifi, doet die het wel gewoon of is dat ook niet goed?


Ja laptop heeft ook wifi deze werkt.

Hallo Pieter,

De switchen zijn unmanaged en deze werk goed ik heb deze getest door bijv mijn printer en laptop een vaste ip adres te geven.
Reputatie 5
Badge +2
@Moony

Zou ik het partnummer van deze switches eens mogen weten.
Je had een Netgear en een Linksys en daar dan het partnummer / typenummer van.
Wil toch eens in detail weten wat daarin fout zou kunnen gaan.
Reputatie 3
Badge +2
Hey @Moony, zeer vreemd! Normaal gesproken is het een kwestie van plug and play. En is een switch een "doorgeefluik". Ben ook wel benieuwd naar het typenummer.
Ik wil even inhaken op dit topic, omdat ik hetzelfde probleem ervaar. Als ik de meegeleverde wifi-repeater in poort 1 of 2 op ons Huawei modem steek werkt alles perfect, maar zodra ik de switch in poort 1 of 2 plug en de repeater daar in dan valt regelmatig de wifi-verbinding weg als ik met de repeater verbonden ben. Mijn apparaten geven aan geen ip-adres te krijgen dan.

Mijn switch is een simpele 8-poorts Zyxel 8-poort (GS-108S v2), waar verder niets aan in te stellen is.
@Moony, is jouw probleem inmiddels opgelost of ervaar je dit nog steeds?
Reputatie 5
Badge +2
@Duncankrebbers

Het probleem is dat de switch denkt in MAC-adressen en er per poort maar 1 MAC adres kan zijn.
Nu hangt je repeater met een MAC adres aan je switch, maar je repeater heeft de functie van een access point (AP).
De switch moet dus nu wisselende MAC adressen gaan verwerken als er dus meer clients op de repeater komen .. maar de switch kent maar 1 MAC adres .. die van de aangesloten repeater.
Er ontstaat een conflict, omdat je repeater a.h.w. de door jouw in gebruik zijnde IP nogmaals gaat uitdelen aan de andere client .. als je even niet oplet.
De DHCP server heeft dus ook maar 1 IP adres uit te delen aan het MAC adres van je repeater .... en hier gaat het dus fout.

Een stelregel is, dat een AP altijd op een component moet worden aangesloten die routing capabilities heeft (DHCP) en een gewone switch heeft dat dus niet.
@Pieter_B

Dankjewel voor je uitleg! Zonder de technische details te kennen vermoedde ik al zoiets en had ik de repeater al rechtstreeks op het modem ingeplugd, met de switch in de andere poort. Dat heeft sindsdien niet meer voor problemen gezorgd.

Ik ben aan het kijken naar een nieuwe switch omdat ik wat poorten tekort kom, en ik overweeg ook een extra bekabeld AP op de eerste etage omdat de Wifi het niet tot daar red nu. Omdat ik dan een poort op het modem tekort kom is het van belang dat de switch de juiste is; is er hier een switch of merk dat vaak wordt aangeraden? Ik weet dat de installatie-monteur het over de Netgear GS-serie had, maar zie daarbij niks over DHCP vermeld staan.
Reputatie 5
Badge +2
@Duncankrebbers

Moet mijn opmerking iets aanpassen v.w.b. AP's lees ik nu zelf bij nader inzien, is niet helemaal de waarheid. Denk dat de oorzaak anders ligt, het verhaal van mij hiervoor is voor een andere situatie .. niet de jouwe dus.

Een repeater is normaal gesproken niet via een LAN aangesloten en werkt alleen maar met Wifi. Dus Wifi in -> Wifi out (repeating same channel), dus waarom die LAN kabel?
Een repeater krijgt wifi signaal van je router of een ander access point, dus mijn vraag is dus nu .. wat heb jij .. een AP (LAN aangesloten) of een echte repeater?
Zit er op die repeater een LAN aansluiting, is dat eerder een LAN uitgang dan een LAN ingang zoals jij nu hebt aangesloten. En dat zou dus dan ook een oorzaak kunnen zijn van jouw probleem.

Wat is het type/model van dat betreffende toestel?

Een echt AP achter een switch zou op zich geen probleem mogen zijn.

V.w.b. aanschaffen van een switch, inderdaad lees je veel Netgear of TP-Link levert hetzelfde product in eenzelfde prijsrange. Geen van beide leveren een slecht product, is meer een voorkeur.
@Pieter_B Ik heb het over de Fritz Wlan Repeater 1750e die vanuit T-mobile geleverd is. Hij staat in LAN-bridge modus en is op zolder bekabeld aangesloten, nu rechtstreeks op LAN1 in het modem, volgens instructies van de monteur. Dat werkt perfect, waar er voorheen helemaal geen wifi te ontvangen was op zolder heb ik nu een sterk signaal. Mijn apparaten wisselen ook naadloos tussen wifi van het modem en wifi van de repeater.

Maar als ik dus de repeater in de switch plug dan gaat het een tijdje goed, totdat opeens alle apparaten de verbinding verliezen en aangeven geen ip-adres meer te ontvangen.
Reputatie 5
Badge +2
@Duncankrebbers

Zie dat dit toestel 2 modes van bedrijf heeft, Wifi Bridged (Repeater mode) of LAN Bridged (Extender mode).
Neem aan dat je operating mode hebt omgezet naar LAN Bridged bij het gebruik als Extender (AP).
Als je hem gebruikt als repeater klopt mijn verhaal, dat je LAN dan een uitgaande LAN is en als je hem gebruikt als extender is de LAN een ingang geworden.

REF: Video

Die staat inderdaad goed ingesteld! Thanks voor je reacties.

Reputatie 5
Badge +2
@Duncankrebbers

Het plaatje doet vermoeden dat hij ook alleen maar direct op een router kan worden aangesloten.
Als ik een andere video kijk, stelt men ook gewoon dat de DHCP van de router moet komen.

Als je de switch er tussen hebt zitten, wat voor IP's krijg je dan in je Network kolom?
SSID's allemaal hetzelfde gekozen?
Werkten je router en extender op hetzelfde kanaal, of heb je gekozen dat ze afzonderlijke kanalen hebben (voorkeur)?
IP op je mobile device als je verbonden bent met de extender is in dezelfde range (192.168.1.xxx), zowel met als zonder switch?

Blijf er een beetje bij dat het iets weg heeft van een conflict tussen iets .. alleen even ... wat?
Reputatie 5
Badge +8
Duncankrebbers schreef:

Maar als ik dus de repeater in de switch plug dan gaat het een tijdje goed, totdat opeens alle apparaten de verbinding verliezen en aangeven geen ip-adres meer te ontvangen.


Als je in deze toestand een PC op LAN2 aansluit, krijgt die dan nog wel verbinding met internet?
Reputatie 6
Badge +5
Mooi om te zien hoe dit topic zich ontwikkeld als een schaakspel! Gaat het nu alleen nog maar om de Fritz die geen (stabiele) IP krijgt als hij achter de switch zit aangesloten? Alles wijst naar de switch of mis ik iets?
De oplossing zit in de profiel wat door T-Mobile wordt ingeladen in modem thuis.
Hierin zit een configurartie die wel werkt en een profiel met cofig die niet werk. T-Mobile wil niet vertel welke profile nu bij mij is geladen daarom weet ik niet welke de goeie is.
Reputatie 3
Hi

ik heb ook een switch, maar bij mij werkt alles prima WiFi en bekabeld. Onderving geen problemen ( netgear GS116).
Sander schreef:

Mooi om te zien hoe dit topic zich ontwikkeld als een schaakspel! Gaat het nu alleen nog maar om de Fritz die geen (stabiele) IP krijgt als hij achter de switch zit aangesloten? Alles wijst naar de switch of mis ik iets?


Hallo Sander,

Ik denk dan T-Mobile nu een goeie profiel heeft en deze bij de meeste werk. Alleen wat ik nu ervaar is dat de wifi niet echt stabiel is deze verlies regelmatig de connectie naar internet terwijl de Wi-Fi verbinden wel is.
Het meest frappante was toen ik de helpdesk van T-Mobile belde en mij probleem had uitgelegd, deze mij antwoorde dat ze niets voor mij kon betekenen ze begreep wel mij issue en deze was niet een T-Mobile probleem en dat is was niet echt klant vriendelijk. Werd mij gezegd dat ik op internet connectie kan (al was het maar met een device en verder was niet de verantwoordelijkheid van T-Mobile of ik een verder kon uitbreiden/werken. gezien mijn kennis over netwerk (CCNP'r) bood ik een oplossing aan maar deze werd niet gewaardeerd.
Maar goed een lang verhaal kort te houden CSD van T-Mobile is niet echt klant vriendelijke gericht.
Reputatie 5
Badge +5
Hi @Moony we zijn altijd bereid om met je mee te denken maar we kunnen geen ondersteuning bieden op het gebruik van eigen apparatuur. Het is onmogelijk om kennis te hebben van alle switches, routers en andere netwerkapparatuur dus de klantenservice kan je hier inderdaad niet altijd mee helpen. Maar we hebben hier op de Community een aantal knappe koppen en vaak komen we er uiteindelijk wel uit! 😉
Hallo Brain,
Dank u voor reactie. Ik denk niet dat deze probleem bij de klant apparatuur lig. De Draytech modem is door T-Mobile geconfigureerd en ik gaf duidelijk aan dat de DHCP scoop niet goed is ingesteld en dat deze niet werkt en het heeft niets te maken met de switchen (dommen switchen) er achter. Maar nog bleef de CSD beweren dat de probleem bij lag. Ik vroeg om us/pw van Draytech modem zodat ik deze zelf kon instellen, dat mocht ook niet.
Maar goed ik denk dat de ontwerpers beter naar hun ontwerp moet kijken voor dat ze deze uitrollen dat zal heel veel frustraties besparen.
Reputatie 5
Badge +2
@Moony

Als CCNP'r zou ik mij voor kunnen stellen dat je eens een switch (bijv Cisco) neemt en een momitor inricht op de inkomende poort op die switch, om te kijken wat de requesten zijn en hoe ze terug komen.

Je zou dan eventueel de 'foute' switch aan je eigen monitorswitch kunnen hangen of de DHCP DISCOVER / OFFER / REQUEST / ACKNOWLEDGE afhandeling aanwezig is.

Is dat mogelijk bij jou?

Reageer