Beantwoord

Internet valt vaak weg

  • 5 november 2018
  • 39 reacties
  • 1001 Bekeken

De laatste tijd gebeurt het regelmatig (gemiddeld 2 á 3 keer per dag) dat mijn internet wegvalt. Via ipconfig zie ik dat ik op dat moment géén standaard gateway meer heb, met een ip-adres in de range 169.254.x.x. Oftewel: mijn router kent geen ip-adres toe. Als ik mijn router vervolgens uit-/aanzet dan werkt het weer, maar het is vervelend dit meermaals per dag te moeten doen.

Ik werk met een bekabeld netwerk en heb 3 apparaten aangesloten. Op alle apparaten komt het probleem voor, maar (tot nu toe) niet tegelijkertijd op meerdere apparaten. Ook een factory reset van mijn router heeft het probleem niet verholpen. De ip-adressen die mijn systemen krijgen als het wel werkt blijven hetzelfde (volgens de DHCP table), dus een ip-conflict lijkt het ook niet te zijn.

Zijn er dingen die ik kan veranderen in de instellingen van mijn router om dit probleem te verhelpen? Of kan ik wellicht nog ergens logging terugvinden die misschien kan aangeven waar het onderliggende probleem zit?
icon

Beste antwoord door Folkert 5 november 2018, 22:51

Aanvulling: De optie Retrieve IPs from inactive clients periodically heeft voor thuis gebruik geen enkel nut hoewel hij pas actief wordt als er 30 of minder vrije IP adressen in de pool zitten. Zie https://www.draytek.com/en/faq/faq-connectivity/connectivity.lan/how-to-clear-dhcp-lease-from-inactive-clients/
Bekijk origineel

39 reacties

Reputatie 7
Badge +18
Dit is duidelijk een DHCP server probleem als ze allemaal hun IP adres en de rest kwijtraken. Hoe lang staat je DHCP leasetime? Kun je die eens op bijvoorbeeld een week zetten?

Heb je alle clients op automatisch toewijzen van IP adres etc. staan?
De leasetime stond op een dag (24 uur). Deze heb ik nu naar een week gezet en ik ga kijken of het hierdoor beter wordt. De clients staan inderdaad allemaal op automatisch toewijzen van IP adres. Ik zie bij de DHCP settings ook het vinkje "Retrieve IPs from inactive clients periodically" aan staan. Kan dit nog invloed hebben hierop?
Reputatie 7
Badge +18
Zo'n optie ken ik niet. Voor zover ik weet vragen de clients een verlenging van de lease tijd als deze 50% op is.
De dhcp server zal wel kijken of ip adressen niet meer actief zijn voodat hij ze vrijgeeft.

Gewoon uitzetten en kijken of het beter gaat.
Reputatie 7
Badge +18
Aanvulling: De optie Retrieve IPs from inactive clients periodically heeft voor thuis gebruik geen enkel nut hoewel hij pas actief wordt als er 30 of minder vrije IP adressen in de pool zitten. Zie https://www.draytek.com/en/faq/faq-connectivity/connectivity.lan/how-to-clear-dhcp-lease-from-inactive-clients/
Bedankt! Ik ga kijken of deze dingen het gewenste effect hebben.
Ik heb ditzelfde probleem in een ander variant. Bij mij worden alle LAN poorten eruit gegooid om de zoveel uur. WiFi doet het nog wel goed op dat moment, heb Google afgezocht en het blijkt aan de firmware van de Draytek router te liggen die niet goed is.

Zal zelf een topic aanmaken met de vraag of een T-mobile medewerker mijn firmware wil updaten want heb zelf geen admin login van de router.
Reputatie 6
Badge +2
@Cyberpunk

Heb hier al een aantal jaren deze Draytek modem/router en nog nooit met de voorgaande of huidige FW dit probleem ondervonden, waardoor ik dus twijfel of dit een FW issue zou kunnen zijn.

Kun je uitvinden eventueel welke 'gebruiker' er aktief is wanneer dit probleem opduikt?
Anders eens een tijdje een bepaalde LAN gebruiker niet aansluiten?

Andere optie is een fixed IP toe te wijzen aan gebruikers buiten de normale DHCP range, om te kijken of het probleem zich dan ook voordoet.
Sinds mijn vorige bericht is het probleem niet meer teruggekomen, tot zojuist. Dat is denk ik geen toeval aangezien ik de DHCP leasetime op een week heb gezet. Is er ook een permanente oplossing? Moet ik de DHCP leasetime gewoon op 10 jaar zetten? Ik vermoed toch niet uit de IP-adressen te lopen, of zijn er nog andere redenen om dit niet te doen?
Reputatie 7
Badge +18
@Fitmacaroni Gewoon de lease time op maximaal zetten. Je zult inderdaad niet snel een tekort aan IP adressen hebben.

Blijft vreemd uiteraard. Normaliter wordt de lease time halverwege al weer vernieuwd.

Indien mogelijk vaste ip adressen gebruiken voor vaste computers. Mobiele telefoons verlaten minimaal elke week wel het huis en krijgen bij thuiskomst een nieuwe lease.
@Folkert De maximale leasetime was 30 dagen, dus daar heb ik hem op gezet. Dit heeft een tijd goed gegaan, maar sinds een paar dagen heb ik het probleem weer meerdere malen per dag. De leasetime staat nog steeds op 30 dagen (en ik zie dit ook terug als ik op mijn pc een ipconfig /all doe).

Is er nog iets anders wat ik kan doen? Is dit niet gewoon een probleem aan de kant van T-Mobile?
Hmm.. Zojuist had ik het probleem weer en heb ik weer even gekeken, maar het lijkt deze keer een ander probleem te zijn. Ik hem namelijk wel gewoon netwerk, maar geen internet.

Het gekke is dat ik vanaf mijn PC een ping kan doen naar andere apparaten in mijn netwerk zonder probleem. Als ik echter de default gateway ping dan krijg ik geen antwoord (soms met een 'destination host unreachable').

Nu zie ik meer mensen met internetproblemen momenteel. Is er toevallig een storing?
Reputatie 7
Badge +18
Hmm.. Zojuist had ik het probleem weer en heb ik weer even gekeken, maar het lijkt deze keer een ander probleem te zijn. Ik hem namelijk wel gewoon netwerk, maar geen internet.

Het gekke is dat ik vanaf mijn PC een ping kan doen naar andere apparaten in mijn netwerk zonder probleem. Als ik echter de default gateway ping dan krijg ik geen antwoord (soms met een 'destination host unreachable').

Nu zie ik meer mensen met internetproblemen momenteel. Is er toevallig een storing?


Er was gisteren een storing, wellicht nog een keer je modem herstarten?
Ik heb mijn modem vandaag al 3 keer moeten herstarten. Dat werk wel, maar blijft helaas tijdelijk.

Zou het in dit geval ook aan de kabel kunnen liggen? Op zich kan dat verklaren dat ik geen internet heb maar wel netwerk. Aan de andere kant is het dan wel weer raar dat het weer werkt na het opnieuw opstarten van mijn modem.

Is er misschien iemand van T-Mobile die in mijn modem kan zien of er iets geks gebeurt?
Hopelijk kan hier snel naar gekeken worden, want ik heb mijn modem zojuist weer opnieuw aan moeten zetten. Deze keer een andere kabel aangesloten, dus ik heb in ieder geval uitgesloten dat het aan de kabel ligt.

Ik heb nu in het afgelopen uur dus al 3 keer mijn modem opnieuw aan moeten zetten. Dit is absoluut geen fijne situatie!
Reputatie 7
Badge +10
wat voor modem heb je ?
klopt jet dat je bekabeld internet uit valt maar de wifi van het modem nog wel gewoon werkt ?
Wifi werkt inderdaad wel gewoon. Daarom dacht ik dat het aan de kabel lag, maar ik heb inmiddels meerdere kabels geprobeerd en het resultaat blijft hetzelfde. Overigens net weer opnieuw aan moeten zetten, dus het gaat nu echt iedere 10 á 20 minuten weer fout...

Ik heb het modem wat ik van T-Mobile gekregen heb: de Draytek Vigor2132FVn.
Ik heb zojuist maar eens een factory reset gedaan. Buiten het wachtwoord heb ik verder nu niets veranderd. Als het dan werkt dan lag het blijkbaar aan een van de niet-standaard instellingen die ik verder heb gedaan (eigenlijk in een poging om problemen op te lossen).
Reputatie 7
Badge +10
volgens mij heb je last van een deadlock van het modem. @Sander kan je hier vast verder mee helpen
Bedankt @Hidden.nld. @Sander Het probleem is zojuist weer teruggekomen, dus een factory reset heeft ook maar een paar minuten geholpen. Kun jij dit z.s.m. voor me oplossen? Ik moet inmiddels om de 5 minuten naar mijn modem lopen...
@Sander Het probleem is nog steeds niet verholpen. Ik ben het naar mijn modem lopen inmiddels wel beu. Als dit niet heel snel wordt opgelost dan zal ik noodgedwongen naar een andere provider moeten stappen, want dit kan gewoon niet.

Als iemand anders wil helpen dan graag, want T-Mobile zelf doet blijkbaar gewoon helemaal niets!
Reputatie 6
Badge +2
@Fitmacaroni

Heb hier een z.g.n windows batch file voor het monitoren van je internet verbinding via je Windows PC.

De code is alsvolgt:

code:
@echo off

set logfile=%userprofile%\Documents\pinglog.log

:Ping
for /f "tokens=* skip=4" %%A IN ('ping 8.8.8.8 -n 1') DO (
echo %date% %time:~0,2%:%time:~3,2%:%time:~6,2% %%A >> %logfile%
echo %date% %time:~0,2%:%time:~3,2%:%time:~6,2% %%A)
timeout 15 >NUL
GOTO Ping



Even uitleggen wat het doet voor de 'angsthazen' onder ons.

@echo off = laat het script niet tijdens het lopen zien
set logfile = de plek waar het logfile komt te staan, in de gebruiker zijn Documents folder
for /f "tokens=* skip=4" %%A = we lezen de return van de ping in de variabele %%A en plaatsen die in het logfile (pinglog.log)
timeout 15 `>`NUL = is een wachtloop van 15 seconden voordat we weer gaan ondervragen en wegschrijven, deze kun je naar wens aanpassen naar bijvoorbeeld om de minuut (60) of meer.
GOTO = begin weer vanaf boven aan (Basic code 😄 )

Mocht je er meer pakketjes uit willen sturen bijv. 3, zet dan achter de -n 3 i.p.v. 1

Sla het bovenstaande op in een .bat file, bijv . TESTPING.BAT en start hem met de rechtermuis dan met 'Run as Aministrator'.
DE CMD terminal gaat open en je kunt zien wat er gebeurt.
Om het script te stoppen gebruik je de toetsen combinatie CTRL+C en dan krijg je ook de vraag in de terminal of je het script wilt stoppen Y/N.
De gewone gebruiker heeft, als het goed is, geen rechten om dit .bat file te 'runnen'.


Ik weet dat het een quick and dirty oplossing is, maar voor het monitoren van bijv 24 uur denk ik wel eens te doen.

BTW een hele mooie taak voor een kleine Raspberry Pi om bij klanten die echt problemen schijnen te hebben neer te hangen en vanaf afstand uit te lezen ... zo een uitdaging moeten zijn voor een echte T-Mobile ICT nurd 😎

@Pieter_B Ik ga hem eens laten lopen. Mijn verwachting is echter dat ik gewoon zie dat er geen berichten verloren gaan tot het moment waarop het fout gaat, waarna alles verloren gaat (totdat ik mijn modem weer opnieuw start). Maar wie weet komt er nog iets verrassends uit. Ik laat het weten!
@Pieter_B Bijna zoals verwacht. Deze keer ging het verrassend genoeg een uur lang goed, maar daarna niet meer. Eén ding valt me hierin op: terwijl hij eruit lag, is er één pakketje tóch aangekomen (zie 18:10:28, bijna onderaan). De onderste 3 zijn van nadat ik mijn router weer opnieuw heb aangezet. Kun je hier iets mee?

code:
(...)
di 18-12-2018 18:03:16 Ping statistics for 8.8.8.8:
di 18-12-2018 18:03:16 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:03:16 Approximate round trip times in milli-seconds:
di 18-12-2018 18:03:16 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:03:31 Ping statistics for 8.8.8.8:
di 18-12-2018 18:03:31 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:03:31 Approximate round trip times in milli-seconds:
di 18-12-2018 18:03:31 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:03:46 Ping statistics for 8.8.8.8:
di 18-12-2018 18:03:46 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:03:46 Approximate round trip times in milli-seconds:
di 18-12-2018 18:03:46 Minimum = 7ms, Maximum = 7ms, Average = 7ms
di 18-12-2018 18:04:01 Ping statistics for 8.8.8.8:
di 18-12-2018 18:04:01 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:04:01 Approximate round trip times in milli-seconds:
di 18-12-2018 18:04:01 Minimum = 7ms, Maximum = 7ms, Average = 7ms
di 18-12-2018 18:04:16 Ping statistics for 8.8.8.8:
di 18-12-2018 18:04:16 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:04:16 Approximate round trip times in milli-seconds:
di 18-12-2018 18:04:16 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:04:31 Ping statistics for 8.8.8.8:
di 18-12-2018 18:04:31 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:04:31 Approximate round trip times in milli-seconds:
di 18-12-2018 18:04:31 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:04:46 Ping statistics for 8.8.8.8:
di 18-12-2018 18:04:46 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:04:46 Approximate round trip times in milli-seconds:
di 18-12-2018 18:04:46 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:05:01 Ping statistics for 8.8.8.8:
di 18-12-2018 18:05:01 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:05:01 Approximate round trip times in milli-seconds:
di 18-12-2018 18:05:01 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:05:16 Ping statistics for 8.8.8.8:
di 18-12-2018 18:05:16 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:05:16 Approximate round trip times in milli-seconds:
di 18-12-2018 18:05:16 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:05:31 Ping statistics for 8.8.8.8:
di 18-12-2018 18:05:31 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:05:31 Approximate round trip times in milli-seconds:
di 18-12-2018 18:05:31 Minimum = 6ms, Maximum = 6ms, Average = 6ms
di 18-12-2018 18:05:46 Ping statistics for 8.8.8.8:
di 18-12-2018 18:05:46 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:05:46 Approximate round trip times in milli-seconds:
di 18-12-2018 18:05:46 Minimum = 7ms, Maximum = 7ms, Average = 7ms
di 18-12-2018 18:06:01 Ping statistics for 8.8.8.8:
di 18-12-2018 18:06:01 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:06:01 Approximate round trip times in milli-seconds:
di 18-12-2018 18:06:01 Minimum = 7ms, Maximum = 7ms, Average = 7ms
di 18-12-2018 18:06:16 Ping statistics for 8.8.8.8:
di 18-12-2018 18:06:16 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:06:34 Ping statistics for 8.8.8.8:
di 18-12-2018 18:06:34 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:06:52 Ping statistics for 8.8.8.8:
di 18-12-2018 18:06:52 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:07:10 Ping statistics for 8.8.8.8:
di 18-12-2018 18:07:10 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:07:28 Ping statistics for 8.8.8.8:
di 18-12-2018 18:07:28 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:07:46 Ping statistics for 8.8.8.8:
di 18-12-2018 18:07:46 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:08:04 Ping statistics for 8.8.8.8:
di 18-12-2018 18:08:04 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:08:22 Ping statistics for 8.8.8.8:
di 18-12-2018 18:08:22 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:08:40 Ping statistics for 8.8.8.8:
di 18-12-2018 18:08:40 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:08:58 Ping statistics for 8.8.8.8:
di 18-12-2018 18:08:58 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:09:16 Ping statistics for 8.8.8.8:
di 18-12-2018 18:09:16 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:09:34 Ping statistics for 8.8.8.8:
di 18-12-2018 18:09:34 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:09:52 Ping statistics for 8.8.8.8:
di 18-12-2018 18:09:52 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:10:10 Ping statistics for 8.8.8.8:
di 18-12-2018 18:10:10 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:10:28 Ping statistics for 8.8.8.8:
di 18-12-2018 18:10:28 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:10:43 Ping statistics for 8.8.8.8:
di 18-12-2018 18:10:43 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:11:01 Ping statistics for 8.8.8.8:
di 18-12-2018 18:11:01 Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),
di 18-12-2018 18:11:19 Ping statistics for 8.8.8.8:
di 18-12-2018 18:11:19 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:11:36 Ping statistics for 8.8.8.8:
di 18-12-2018 18:11:36 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:11:36 Approximate round trip times in milli-seconds:
di 18-12-2018 18:11:36 Minimum = 12ms, Maximum = 12ms, Average = 12ms
di 18-12-2018 18:11:51 Ping statistics for 8.8.8.8:
di 18-12-2018 18:11:51 Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
di 18-12-2018 18:11:51 Approximate round trip times in milli-seconds:
di 18-12-2018 18:11:51 Minimum = 6ms, Maximum = 6ms, Average = 6ms
@Sander Tijdens het typen van mijn vorige post viel de verbinding weer weg, dus het is weer terug naar om de paar minuten blijkbaar. Ik heb besloten dat als het deze week niet is opgelost, ik naar een andere provider ga. Ik zal me er ook hard voor gaan maken dat dit per direct en kostenloos kan. Ik vind het gewoon ronduit belachelijk dat ik door niemand van T-Mobile geholpen wordt. Ik weet inmiddels wel waarom het goedkoop is in ieder geval, want jullie hoeven geen loonkosten te betalen voor support.
Inmiddels heb ik weten te regelen dat er een monteur langskomt met een nieuw modem. Hopelijk gaat dat helpen (al twijfel ik, want een factory reset lost ook niets op)...

Reageer