Beantwoord

T-mobile thuis en NAS

  • 25 december 2018
  • 9 reacties
  • 494 Bekeken

Sinds kort ben ik overgestapt naar TM thuis glasvezel. Naar buiten toe gaat alles perfect en ben ik dik tevreden, ondanks dat de Guidion monteur niets voor mij heeft kunnen installeren (er was geen internetsignaal op de inkomende lijn, waardoor hij niet heeft kunnen doen, anders dan de apparaten inpluggen en neerzetten).

Alleen op het thuisnetwerk (LAN) stuit ik op nogal vervelende problemen bij het verbinden met mijn NAS (Synology Ds218Play)

Ik draai op de NAS een website. Die wil ik vanuit thuis en extern kunnen benaderen. Extern geen problemen, vanuit thuis totaal geen connectie. Niet met het DDNS adres, niet via /sitenaam
Aangezien dit de basis is van mijn thuiswerken, is dit voor mij een serieus probleem.

Ander probleem, op mijn pc is het regelmatig volledig onmogelijk om via windows explorer de netwerkmappen in te kunnen. De drive-mappings werken niet en in de netwerkomgeving is de NAS niet te zien. Inloggen op DSM (dat werkt dan weer wel) gaat dan prima, alleen dus geen toegang via verkenner. (uur later overigens weer zonder probleem)

Ik ben volledig uitgedokterd hier en andere forum posts gaan blijkbaar enkel over portforwarding problemen. Problemen die ik dus juist niet heb.

Wie heeft er hier een passende oplossing?

(als er iemand trouwens al een oplossing heeft voor het bereiken van de NAS via DDNS over het LAN, ben ik erg benieuwd)
icon

Beste antwoord door tmoesel 25 december 2018, 22:27

De Huawei HG659 van TMT doet geen NAT loopback, dat is zo te lezen het probleem. Als je PC/laptop op het thuisnetwerk zit, moet je de serverfuncties op de DSM benaderen via het LAN subnet IP adressen, dus 192.168.1.x. Via DDNS ( je publieke WAN IP adres of naam) werkt niet vanuit thuisLAN.

NAT loopback zit nogal diep in een router en TMT heeft al aangegeven dat die functionaliteit niet wordt toegevoegd. Andere/eigen router die dat wel kan is eigenlijk de enige echte oplossing om om wat je wilt probleemloos te laten werken.

NAS (SMB Samba fileserver in geval van Windows) zou ik sowieso niet of nooit via een extern IP adres benaderen, dan liggen de problemen die je hebt bijna gegarandeerd op de loer.
Voor een webserver ligt het wat anders, maar je zou 2 bookmarks erop na kunnen houden, 1 met DDNS naaam/adress en 1 met LAN adres.
Bekijk origineel

9 reacties

Reputatie 6
Badge +11
De Huawei HG659 van TMT doet geen NAT loopback, dat is zo te lezen het probleem. Als je PC/laptop op het thuisnetwerk zit, moet je de serverfuncties op de DSM benaderen via het LAN subnet IP adressen, dus 192.168.1.x. Via DDNS ( je publieke WAN IP adres of naam) werkt niet vanuit thuisLAN.

NAT loopback zit nogal diep in een router en TMT heeft al aangegeven dat die functionaliteit niet wordt toegevoegd. Andere/eigen router die dat wel kan is eigenlijk de enige echte oplossing om om wat je wilt probleemloos te laten werken.

NAS (SMB Samba fileserver in geval van Windows) zou ik sowieso niet of nooit via een extern IP adres benaderen, dan liggen de problemen die je hebt bijna gegarandeerd op de loer.
Voor een webserver ligt het wat anders, maar je zou 2 bookmarks erop na kunnen houden, 1 met DDNS naaam/adress en 1 met LAN adres.
Hoi tmoesel,
Als ik vanuit thuis alleen met subnet IP er al op zou kunnen, was ik al tevreden. Niet ideaal, maar werkbaar.
Ik kom vanuit het LAN helemaal niet meer op de sites op de NAS. Ook niet via 192.168.1.xxx/sitemap adres in de browser.

Ook dat ik mijn document die op de NAS worden bewaard, kan ik helft van de tijd alleen bereiken door te downloaden (Quickconnect werkt gek genoeg wel, maar daarmee kan je sowieso de webserver niet bereiken, enkel de DSM). Als ik alle documenten iedere keer weer moet updaten naar de server toe, daar heb ik de server niet voor aangeschaft.

Netwerk Share in windows worden er uit getrapt met opmerking dat local device name is already in use
Reputatie 6
Badge +11
OK, er is dus (ook nog) wat anders aan de hand. Ik heb geen ervaring met Synology, maar het lijkt erop dat er ergens iets met adressering de mist in gaat. Ik zou denk ik om het verder uit te vissen zowel je PC als de NAS tijdelijk een vast IP adres geven. Dan kun je 1 ethernetkabel tussen PC en NAS aansluiten, Huawei staat dan buitenspel en ook eventuele andere apparaten.
Op de PC kan je dan de NAS benaderen via \\192.168.1.xxx\sharenaam
Het kan ook zijn dat je PC ergens nog iets wil wat met het oude/vorige netwerk te maken heeft. Start dan e.v.t. anders eerst op in veilge modus met wel netwerk actief
zowel pc als NAS hebben een vast IP. in deze verbinding wordt geen gebruik gemaakt van wifi, maar via wifi zelfde symptomen.
zal proberen wat er gebeurd als ik Huawei ertussen uit plug.
** edit: dan heb ik al helemaal geen verbinding meer en geeft zelfs ping geen antwoord 😶 **

je punt mbt veilige modus opstart begrijp ik niet... kan je die nog uitleggen??
Reputatie 6
Badge +11
Weet je zeker dat er een ethernetverbinding is als je een kabel direct van de NAS naar de PC verbindt?
De lampjes van de ethernetpoort van zowel de NAS als PC moeten dan activiteit vertonen.
Stel je NAS heb je tijdelijk op 192.168.1.202 en de PC tijdelijk op 192.168.1.201 dan moet, als je op de PC ping 192.168.1.202 doet, wel iets gebeuren met die lampjes. Misschien heeft de kabel (vooral de connectoren) niet helemaal goed electrisch contact, maar het kan ook zijn dat de PC of NAS eigenwijs zijn en bij geen internet (geen DNS, geen default Gateway) de hele LAN poort uitschakelen.

Vaste IP adressen kan flink lastig worden want de DSM eenmaal ingesteld, kan dan niet meer bereikbaar zijn als je PC weigert op datzelfde subnet. Dus maak voor jezelf en dit forum duidelijk wat de adressen zijn, misschien is er overlapping met zaken van vorige provider en/of DHCP range.

Kijk anders eens wat op de PC het commando ipconfig weergeeft.

met commando msconfig kun je een (Windows) PC instellen hoe die moet opstarten. Maar dat heeft alleen zin als je weet dat de router enz wel zijn werkt goed doet.
Als via WiFi zelfde symptomen zijn lijkt het dat de DSM en Huawei niet goed op elkaar zijn afgesteld.
Ik heb een denkfout gemaakt... IP adressen stonden als vast ingesteld in de Huawei en NAS, maar nog niet in de PC. Bij losnemen van de Huawei, was de PC dus meteen het IP kwijt.
Na het ook in de PC een vast IP te hebben gegeven, werkte de verbinding goed tussen PC en NAS. Maar ook gek genoeg tussen laptop (dynamisch IP) en nas

Wat nog niet werkt zijn de Netwerk Shares in verkenner... Krijg daar nu nog helemaal geen verbinding met NAS. Ook niet meer sporadisch
Reputatie 6
Badge +11
Goed dat een directe kabelverbinding tussen PC en NAS werkt, in ieder geval elektrisch gezien.

Er zijn in de afgelopen 20 jaar een hoop veranderingen gedaan aan hoe MS Windows shares werken en het kan makkelijk zijn dat nu met wisseling van providerrouter een oude instelling o.i.d. niet meer zonder meer geaccepteerd wordt tussen PC en NAS (meestal vanwege veiligheid). Verder kan of doet een NAS een ranking van zichzelf t.o.v. ander eventuale Microsoft shares/systemen en daar kan wat tijd overheen gaan voordat dit 'uitonderhandeld' is. Ook kan simpelweg een speciaal naamgevingssysteem op tilt gaan of niet actief zijn waardoor de Netwerk Shares er wel zijn maar niet gevonden willen worden. Het is allemaal rondkijken in de DSM wat er e.v.t. loos kan zijn.

Synology kan ook DHCPserver zijn, dat kan ook automatisch actief worden denk ik als ie geen andere DHCPserver tegenkomt (nu dus nu de Huawei is afgekoppeld). Of de IP adress leasetime is nog niet afgeliopen en dus houd de laptop maar zijn oude/bestaande adresuit de thsuiLAN range en dus is de NAS benaderbaar via de laptop. Dat kan verklaren waarom de Laptop ook werkt. Dus kijken wat de IP adressen zijn.
Met Huawei weer aangekoppeld, werkt het onderdeel via webbrowser toegang krijgen weer optimaal...
Het probleem met de netwerk shares zit denk ik in de naamgeving van het netwerk... Maar ik kom er niet meer uit...
In mijn oude router kon ik het netwerk een naam geven. Dat kan ik in de Huawei niet terug vinden.
In win10 kan ik ook niet terug vinden hoe ik die naam moet wijzigen. Deze neemt de naam van de router over.
In DSM kan ik het wel instellen, maar welke naam ik daar ook gebruik, ik krijg niet de gewenste verbinding (los van wat via de browser gebeurd... dat werkt en blijft werken)

Synology is niet ingesteld op DHCP Server.

die netwerk shares werkten voor ik het fixed IP ding heb gewijzigd. Niet stabiel, maar ik had soms verbinding. Die verbinding is nu volledig kwijt.
Reputatie 6
Badge +11
Er is eerder gemeld dat de Huawei van TMT problemen had met naamgeving, maar dan als ie zelf Samba server is (dus NAS voor Windows computers). Het lijkt erop dat de Huawei van TMT allleen maar standaard internet naamgeving doet en niks wat betreft Microsoft naamgevingsprotocollen zoals WINS. En het kan ook nog best zijn dat die Microsoft protocollen geblokkeerd worden maar dat denk ik niet. Ik heb altijd mijn eigen NAS gefabriceerd en er is nogal wat special werk nodig om de MS Windows zaken handig/netjes te maken. Vaak loonde het niet voor mij en gebruikte ik gewoon het IP adres i.p.v. wachten op een verkenner/explorer en allerhand gesukkel.

Op je DSM kan je wel een naam instellen, maar de PC vraagt zijn namen aan de Huawei en die weet weer niks van wat je op de DSM hebt ingesteld. Het kan zijn dat als je alle apparaten die aan de Huawei hangt op dynamisch instelt, de Huawei in ieder geval de DSM naam via DNS meekrijgt en dus weet. Luisteren op het netwerk om zo naamaankodigingen volgens Windows principes te achterhalen doe ie schijnbaar niet.

Ik had een tijdlang een Huawei van 4GvT actief, ook kwa routing een beperkt ding (en instabiel WiFi i.c.m. T-Mobile 4G netwerktactieken). Heb toen al het DHCP etc gebeuren naar mijn NAS verhuist en de Huawei alleen nog gateway en NAT firewall laten zijn. Dat was een hele verademing omdat zaken daardoor werkten zoals ik wilde (ik kwam van XS4ALL met FritzBox). Misschien kun je ook zoiets doen, dat scheelt weer een andere router kopen maar is wel gekunstel. Anders andere eigen router kopen en installeren, zie topics m.b.t. dat op dit forum.

Reageer