Beantwoord

Van intern ip-adres naar public ip-adres naar web-server

  • 19 oktober 2017
  • 4 reacties
  • 516 Bekeken

Vanaf internet (smartphone) kom ik via mijn publieke ip-adres (85.x.x.x) binnen op de router HG659 en met port forwarding kom ik netjes uit op de machine (192.x.x.x) waar mijn WordPress site draait.
Precies wat je van port forwarding verwacht.
Nu verwacht mijn WordPress site alleen verkeer afkomstig van het 85.x.x.x adres.
Mijn probleem:
Het lukt niet om vanaf een intern 192.x.x.x via het 85.x.x.x adres de WordPress site te bereiken en te managen. In plaats van port forwarding naar de machine krijg ik de inlogpagina van de HG659.
Weet iemand een oplossing?
icon

Beste antwoord door Hidden.nld 20 oktober 2017, 08:02

Hallo wjkuitems,

Je modem heeft 2 ipadressen een externe de 85 en een interne 192.168.1.1
er vind vanaf 192.168.1.x geen forwarding plaats. en omdat het modem zelf het 85 adres heeft en je binnenkomt vanaf 192 geeft hij de login pagina.
Wat ik dan doe is een static entry maken in de dns van het modem zodat de naam bijvoorbeeld www.wjkuitems.nl gaat naar het 192 adres. dit werkt alleen op dns naam en niet op ip. ik weet niet of het modem dit ondersteund.
Bekijk origineel

4 reacties

Reputatie 7
Badge +10
Hallo wjkuitems,

Je modem heeft 2 ipadressen een externe de 85 en een interne 192.168.1.1
er vind vanaf 192.168.1.x geen forwarding plaats. en omdat het modem zelf het 85 adres heeft en je binnenkomt vanaf 192 geeft hij de login pagina.
Wat ik dan doe is een static entry maken in de dns van het modem zodat de naam bijvoorbeeld www.wjkuitems.nl gaat naar het 192 adres. dit werkt alleen op dns naam en niet op ip. ik weet niet of het modem dit ondersteund.
Goedemorgen Hidden.nld.
Ik begrijp wat je zegt en ik denk dat je refereert naar de de tab Internet->Internet Settings. Daar zie ik: INTERNET_VOICE_R_VID_300 met IPv4 primary en secondary DNS server adressen. Echter, met de user 'User' en het bijbehorende password heb ik daar geen mogelijkheid om iets te wijzigen. Ik vermoed dat die user onvoldoende rechten heeft gekregen van de fabriek of vanuit mijn ISP.
Heb je misschien nog een andere tip?


Hallo wjkuitems,

Je modem heeft 2 ipadressen een externe de 85 en een interne 192.168.1.1
er vind vanaf 192.168.1.x geen forwarding plaats. en omdat het modem zelf het 85 adres heeft en je binnenkomt vanaf 192 geeft hij de login pagina.
Wat ik dan doe is een static entry maken in de dns van het modem zodat de naam bijvoorbeeld www.wjkuitems.nl gaat naar het 192 adres. dit werkt alleen op dns naam en niet op ip. ik weet niet of het modem dit ondersteund.
Reputatie 7
Badge +10
Hallo Wjkuitems,

Ja hoor je kan het per apparaat instellen in C:\Windows\System32\drivers\etc\hosts door 1 regel toe te voegen.
[ipadres][domeinnaam]
bijvoorbeeld
192.168.1.2 www.wjkuitems.nl

maar je kan ook zelf een dns server draaien op je computer of nas.
Als je dan toch bezig bent kan je ook even kijken naar https://pi-hole.net deze stript ook nog eens reclame van websites en in apps 🙂
Bingo ! Helemaal goed. Bedankt !!

Reageer