Beantwoord

Huawei HG659 poort open zetten

  • 1 augustus 2019
  • 10 reacties
  • 424 Bekeken

Ik hoop op hulp, ik kom er niet uit.
Ik wil een inverter van zonnepanelen via een kabel met internet verbinden. Dit lukt echter niet. De kabel is goed, als ik de laptop er op aansluit heb ik normale snelheid.
De eisen van de inverter zijn deze.

The PowerRouter uses a dynamic IP address. This means that it receives an IP address from its Internet router (DHCP server).
It is not possible to bring the PowerRouter online by means of a proxy server.
The PowerRouter communicates via a half-duplex 10Mbit connection through (http / web) port 80, which should not be blocked by a firewall (e.g., through the Internet modem).

Mijn vermoeden is dat poort 80 geblokkeerd is.
Van de inverter heb ik alleen een macadres.
Wat moet ik doen om dit werkend te krijgen. Graag in Jip en Janneke taal.
Bij voorbaat dank.
icon

Beste antwoord door tmoesel 2 augustus 2019, 17:38

Het IP adres 169.254.1.1 is een https://en.wikipedia.org/wiki/Link-local_address
Wat er op neer komt betekent dat de PowerRouter na een aantal mislukte pogingen om een IP adres te verkrijgen van de HG659 dit zichzelf toekent.

Blijkbaar gaat dus DHCP (server: HG659 client: PowerRouter) mis. DHCP is normaal een 4 staps onderhandeling maar die loopt dus spaak. Aan welke van de beide apparaten het nu ligt is erg moeilijk te zeggen zonder daadwerkelijk te kijken wat voor ethernet datapaketten er tussen de HG659 en de PowerRouter heen en weer gaan.

Je zou de PowerRouter eens aan een andere router kunnen hangen en kijken of ie dan wel een adres krijgt. Of de HG659 ook fabrieksresetten en hopen dat het dan wel goed gaat.

Een andere router is ook een laptop die met z'n WiFi aan het internet hangt en dan zijn WiFi internet-delen naar de ethernetpoort van de laptop en daaraan de PowerRouter hangen.
Bekijk origineel

10 reacties

Reputatie 6
Badge +11
Er zijn inderdaad berichten dat poort 80 vanaf buitenshuis in de HG659 al bezet is en daardoor dus eigenlijk (al) geblokkeerd.

Maar heeft de inverter wel internetverbinding ?
Hij moet in ieder geval in de HG659 bekend zijn. Ergens in de HG659 zal het MAC-adres van de inverter, met daaraan een IP adres toegekend, zichtbaar moeten zijn.
Controleer dat eerst, want het zou ook nog kunnen zijn dat de HG659 weigert in 'half-duplex 10Mbit' snelheidsmodus te gaan.
Ik zie dat die lanpoort zich heeft ingesteld op 10Mbit. Maar ik zie de inverter nergens.
De groene led is aan bij de inverter en de oranje knippert.
Ook zie ik op de lanpoort wel verzonden en ontvangen data.
Reputatie 6
Badge +11
Er is dan zo te lezen wel electrische verbinding en er worden ook wel bits heen en weer verzonden. Maar als de inverter geen valide IP adres krijgt van de HG659 dan 'praten ze wel tegen elkaar' maar is er 'geen conversatie'.

Wil je verder komen, dan moet de inverter een IP adres hebben wat door de HG659 is uitgegeven of in ierder geval waarmee de HG659 kan omgaan. In het laaste geval kan het zijn dat de inverter al een vast IP adres had of heeft wat buiten het bereik van de HG659 ligt.

Maar hoe zie je in de HG659 welke apparaten wel door de HG659 van IP adres zijn voorzien?
Ik heb zelf geen HG659, is bij ieder apparaat weer anders, maar het is wel een voorwaarde dat je dat kan zien of begrijpen.
Inderdaad op elektrisch niveau is er verbinding, maar er is geen werkelijke communicatie.
De inverter heeft geen eigen IP adres zegt de manual alleen een MAC adres.
Als ik inlog en kijk naar het kopje thuisnetwerk, dan zie ik apparaten die gebruik maken van het netwerk WAN of LAN, de inverter zie ik echter niet.

If all this has not worked, there is also the possibility to assign a fixed IP address to the PowerRouter. However, this is not possible at the PowerRouter since it always gets its address from the Internet router. This setting must be made at the Internetrouter and is as follows:
This is what you do:

Each PowerRouter, like any other network device, has its own number, the Mac address.
These can be easily read in the InstallationTool by pushing the mouse arrow on the internet symbol. Alternatively, this address can also be found in the display menu under "Maintenance-> Status" and then press down with the arrow key.

https://powerrouter.zendesk.com/attachments/token/oDiDms4sulWwP9ITJ48LcauMI/?name=inline1732020778.png

With this number you can assign a fixed IP address to the PowerRouter (ie this MAC address) in the setting menu of the Internet router, which is always assigned to this MAC address when it logs on to the network. After that you only have to restart the PowerRouter and the Internetrouter.

Whether the PowerRouter has got an IP address, either statically via the MAC address or dynamically via DHCP server, one can determine in the same way how to retrieve the MAC address.


Nog een stukje manual
Reputatie 6
Badge +11
Het is duidelijk dat die inverter (PowerRouter) geen IP adres in het bereik van 192.168.1.x heeft of krijgt. Als het plaatje van die PowerRouter van jou is, dan gaat het met die 1.0.0.0 adressen in ieder geval niet werken, hoewel dat misschien voorbeelden zijn en niet echt de actuele waarden.
Als het wel de actuele waarden zijn dan zul je die moeten zien te wissen, wat ze zijn blijkbaar nu statisch. Kijk of er ergens een fabrieksreset te doen is van de PowerRouter, zodat ie daarna niet met verkeerde vaste waarden werkt maar vailide waarden vraagt en krijgt aan/van de HG659.
Nee dat is niet een plaatje van mijn powerrouter, Even verbonden via usb en er staat 169.254.1.1
Ja die reset heb ik al wat keren gedaan, maar zal het nog eens doen en kijken op dit adres dan verandert.
Dat adres wat er staat gaat niet veranderen, niet na herstarten, koude start of fabrieks reset.
Een ping geeft nul resultaat op dit IP.
Reputatie 6
Badge +11
Het IP adres 169.254.1.1 is een https://en.wikipedia.org/wiki/Link-local_address
Wat er op neer komt betekent dat de PowerRouter na een aantal mislukte pogingen om een IP adres te verkrijgen van de HG659 dit zichzelf toekent.

Blijkbaar gaat dus DHCP (server: HG659 client: PowerRouter) mis. DHCP is normaal een 4 staps onderhandeling maar die loopt dus spaak. Aan welke van de beide apparaten het nu ligt is erg moeilijk te zeggen zonder daadwerkelijk te kijken wat voor ethernet datapaketten er tussen de HG659 en de PowerRouter heen en weer gaan.

Je zou de PowerRouter eens aan een andere router kunnen hangen en kijken of ie dan wel een adres krijgt. Of de HG659 ook fabrieksresetten en hopen dat het dan wel goed gaat.

Een andere router is ook een laptop die met z'n WiFi aan het internet hangt en dan zijn WiFi internet-delen naar de ethernetpoort van de laptop en daaraan de PowerRouter hangen.
Dankjewel dat is een hele goeie.
Via de laptop even betere informatie als via modem.
De melding is inderdaad ongeldige IP configuratie.
Tja ik zeg het is de powerrouter, maar hoe deze weer op t pad te krijgen geen idee.
De router had ik al een fabrieksreset gegeven.
De powerrouter aan alle kanten gereset en spanningsloos gemaakt, moet denken wat ik daar nog meer mee kan.
Afgelopen zaterdag heeft het een paar uur gewerkt. Dat blijft vreemd voor mij. Nu dat IP adres er uit zien te krijgen. Misschien de installatiewizzard opnieuw draaien. Enige wat ik nog kan verzinnen.
Maar dankjewel voor de info, ik ga weer knoeien.
Reputatie 6
Badge +11
Je kan eens kijke of vragen bij de fabrikant of er misschien nieuwe firmware is. Als je via een USB kabel er wel bij of in kan. Dit soort apparaten heeft internetwerktechniek niet als speerpunt, maar ze moeten wel met allerhande routers overweg kunnen. Je kan met een netwerksniffer programma als wireshark e.v.t. kijken wat er over de ethernetkabel gaat, om zo te zien wat er in de DHCP handelingen verkeerd gaat, of of die uberhaupt wel plaats vindt.

Reageer