Beantwoord

UDM Pro krijgt geen ip adres meer sinds storing afgelopen maandag

  • 28 januari 2021
  • 25 reacties
  • 396 Bekeken

  • is een Master Poster
  • 21 reacties

Ik heb TMobile Thuis rechtstreeks met de glasvezel kabel aangesloten op mijn eigen router. Dit werkte perfect, tot de storing van afgelopen maandag. Ondanks diverse resets slaagt de UDM Pro er niet meer in om een DHCP lease te bemachtigen. Wat mij opvalt is dat ik voor de storing een 85.x adres had, en nu (via de standaard zyxel router) een 31.x adres krijg.

Daarnaast ervaar en zie ik ook gedurende de dag diverse onderbrekingen van de verbinding, via de standaard router.

Hoe ga ik de UDM Pro weer aan de praat krijgen??

Moderator edit: geen persoonsgegevens en gevoelige informatie in een openbaar bericht plaatsen, alsjeblieft.

icon

Beste antwoord door Jason 2 februari 2021, 09:37

Goedemorgen @ernste, sorry voor de latere reactie! 

Een MAC-release zorgt ervoor dat het MAC-adres van een modem opnieuw geregistreerd wordt op de aansluiting en sneller online komt bij het vervangen van een modem. Dit heeft enkel nut wanneer het modem omgeruild wordt, bijvoorbeeld tijdens het bezoek van een monteur. Wat eventueel een IP kan pushen op de UDM is een reprovisie van het modem en factory reset van de UDM Pro → de reprovisie voer ik nu uit, daar merk je op de achtergrond niets van. Met een reprovisie wordt de verbinding, of beter gezegd alle diensten (Internet, TV en vast Bellen) opnieuw naar het modem gestuurd.

Kun jij straks bevestigen of dit geholpen heeft? Alvast bedankt! 

UPDATE: wanneer ik een abonnement zoek met de opgegeven informatie in jouw profiel, kom ik een inactief abonnement tegen. Kun je mij een privébericht (de link is klikbaar) sturen met jouw postcode, huisnummer, geboortedatum en de laatste vier cijfers van je IBAN, alsjeblieft? Dan voer ik de reprovisie meteen uit!

Bekijk origineel

25 reacties

Hier de gegevens van de Zyxel met gevoelige informatie uitgegumd:

 

 

Reputatie 4
Badge +2

Hi @ernste

Laat de logging van de UDM niet zien waarom die geen ip adres meer krijgt of iets anders intressant waarom het niet werkt? 

 

 

Goed punt :)

 

Dit is de feedback als ik handmatig de DHCP client opstart:

 

/sbin/udhcpc --foreground --interface eth9.300 --script /usr/share/ubios-udapi-server/ubios-udhcpc-script
udhcpc: started, v1.31.1
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
....

 

En de discover gaat zo eindeloos door. Dit werkte overigens voor de storing prima, en aan de UDM kant is er niks gewijzigd.

Reputatie 4
Badge +2

Just to double check;

  • Werkt het ook niet als je de UDM op de converter aansluit?
  • Wat laat; ethtool -m eth9 zien als je de fiber aansluit

Ik neem aan dat de fiber poort wel gewoon up is als je de glasvezel aansluit ;) 

 

 

 

Via de converter werkt het deels, packet loss gaat dan richting 30%. Schijnt iets met jumbo frames te maken te hebben.

 

Hier de output van ethtool, ziet er volgens mij prima uit:

 

# ethtool -m eth9
Identifier : 0x03 (SFP)
Extended identifier : 0x04 (GBIC/SFP defined by 2-wire interface ID)
Connector : 0x01 (SC)
Transceiver codes : 0x00 0x00 0x00 0x02 0x00 0x00 0x00 0x00
Transceiver type : Ethernet: 1000BASE-LX
Encoding : 0x00 (unspecified)
BR, Nominal : 1300MBd
Rate identifier : 0xff (reserved or unknown)
Length (SMF,km) : 20km
Length (SMF) : 20000m
Length (50um) : 550m
Length (62.5um) : 550m
Length (Copper) : 0m
Length (OM3) : 2550m
Laser wavelength : 1310nm
Vendor name : DrayTek
Vendor OUI : 00:50:7f
Vendor PN : 455-0000007-01
Vendor rev : 1.0
Option values : 0x00 0x1a
Option : RX_LOS implemented
Option : TX_FAULT implemented
Option : TX_DISABLE implemented
BR margin, max : 100%
BR margin, min : 100%
Vendor SN : 010295C4027
Date code : 151202

 

En nog van de VLAN interface:

 

# ethtool eth9.300
Settings for eth9.300:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes

 

Reputatie 4
Badge +2

De output zit er inderdaad prima uit. 

Als de UDM wel een ip krijgt als die aan de converter hangt (los van de packet loss) lijkt wel als de sfp interface het probleem geeft. 

Hier heeft iemand ongeveer hetzelfde en heeft opgelost met de auto negotiation aan te passen.

Heb zelf helaas geen UDM (en geen glasvezel) dus ik kan het niet vergelijken :( 

 

Dank voor het meedenken!

Ik heb sinds de storing niet meer getest met de media converter, zal ik nog eens proberen.

Auto-negotiation heb ik idd ook al uitgezet (ook voor de storing stond dit al uit), maar dat lijkt lig voor de link status niets uit te maken.

Wellicht dat iemand van @TMobile ernaar kan kijken? Zoals ik al aangaf, voor de storing werkte deze setup prima, na de storing niet meer.

Ik kwam dit topic tegen. Wat is een Mac release, en kan dit wellicht in mijn situatie ook helpen? Ik heb de Zyxel al een factory reset gegeven, en daarna weer de UDM Pro aangesloten, maar het resultaat is hetzelfde.

Oh, en ik heb de helpdesk gebeld, en die wisten gelijk wat het probleem was, en hebben mij de IP adressen van de DNS server gegeven. Ik heb gevraagd of ze een case konden aanmaken en een 2e lijn ernaar konden laten kijken...

@Jason Even een atmention hier aangezien jij ook hebt geholpen in het topic zoals hierboven gelinkt mbt een mac release. Kun jij aangeven wat een mac release is, en of dat in mijn geval de DHCP toewijzing weer op gang zou kunnen helpen?

Reputatie 7
Badge +7

Goedemorgen @ernste, sorry voor de latere reactie! 

Een MAC-release zorgt ervoor dat het MAC-adres van een modem opnieuw geregistreerd wordt op de aansluiting en sneller online komt bij het vervangen van een modem. Dit heeft enkel nut wanneer het modem omgeruild wordt, bijvoorbeeld tijdens het bezoek van een monteur. Wat eventueel een IP kan pushen op de UDM is een reprovisie van het modem en factory reset van de UDM Pro → de reprovisie voer ik nu uit, daar merk je op de achtergrond niets van. Met een reprovisie wordt de verbinding, of beter gezegd alle diensten (Internet, TV en vast Bellen) opnieuw naar het modem gestuurd.

Kun jij straks bevestigen of dit geholpen heeft? Alvast bedankt! 

UPDATE: wanneer ik een abonnement zoek met de opgegeven informatie in jouw profiel, kom ik een inactief abonnement tegen. Kun je mij een privébericht (de link is klikbaar) sturen met jouw postcode, huisnummer, geboortedatum en de laatste vier cijfers van je IBAN, alsjeblieft? Dan voer ik de reprovisie meteen uit!

En we zijn weer back in business. Met dank aan @Jason die een reprovision heeft geregeld.

 

Heb net het IP vanuit de Zyxel gereleased, en de glasvezel rechtstreeks in de UDM Pro geprikt. Gelijk een nieuw DHCP adres gekregen en gaan.

 

Het viel mij trouwens wel op dat ik voor de storing een 85.x adres had, na de storing een 31.x adres, en nu weer een 85.x adres.

Hi @ernste goed dat je weer in business bent ;-) 

Ik zie dat je een UDM PRO hebt die je rechtstreeks aan de Glasvezel hebt hangen. Althans zien, dat natuurlijk niet maar ik begrijp uit deze thread dat dat zo is.

Vraagje heb je ook telefoon en TV of heb je alleen internet?

groet 330

Reputatie 6
Badge +2

Het viel mij trouwens wel op dat ik voor de storing een 85.x adres had, na de storing een 31.x adres, en nu weer een 85.x adres.

Hetzelfde gebeurt bij mij.

Via de Zyxel krijg ik een 85.x.x.x adres.
Als ik een Microtik RB750 aansluit komt er een adres in de 31.x.x.x tevoorschijn.

Er zal een scriptje draaien op de DHCP servers die de mac adressen bekijkt tijdens de aanvraag en het adres aan de hand van dat adres categoriseert.

Nog geen tijd genomen om het Zyxel mac adres in de Microtik te spoofen om te zien wat voor IP er dan uitgegeven wordt. (Als het werkt niet proberen te repareren)

Hallo @Jason . Na een herstart (gedwongen door stroomuitval) is weer hetzelfde aan de hand. Geen response van de DHCP server.

Kun jij weet je magic doen? Thanks!

Net contact gehad met @Vikram van de klantenservice. Helaas lag het interne support systeem eruit, dus kon hij mij niet direct helpen. Maar een Mac release zou eea weer moeten vlot trekken.

Misschien een gekke vraag heh maar zou het niet kunnen werken als je gewoon even het modem van TMT even rechtstreeks aan de MC hangt? Alleen om een op adres te forceren. Mss zeg ik wel domme dingen maar ik ga er van uit dat mensen die gewoon de standaard configuratie hebben bij stroomuitval of storing toch niet allemaal de helpdesk moeten bellen voor een reset?

@330Driver Dat is idd precies wat ik gedaan heb. En de Zyxel krijgt keurig een adres (wel weer in de 31.x reeks). Maar sluit ik dan de boel weer aan op de UDM Pro, dan krijgt ie geen adres. Ergo, TMT moet ergens achter de schermen iets doen waardoor mijn UDM Pro MAC adres weer geaccepteerd wordt.

 

Reputatie 7
Badge +8

Hi @ernste Jason is even lekker van een welverdiende korte vakantie aan het genieten maar als je mij een privébericht wil sturen met je volledige adres, geboortedatum en de laatste vier cijfers van het rekeningnummer dan voer ik de MAC-release graag voor je uit!

Reputatie 7
Badge +2

@ernste 

Ten eerste, ik heb hier denk ik 5 of 6 verschillende devices als router op de TMT glasvezel gehad, met IP’s van 31.x, 85.x en nu 143.x op de pfSense box. Dit alles zonder ook maar 1 keer een MAC-release nodig te hebben gehad.

Deze opmerking bevreemd mij iets

Via de converter werkt het deels, packet loss gaat dan richting 30%. Schijnt iets met jumbo frames te maken te hebben.

https://www.mirazon.com/jumbo-frames-do-you-really-need-them/

Lijkt mij sterk dat daar het probleem ligt, want eigenlijk staat dit default meestal op alle devices op disabled.

Hoe meet je deze packet loss en over hoeveel tijd is die meting?

Als dit over een korte periode is, dan heb ik eerder het vermoeden dat je fiberline een defect heeft.

Als je een TMT router aansluit, is dan je bandbreedte wel in orde en ook je packet loss minder?

 

@330Driver Dat is idd precies wat ik gedaan heb. En de Zyxel krijgt keurig een adres (wel weer in de 31.x reeks). Maar sluit ik dan de boel weer aan op de UDM Pro, dan krijgt ie geen adres. Ergo, TMT moet ergens achter de schermen iets doen waardoor mijn UDM Pro MAC adres weer geaccepteerd wordt.

 


Ok ;-) was alleen aan het meedenken ;-) Hopelijk is het gefixed nu.

Reputatie 1

@ernste

Kan je je Unifi-settings delen qua netwerk, poortinstellingen e.d.? Ik ben wel benieuwd. Ik heb nog geen problemen met mijn UDM Pro na 2 maanden.

@Bryan96 glasvezel direct via een Draytek transceiver in de WAN poort van de UDM Pro, ingesteld op 1000FD. VLAN 300 ingesteld op de WAN poort. Verder geen specifieke instelingen, maar als TMT DHCP server niet in ‘nieuwe modem’ status staat voor jouw pijp, dan krijg je dus geen adres.

 

@330Driver Dank voor het meedenken, zie nu dat mijn post ietwat kortaf over komt, was niet zo bedoeld 😬

 

@Pieter_B goed punt. Packet loss meet ik via smoke Ping. Fiber op zich is prima denk ik, want nu wel weer goede waarden (met UDM PRO rechtstreeks op glas ipv UTP wan). Ik heb overigens ook jouw ervaring gehad op een andere locatie, maar sinds ik op een nieuw adres woon, waar het netwerk door KPN is aangelegd, heb ik dit issue.

@ernste Nou inderdaad ik was totaal geshockeerd en dagen van slag heb er gewoonweg niet van kunnen slapen en durfde ook niets meer te schrijven :sweat_smile::sweat_smile::stuck_out_tongue_winking_eye:  no worries my friend!

 

Reageer