Port forwarding op de Huawei HG659


Reputatie 7
Badge +9
  • T-Mobile Moderator
  • 2492 reacties

Hoi,

Mijn naam is Michael en ik ben werkzaam bij T-Mobile voor thuis. Mijn expertise ligt onder andere op klant apparatuur en zodoende maak ik dus ook dit topic aan.

Eens in de zoveel tijd kijk ik hier wel eens rond en zie veel terugkerende vragen betreft het portforwarding. Nu zijn hier al een paar topics over maar ik ga proberen dit zo makkelijk mogelijk uit te leggen.

Wanneer/Waarom port forwarden?

  • Sommige applicaties willen vanaf het internet toegang tot een apparaat die zich in het LAN bevindt.
  • Indien je een server wil hosten voor vrienden (bijv. o.a. minecraft)
  • Indien je de juiste poorten niet ‘forward’ naar het juiste apparaat kan het zijn dat een verbinding niet opgezet kan worden.


Wat heb je nodig?

 

  • Welke poorten wil je ‘forwarden’
  • Naar welk apparaat wil je het ‘forwarden’
  • Niet noodzakelijk maar handig: betreft het een TCP of UDP verbinding

Deze uitleg gaat uit van de standaardconfiguratie van de router. Indien je al wijzigingen hebt aangebracht kan het zijn dat sommige stappen niet meer kloppen

Hoe werkt het?
In dit voorbeeld gaan we de poorten forwarden voor een Minecraft server. Een Minecraft server gebruikt standaard poort 25565.

1. Open je favoriete browser (Chrome, internet explorer, etc)
2. Vul in de URL balk van de browser het volgende in : http://192.168.1.1/
3. Je krijgt het inlogscherm van de router te zien.
4. Vul bij gebruikersnaam: user in.
5. Het wachtwoord kun je achterop de Huawei HG659 vinden.

 

 

d525d7d4-a05e-476c-9496-ffcaf5237c45.jpg


4. Druk vervolgens op aanmelden.
5. Je bevindt je nu in de homepage van de Huawei HG659. Druk vervolgens op de knop internet. Selecteer dan Doorsturen

 

 

70005e7c-2368-4867-b50a-25eeeb1bbb5e.jpg

 


6. Klik op Port Mapping en kies voor Nieuwe Port mapping.
7. Geef het een toepassende naam. In dit geval kies ik voor minecraft server.
8. Kies bij applicatie voor de optie “Toepassing voor Port mapping toevoegen”
9. Scroll naar onder en klik op poorttoepassing toevoegen.
10. Geef een naam op. In dit geval kies ik weer voor minecraftserver.
11. Bij interne en externe poort kun je een range opgeven (bijv. 1000 t/m 1005) of een enkele poort (1000 t/m 1000)

 

 

e6440501-25e8-4713-85cb-b059be1167b0.jpg


12. Bij protocol kun je kiezen voor TCP of UDP. Weet je het niet zeker kies dan voor TCP/UDP.
13. Klik vervolgens op opslaan.
14. Vervolgens kies je de gemaakte toepassing. In mijn geval heet deze dus minecraftserver. Kies hierbij ook het apparaat dat de applicatie draait.

 

 

0dbcd5fb-cd49-4df7-b13e-9e5b858c1bb9.jpg


15. Druk op opslaan. Je bent nu klaar.

Ik zal dit topic in de gaten houden. Eventuele vragen zal ik proberen te beantwoorden.

Groeten,
Michael

Moderator tip: Bekijk ook eens dit topic: Portforwarding 80 en 443 op Huawei modem

 


168 reacties

Reputatie 7
Badge +8
Hi allen, hier een update over de NAT loopback:

Momenteel is NAT loopback geen actieve feature op de HG659. De makkelijkste manier is om in plaats daarvan 2 URL’s te gebruiken. Eentje voor wanneer het interne netwerk en een andere voor buitenaf.
Twee andere opties voor de echte hobbyisten zijn:

- De Host file aanpassen
- Zelf een Lokale DNS server hosten en hier de verwijzing maken

We gaan daarnaast contact opnemen met de leverancier om te kijken of dit iets is wat makkelijk aan te zetten valt en zo ja of we dit veilig kunnen doen!
Hey Robin, we hebben contact gehad met onze leverancier en zij geven aan dat het niet mogelijk is om NAT loopback te implementeren in de Huawei HG659. Waarschijnlijk hoopte je op een ander antwoord maar NAT loopback gaat er vooralsnog dus niet komen.

Inderdaad niet het antwoord waar ik op hoopte...
Ik hoop dat dit wordt meegenomen in de wensenlijst voor de opvolger van dit modem.
Gr Robin
Geweldig bedankt Michael! Dit werkt! Helder en duidelijk beschreven, letterlijk doen wat er staat, dan lukt het. Super!
Hey Robin, we hebben contact gehad met onze leverancier en zij geven aan dat het niet mogelijk is om NAT loopback te implementeren in de Huawei HG659. Waarschijnlijk hoopte je op een ander antwoord maar NAT loopback gaat er vooralsnog dus niet komen.

In tegenstelling tot wat ik op dit forum lees heb ik vooralsnog weinig problemen met portforwarding om de verschillende services die op mijn interne netwerk draaien (diverse dingen op mijn Synology NAS zoals DS Note, Photostation, FTP-server maar ook dingen zoals Plex, Tautulli op mijn MacMini) te kunnen bereiken van buitenaf.

Wifi bereik op de bovenverdieping is zoveel verbeterd dat ik geen mopperende ega en kind meer heb 😆

Alleen het gemis van NAT Loopback is dermate ruk dat ik vanavond toch maar weer een andere router (Asus RT-AC68U) ga plaatsen ipv de HG659B.

Ik geloof eerlijk gezegd niet dat het niet mogelijk zou zijn om NAT Loopback te implementeren (ja de firmware zal aangepast moeten worden door de fabrikant, maar het blijft een software iets). Het zal een kwestie van willen zijn vanuit Huawei, want de eerder genoemde RT-AC68U uit begin 2014 kan het namelijk wel.
Werkt bij mij niet. .

ik wil zelf een webserver hosten. maar na al die stappen. komt alleen de huawei modem in zicht ?? hoe kan ik mijn eigen website laten zien ??

, als ik naar mijn internet ip adres ga, zie ik alleen de website van de router.. 😞
Reputatie 7
Badge +8
@tmoesel Goeie tip! @Roorda IPv6 ondersteunen we op dit moment nog niet officieel dus het zou het makkelijkst zijn om inderdaad IPv6 uit te zetten zoals tmoesel aangeeft en het op die manier te proberen.
Ik kan niet anders zeggen dan dat ik erg teleurgesteld ben met de port-forward functionaliteit van dit modem. Na jarenlang probleemloos mijn thuisserver gebruikt te hebben op een KPN Modem verwachtte ik dat overstappen naar T Mobile een fluitje van een cent zou zijn. Ik wist immers alle te forwarden poorten al en kon de oude instellingen simpelweg overnemen. Dan blijkt dat het forwarden van ports bij deze modem het mac-adres van de host moet worden ingesteld, wat op zich geen probleem is.

Maar jammergenoeg werkt het simpelweg niet. Of het aan IPv6 ligt weet ik niet zeker, maar los daarvan vind ik het eigenlijk onacceptabel dat zo'n moderne standaard niet ondersteund wordt. Wanneer kunnen we verwachten dat IPv6 wél wordt ondersteund? Een genoemde workaround is het uitzetten van IPv6, maar waar dit moet gebeuren is me niet duidelijk. In de modemsoftware of op de host die geforward moet worden?

Ik ben tevreden met de kwaliteit van jullie dienst en de verbinding is prima en stabiel. Maar voor de wat meer technische gebruikers lijkt port-forwarding me een essentiele functionaliteit van een modem en ik ben eigenlijk verbaasd om te zien dat een partij als T-Mobile dit gewoon niet goed op orde heeft. Ook in andere topics en op andere fora zoals Tweakers wordt hierover geklaagd.

Mocht iemand een manier hebben gevonden om het alsnog werkend te krijgen, dan hoor ik het natuurlijk graag 🙂
Reputatie 6
Badge +11
@jeemy12
Wellicht moet dit topic wat ge-update worden door T-Mobile, ik heb zelf niet een dergelijk vastelijn modem, maar het lijkt op:
- poort 443 is in dit modem al geclaimed voor beheer van het modem zelf vanaf extern adres.
- zie boven, mijn eerdere post m.b.t. IPv6

Probeer ook in ieder geval een URL met direct het IPv4 (ik neem aan dat je geen IPv6 beoogd) adress, zodat je e.v.t. DNS issues vermijdt. Ik weet niet wat transip doet, b.v. hoe snel de updates worden gedaan.
Op verzoek van de webcare even een berichtje.
https://twitter.com/tmobile_webcare/status/988024674574618625

Ik wil een poort fowarden, maar ik kan niets toewijzen, omdat de dropdowns niet zichtbaar worden/leeg blijven. Ik heb de meest voorkomende browsers geprobeerd, (IE/EDGE/Chrome/FF) alle blockers uitgezet, meerdere devices (Windows 10, android en iOS), maar overal hetzelfde. Waar kan dit aan liggen?

Het heeft altijd gewerkt, maar sinds kort niet meer (volgens mij minder dan een maand geleden werkte het nog)

Maar het stomme is, als ik 'een nieuw apparaat voor portmapping' aanmaak, dan krijg ik wel het device te zien dat ik wil forwarden. Deze moet ik even openen en opslaan, en dan lukt het wel.



Maar als ik dat bij interne host wil doen, dan zegt hij dat het apparaat al bestaat.



Maar ik kan het niet kiezen in het menu, en ook verwijderen heeft geen zin, want dat pakt hij niet.



Het device is goed aangesloten. Via het lokale netwerk op de camera kijken kan wel, maar extern dus niet.

Waarom heeft dit altijd gewerkt en is het in ineens niet meer mogelijk? Is er een update geweest misschien?

Alvast bedankt!
Gisteren ook uren bezig geweest met port forwards etc. zonder succes helaas.

Tot ik vanmorgen vanaf een computer buiten mijn netwerk de forward testte, en het opeens prima bleek te werken.

Dus, om een of andere vage reden werken port-forwards alleen van buitenaf! Hebben meer mensen hier hetzelfde? Dus vanaf het interne netwerk werkt de forward niet, vanaf een externe computer wel.

T-Mobile, zouden jullie wellicht kunnen kijken of dit te fixen is? Graag zou ik m'n HomeAssistant interface overal via dezelfde url gebruiken...
Aanvulling: blijkbaar heb je voor het benaderen van een port forward vanaf je lokaal netwerk NAT loopback ondersteuning nodig, iets wat de HG659 niet ondersteunt. Erg jammer dit...

Weet iemand hier een oplossing voor?
Inmiddels na drie dagen stoeien heb ik nu wel verbinding met het systeem.
Op de lokale machine inderdaad de host tabel aangepast.
Maar op een tweede machine werkt dat niet !!
Hij komt dan steeds weer in het menu van de router terecht.
Het lijkt mij toch dat dit echt een router probleem is
Met de Zyxel van Telfort geen last mee gehad.
Hallo allemaal. Ik dacht; ik check even of er inmiddels een oplossing is gekomen, misschien in de vorm van een update. Maar nee hoor, het werkt nog steeds niet.

Ik vind het echt belachelijk dat men hier niet in staat is is om zo'n basic functie van een router fatsoenlijk werkend te krijgen, zonder allerlei ingewikkelde omwegen. Ik zie hier meerdere gebruikers die het zonder problemen werkend gekregen hebben bij andere providers en nu ineens problemen hebben. Dit is ook bij mij het geval. Los dit nou eens op!
Het probleem is al opgelost
Poort open gezet werkt nog steeds niet!
ICT Nerd naar laten kijken ook niet aan de praat gekregen!

Modem gerest ook geen oplossing? Ik snap niet dat zo rare modem geleverd wordt bij andere providerd 0 problemen gehad met port openzetten. nog tips? anders ga ik per direct opzoek naar een andere oplossing. 🙂








Ik heb van alles geprobeerd de HG659 modem is gewoon troep! Graag een oplossing?
Als ik een Fritz!box moet gaan kopen voor 170 euro voor alleen 1 poort open te kunnen zetten is belachelijk.....

@Brian @tmoesel @Sander
Hey Robin, we hebben contact gehad met onze leverancier en zij geven aan dat het niet mogelijk is om NAT loopback te implementeren in de Huawei HG659. Waarschijnlijk hoopte je op een ander antwoord maar NAT loopback gaat er vooralsnog dus niet komen.

Kom op jongens! Even aandringen bij de leverancier ;)
Dit zou een basis functionaliteit moeten zijn om naar wens aan/uit te kunnen zetten in de modem.
Reputatie 6
Badge +11
Ik snap het! Tnx! Maar vrij lastig om dan makkelijk een pi-hole te gebruiken.. Dan moet je hem dus steeds aan- of uitzetten.
Misschien kun je zaken vrij radicaal omgooien. Je Airport wellicht als hoofdrouter gebruiken (als die NAT loopback kan) en dan in de HG659 de Airport als DMZ host. Of de hele HG659 vervangen door eigen modem(router). Met glasvezel is dat vrij eenvoudig, met DSL wat lastiger.
Reputatie 7
Badge +2
Hallo @EricDec2018

In dit betreffende topic heb ik een stap voor stap portforwarding opgezet (het antwoord), hopelijk kom je er dan wel uit.
Als voorbeeld heb ik daar poort 1221 opgezet om te openen via TCP voor een server
Reputatie 7
Badge +2

@SergeiK 

I do not know if you had seen this topic, where i explain in a step by step how to proceed. 

Reputatie 7
Badge +6

[Wow!]

Wat een prachttopic! Er zijn vele vragen die gaan over portforwarding op dit Forum. Zo'n gedegen en heldere uitleg komt zeker van pas. Hier ga ik erg veel plezier van hebben! Heul erg bedankt.

[/Wow!]

Hallo,

Mijn naam is (tevens) Michael en ik heb een probleem.

Ik volgde alles in deze instructies, met nog een paar dingen die het in de weg zouden kunnen staan omzeild te hebben. en NOG kan mijn port forwarding NIET gezien worden.

Ik probeerde alles, van uitzonderingen in firewalls tot het proberen van rare truckjes (maar niet te raar, ik blijft veilig).

Mischien is er een optie doe moet aangevinkt worden? is er een manier dat mijn modem zijn firewal mij in de weg zit? moet ik juist iets deactiveren? ik word hier al 2 dagen gek van. ik wil gewoon minecraft spelen met mijn broer! hoe lastig kan dit zijn! help!
Reputatie 2
Hallo,

Mijn naam is (tevens) Michael en ik heb een probleem.

Ik volgde alles in deze instructies, met nog een paar dingen die het in de weg zouden kunnen staan omzeild te hebben. en NOG kan mijn port forwarding NIET gezien worden.

Ik probeerde alles, van uitzonderingen in firewalls tot het proberen van rare truckjes (maar niet te raar, ik blijft veilig).

Mischien is er een optie doe moet aangevinkt worden? is er een manier dat mijn modem zijn firewal mij in de weg zit? moet ik juist iets deactiveren? ik word hier al 2 dagen gek van. ik wil gewoon minecraft spelen met mijn broer! hoe lastig kan dit zijn! help!


Hi,

Ik zou even het volgende controleren:
  • Heb je bij internal host (stap 14) wel het apparaat gekozen waarop de minecraft server actief is? Dit kan je eigen PC zijn maar hoeft natuurlijk niet.
  • Er zijn verschillende minecraft servers. Het kan zijn dat jou variant misschien andere poorten gebruikt. Check dit even voor de zekerheid.

Je zou voor de rest op de router(!) niets hoeven te doen. Het zou nog kunnen dat een firewall op je PC nog iets blokkeert. De firewall van Windows staat bijv. standaard aan en wil nog wel eens het e.e.a. blokkeren.

Grt,
Michael
Reputatie 7
Badge +8
Goeie tips Michael! @andere Michael is het inmiddels gelukt? 🙂
Reputatie 6
Badge +11
@Roorda
Het symptoom dat je beschrijft treedt o.a. op als je via een IPv6 een connectie poging op je DSLmodemrouter vanaf extern op het publieke adres van je DSLmodemrouter probeert te krijgen. De portforwarding hier beschreven is IPv4 only maar voor zover ik lees heeft T-Mobile Thuis IPv6 wel aan staan.

Moderne apparaten geven soms als standaard de voorkeur aan IPv6 connecties. Dus maak alles dualstack, ook de portforwarding als dat kan in de DSLmodemrouter of zet IPv6 uit in alle betrokken apparaten.
sorry voor de late reactie, maar ik ben achter een paar dingen gekomen die wellicht zouden kunnen helpen (geen van deze dingen heeft gewerkt) ik probeer nu een nieuwe LAN apparaat aan te maken in mijn modem om het nog eens te proberen, maar het accepteert mijn MAC adres niet?

ik begin me af te vragen of het probleem is dat ik voor dit letterlijk een router tussen mijn modem en mijn PC in moet zetten voor dit om te werken... suggesties?

Reageer