Eigen router, Zyxel T-50, slecht internet na dagen/weken

  • 10 August 2022
  • 2 reacties
  • 87 Bekeken

Hi all,

graag deel ik met jullie mijn oplossing voor mijn probleem met een slechte internetverbinding. De oplossing bestond bij mij uit het verhogen van “het aantal NAT-sessie per host” van 2048 naar 8192 in m’n Zyxel T-50 modem. 

Het actueel aantal sessies is te bekijken via het navigatie pad: > Systeemmonitor > Verkeersstatus > NAT. Bij mij stond daar 1 apparaat (m’n router/firewall) met 2048 connecties

De waarde is aan te passen via het navigatie pad: > Netwerkinstellingen > NAT > Sessies.

Ik ga ervan uit dat 2048 connecties normaliter voldoende zou moeten zijn per apparaat. Echter vanwege dat ik al m’n internetverkeer via een eigen router/firewall laat verlopen, verlopen alle connecties van m’n apparaten via deze enkele host. 

In de praktijk merkte ik dat soms het opvragen van een pagina of het starten van een app een probleem gaf. Na enkele minuten was het probleem even weg. Maar het probleem kwam daarna steeds regelmatiger voor.

Helaas heeft me dit meerdere maanden van ergenis gegeven. Ook de helpdesk heeft me nooit verwezen naar deze limiet van 2048 connecties. Achteraf gezien is het eigenlijk heel logisch dat dit het probleem was.

Dus… Heb je een eigen firewall/router achter je Zyxel T-50 modem staan? Wordt je internet na verloop van tijd minder stabiel? Dan even deze waarde controleren en/of ophogen..

 

Voor het routeren van “alle” traffic via m’n eigen router/firewall, heb ik:

  • In de Zyxel T-50 modem een MAC-filter ingesteld om alleen specifieke Mac-adressen toe te staan: “Mac-adresfilter=ingeschakeld”, “MAC-restrictiemodem=toestaan”. In het filter heb ik het MAC-adres van m’n firewall/router en Amino TV-box opgenomen. 
  • In m’n eigen router/firewall heb ik een MAC-filter ingesteld om het MAC-adres van de Amino TV-box te blokkeren.
  • In m’n eigen router/firewall staat de DHCP-server ingeschakeld. En dus ook in de Zyxel T-50.
  • DNS queries verlopen ook via m’n eigen router/firewall.

Bovenstaande constructie zorgt ervoor dat ik niet aan de slag hoef met VLAN instellingen. Wel is het zo dat er sprake is van double-NAT, wat niet optimaal is. 

 

Hope this helps…

groet, Sander


2 reacties

Reputatie 7
Badge +2

Hier opstelling met Zyxel DMZ → pfSense router firewall (virtueel op ESXI)

Geen MAC filtering toegepast.

Bij de verkeerstatus naar de pfSense staan op dit moment 132 open sessies. Dus 2048 lijkt een goede (default) waarde.

Al bijna 3 jaar deze setting en geen vertragingen of dergelijke bemerkt. Maar hier wordt (bijna) niet gedownload van payservers of dergelijke.
Is je (@GrumpyMeow) eigen router/firewall heel erg behoudend na het opzetten van verbindingen of staan er veel heel download kanalen open.

Een dergelijke tip is altijd meer dan welkom al zal de standaard user niet snel aan die limiet komen.

Tsja, de opmerking dat de helpdesk je hiermee niet verder kon helpen is niet vreemd. Hoeveel mensen zullen bij een trage verbinding opmerken dat ze tegen de limiet van een router instelling lopen. En hoeveel netwerkverkeer moet er gegenereerd worden voor deze bereikt wordt.
Ik zal komende dagen/weken het aantal sessies dat er open staan eens in de gaten houden als “home” user.

Vooralsnog werkt m’n internet nog goed na het doen van deze aanpassing. Zojuist even gekeken naar het aantal sessies: 388. Ik heb wel +/- 70 netwerk apparaten binnen m’n LAN. Veel fysieke apparaten t.b.v. m’n huisautomatisering, maar ook veel virtuele devices (in Proxmox). Theoretisch kan je dan beredeneren dat met een eigen router ik 70x eerder de 2048 ga bereiken.

De 2048 actieve sessies was wanneer een gezin bij ons op bezoek was. Er wordt dan veel Minecraft en Roblox gespeeld op Android en iOS apparaten. Wellicht dat die apps veel sessies openen. 

Anyway. Het is het proberen waard wanneer je vergelijkbare issues hebt.

Reageer