Beantwoord

Pfsense T-Mobile glasvezel

  • 1 September 2022
  • 11 reacties
  • 389 Bekeken

  • is een nieuwe Poster
  • 5 reacties

Sinds deze week heb ik glasvezel van T-mobile. Ik heb al een eigen router met pfsense. Nu probeer ik mijn eigen router te gebruiken het de router van T-mobile ertussenuit te halen.

Ik heb hiervoor een VLAN300 toegevoegd op de WAN-interface en daarna de juiste interface assigned. Ik krijg echter geen Ip-adres als ik mijn router direct op de media converter aansluit. Ook heb ik geprobeerd om het MAC-adres van de router van T-mobile te klonen, echter zonder succes. Ik heb deze instellingen gedaan:

 

Moet T-mobile nog iets instellen aan hun kant? Of doe ik toch wat fout?

icon

Beste antwoord door JDM 13 September 2022, 19:15

Bekijk origineel

11 reacties

Reputatie 7
Badge +20

Hallo @JDM 

Hij zou moeten werken zonder dat je iets door hoeft te geven. Heb je de mediaconverter al eens even van het stroom gehaald of laat hem anders eens een uurtje aangesloten.

Reputatie 7
Badge +9

Hoi @JDM, een terechte vraag en leuk dat je je eigen modem wilt aansluiten! We hebben in onze Wiki een handige how-to beschreven voor het installeren van het eigen modem: 

Liggend aan de type verbinding, kan daarbij de instelling verschillen. Brengt dit topic je verder op weg? 

Bedankt alvast voor het meedenken. Ik heb afgelopen 24 uur de router aangesloten gehad, en de mediaconverter meerdere keren herstart. Helaas zonder effect. DHCP staat aan op WAN.

Dit zijn de instellingen:

 

 

 

Waar gaat het mis?

Reputatie 7
Badge +2

@JDM

Heb je al eens gekeken wat er in je logfile onder DHCP staat?

Hier zie je het volgende gebeuren (even een reboot gegeven voor hier)

 

Is het een Netgate device of een eigenbouw, we hebben hier wel eens vaker problen voorbij zien komen met de pfsense Netgate devices.

Hier is het een zelfbouw, PC met 4 poort Intel NIC. Hier geen enkele issue tot nu toe meegemaakt.

Ik gebruik een qotom met 4x Intel NIC, waarop pfsense is gevirtualiseerd via esxi.

Dit is een stukje log:

 

Reputatie 7
Badge +2

De juiste interface toegewezen aan de wan verbinding?

Verkeerde UTP lan-poort via Esxi?

Er komt zo te zien helemaal GEEN reactie op de DHCP request.

Reputatie 7
Badge +2

@JDM 

Neem aan dat je al deze stappen hebt doorlopen, door het aanmaken van een extra vSwitch, om daarna de port groups aan te maken.

Wat @yalerta ook al aangeeft, heb je wel de juiste poort (MAC) gekoppeld als WAN?

Het lukt nu niet om screenshots te uploaden, ik krijg een foutmelding. Maar ik heb 1x WAN- en 1x LAN-interface in ESXI en verbonden aan pfsense (en aan elk een fysieke ethernetpoort). Uit het filmpje maak ik op dat ik in ESXI op de WAN-interface ook VLAM 300 moet instellen?

Gek genoeg had ik VLAN 300 in ESXI en pfsense ingesteld, dat leek niet te werken. Toen ik de router van T-mobile er weer tussen had gezet, en weer achter de pc ging zitten, leek Pfsense ineens wel een extern IP-adres van T-mobile gekregen te hebben, dit was ook zichtbaar in de DHCP-log. Daarna is het niet meer gelukt dit voor elkaar te krijgen, en krijg ik in de DHCP-log ook geen antwoord meer op de DHCP-requests.

Images uploaden lukt nu wel:

Initieel had ik het als volgt:

Onder WAN heb ik dus VLAN ID 300 ingesteld, echter zonder succes.

Reputatie 7
Badge +2

@JDM 

Hou er rekening mee op welke plek je die VLAN 300 instelt, want doe je dat op vSwitch lvl, dan zal de vSwitch poort output UNTAGGED zijn naar je VM.

Om de vSwitch poort zich te laten gedragen als een TRUNK, moet je hem een VLAN 4095. Hiermee komt de VLAN 300 op de VM terecht .. wat in dit geval dus pfsense is.

Dus als je vSwitch lvl VLAN doet, zal je pfsense dus een UNTAGGED netwerk zien .. en is daar dus geen VLAN 300 setting meer nodig.

Dit was zo even uit de losse pols …..

Ik heb het werkend gekregen! Enige wat nodig was was om vlan 300 aan te maken op de WAN in ESXI. Ik hoefde verder niets in te stellen in Pfsense.

Bedankt allemaal voor het meedenken!

Reageer