Beantwoord

Port Forwarding VMG8825-T50

  • 28 December 2021
  • 73 reacties
  • 1303 Bekeken

Reputatie 1
  • is een Master Poster
  • 10 reacties

Al een tijdje ben ik bezig om wat poorten open te zetten op mijn zyxel router. Tot op heden is dit echter niet gelukt ondanks alle hulp die al geboden is bij voorvangers op de community. Hier onder een foto hoe ik de instellingen heb gemaakt. 

Wie o wie kan mij helpen mijn poorten open te zetten. Alvast bedankt!

icon

Beste antwoord door Waqqas 28 December 2021, 16:23

Bekijk origineel

This topic has been closed for comments

73 reacties

Reputatie 1

De ONT is alleen maar een glas naar ethernet omzetting. Zeg maar OSI model laag 1. Daar wordt dus niets met IP adressen of poorten gedaan.

Ok, dus die kan ik ook uitsluiten in dit verhaal. Wat zou het dan kunnen zijn? 

Reputatie 7
Badge +9

Hoi @San2022 ,

Terechte vragen. Graag wil ik onze NAS-experts @Gerrit078 en @Pieter_B vragen om een kijkje te nemen naar jouw vraag. Ik weet zeker dat we tot een oplossing komen.

Reputatie 1

Hoi @San2022 ,

Terechte vragen. Graag wil ik onze NAS-experts @Gerrit078 en @Pieter_B vragen om een kijkje te nemen naar jouw vraag. Ik weet zeker dat we tot een oplossing komen.

Dat zou super zijn. Volgens mij zijn er tot nu toe een aantal zaken die voorlopig vastgesteld kunnen lijken te worden:

  • Het ligt niet aan het ONT kastje
  • Het ligt niet aan de router??? (Omdat het aansluiten van een Netgear R7000 ook dezelfde issues heeft. Wel functionerend internet, maar geen poorten die open gaan / de status ‘filtered’ houden volgens zenmap)

Echter, het moet wel aan 1 van de 2 liggen, aangezien de voordeur gewoon dicht blijft. 

Reputatie 1

Even een check @Boris zou het te maken kunnen hebben met het IPv4 adres dat vanuit T-mobile wordt toegewezen? 

Ik vond dit :https://serverfault.com/questions/995896/port-is-filtered-after-port-forward en wordt doorgelinked naar https://en.wikipedia.org/wiki/Carrier-grade_NAT . Dit verhaal komt overeen met het verhaal dat ik van een techneut vernam. 

Reputatie 7
Badge +14

Goedemiddag @San2022, als alle instellingen voor de NAT/forwarding correct geconfigureerd zijn, neig je al gauw naar een probleem binnen de apparatuur, maar ook dat lijkt hier niet het issue te zijn - ik vind het een lastige en zet jouw vraag net als Boris uit bij de deskundigen. Je hebt maar aan hun expertise dan ons giswerk - ook al weten ook wij wel degelijk één en ander van port forwarding natuurlijk! 😄

Het zou kunnen dat de IPv4 roet in het eten gooit trouwens, maar dan zou het mijns inziens eerder ontstaan doordat het IP niet overeenkomt met hoe het in de NAT/forwarding ingesteld is en daar lijkt de oorzaak ook niet te liggen.

Reputatie 1

Hi @Jason dank voor je bericht. Ik ben het wel met je eens, maar toch vind ik het moeilijk te begrijpen waarom het zowel bij de Zyxel router niet lukt als bij de Netgear router. Dt is moeilijk te verklaren op het niveau van de router zelf?

Reputatie 7
Badge +2

Hi @Jason dank voor je bericht. Ik ben het wel met je eens, maar toch vind ik het moeilijk te begrijpen waarom het zowel bij de Zyxel router niet lukt als bij de Netgear router. Dt is moeilijk te verklaren op het niveau van de router zelf?

Of in de Synology ?

Hi @Jason dank voor je bericht. Ik ben het wel met je eens, maar toch vind ik het moeilijk te begrijpen waarom het zowel bij de Zyxel router niet lukt als bij de Netgear router. Dt is moeilijk te verklaren op het niveau van de router zelf?

Wat laat grc.com zien?

→ grc.com

→ Scroll omlaag tot je de grote tekst "Hotspots” ziet staan, daaronder klik je op;

→ ShieldsUP!

→ Proceed

→ In de tekstbox type je de poorten die je wilt testen;

 

→ Vervolgens klikken op de button "Custom Port Probe

 

OPEN = Poort bereikbaar

CLOSED = Poort bereikbaar maar service erachter is niet ingeschakeld of de port-forward verwijst naar het verkeerd IP-Adres.

STEALTH = Poort is onbereikbaar, de portscan is tegen de Firewall aangelopen die iedere vorm van verbinden afwijst.

 

Reputatie 1

Hi @Gerrit078 

Thanks, zie 

 

Hi @Gerrit078 

Thanks, zie 

 

Getest met je eigen modem of de Zyxel?

Public IP trouwens beginnend met 87.208 ?

Reputatie 1

Hi @Gerrit078 

Thanks, zie 

 

Getest met je eigen modem of de Zyxel?

Public IP trouwens beginnend met 87.208 ?

Getest met R7000. Nee, ip adres begint met 85.144

Reputatie 7
Badge +2

@San2022

Kijk eens of deze setting in je router eventueel toch verkeer tegen aan het houden is, want echt .. WANIP:poort → NASIP:poort met een eenvoudige poort forwarding rule moeten werken.

Zelf pfsense, die best wel zinnig is soms, werk het met 1 regel gewoon om een translation te doen van Ext-poort naar Int-poort 5000

 

Reputatie 1

Hi @Pieter_B haha ja ik begrijp er ook helemaal niets van. Hopelijk doe ik iets doms. 

Heb de instelling in de R7000 veranderd, zie: 

 

Vervolgens heb ik weer een probe gedaan: 

Helaas.. 

 

Voor het beeld, ook nog even een plaatje van de port forwarding regels. 

 

Reputatie 1

Zal ik de Zyxel er weer eens achterhangen?

Reputatie 7
Badge +2

@San2022 

Die NAS is direct aangesloten op de Netgear/ Zyxel, of zit er nog iets tussen?

Log je via je webbrowser ook in op dat IP met het betreffende poortnummer?

Blijf het raar vinden dat je STEALTH krijgt, wat min of meer aangeeft dat er wel een soort van reactie komt vanuit je netwerk. Zou er geen enkele reactie komen, zou er CLOSED staan. En als de gewenste reactie wel komt, dan zou er OPEN staan.

Zie dat je ook een FTP server open hebt gezet, als je die poort vai GRC controleert, wat krijg je dan?

Reputatie 1

@Pieter_B 

De NAS is “in principe” direct aangesloten op de router. Er zit wel een switch tussen, maar dat heeft m.i. geen effect. 

Momenteel kan ik alleen maar inloggen via interne LAN, dus 192.168.1.15. Dan spring hij automatisch naar poort 5000 met google chrome en kom ik gewoon op de NAS. Ook als ik naar 192.168.1.15:5000 ga kom ik bij NAS. De poort van NAS is gewoon open. 

Als ik poort 21 scan, krijg ik ook ‘stealth’. 

Het is idd gek. waarom worden de poorten als stealth of filtered gezien, en zijn ze niet gewoon open. En hoe kan het dat dit ook zo was bij de Zyxel router. Aan de NAS lijkt het niet te liggen. 

 

Reputatie 7
Badge +2

@San2022

Heb je toevallig ook ‘Quickconnect’ enabled of heb je onder de andere tabs iets ingesteld?

Dit kan je vinden onder Control panel → External access

Als dat zo is, verwijder of disable dat.

Reputatie 7
Badge +2

@Pieter_B

De NAS is “in principe” direct aangesloten op de router. Er zit wel een switch tussen, maar dat heeft m.i. geen effect. 

Momenteel kan ik alleen maar inloggen via interne LAN, dus 192.168.1.15. Dan spring hij automatisch naar poort 5000 met google chrome en kom ik gewoon op de NAS. Ook als ik naar 192.168.1.15:5000 ga kom ik bij NAS. De poort van NAS is gewoon open. 

Als ik poort 21 scan, krijg ik ook ‘stealth’. 

Het is idd gek. waarom worden de poorten als stealth of filtered gezien, en zijn ze niet gewoon open. En hoe kan het dat dit ook zo was bij de Zyxel router. Aan de NAS lijkt het niet te liggen. 

 

 

Misschien ben ik wel dom(bo) Maar in de schermdump van de instellingen zie ik 192.168.1.50
in de gequote reactie zie ik 192.168.1.15

Nogmaals in mijn gedachte moet het gezocht worden in de Synology Disk Station

@San2022

 

Blijf het raar vinden dat je STEALTH krijgt, wat min of meer aangeeft dat er wel een soort van reactie komt vanuit je netwerk. Zou er geen enkele reactie komen, zou er CLOSED staan. En als de gewenste reactie wel komt, dan zou er OPEN staan.

Zie dat je ook een FTP server open hebt gezet, als je die poort vai GRC controleert, wat krijg je dan?

Als er geen reactie komt is het STEALTH (a.k.a. Filtered), de poort wordt dan geblokkeerd door een firewall. De portscan komt dus niet verder dan de firewall waar deze tegenaan bonkt.

CLOSED betekent dat er een port is geconfigureerd het zei via de daemon zelf het zei via een port-forwarding maar dat de service op dat moment niet actief (gestart) is.

OPEN betekent dat de port geconfigureerd en bereikbaar is en de daemon erachter connecties toelaat.

 

/ Daemon → Linux ook wel bekend als service (http/dns/mail etc).

 

Ben eigenlijk benieuwd wat er gebeurt als je upnp uitzet volgens mij staat deze vaak nog per default ingeschakeld - tenminste, als ik sommige portscans zo bekijk - en zou dit misschien ook nog wel eens roet in het eten kunnen gooien met port-forwarding.

@yalerta Goeie, maar als de port-forwarding verwijst naar een onjuist intern IP-Adres, dan zou deze CLOSED moeten geven i.p.v. STEALTH/Filtered.

 

Reputatie 1

@yalerta goed gezien, dit probleem duurt inmiddels al best lang. In het begin op de Zyxel had ik alles op .50 staan, op de R7000 heb ik .15 geprobeerd. 

Reputatie 1

@Gerrit078 ik zal dit weekend even proberen UPnP te disablen. 

Reputatie 1

Hi allen, 

Ik heb het aan de praat gekregen na er eens goed over nagedacht te hebben en de Zyxel router er weer achter te hangen. Mijn redenatie: 

  • Beide routers gaven een FILTERED of STEALTH bericht bij port scanning
  • Het probleem kan eigenlijk niet aan de WAN kant van de router zitten
  • Het probleem moet dus eigenlijk aan de LAN kant zitten
  • Bij port scanning bij de NAS stonden alle poorten open die nodig zijn
  • Deze poorten waren vanaf de WAN kant dus niet open. 

Na hier even over nagedacht te hebben bedacht ik me dat een stealth of filtered state eigenlijk betekent dat het pakketje niet aankomt. De poort op de NAS kan dan wel openstaan, maar dan zou het dus achter de poorten van de NAS moeten zitten. 

En ja hoor, wat bleek, de DNS server stond verkeerd ingesteld. De DNS server in het hoofdmenu van de SYnology NAS stond wel goed (8.8.8.8), maar de DNS op Bond 1 (zitten 2 UTP kabels in) stond nog handmatig ingesteld op een verkeerde. 

Oplossing:

  1. Statische DHCP op Zyxel toewijzen
  2. Automatisch IP adres op NAS
  3. Automatische DNS server NAS

Done. Thanks voor alle hulp!

 

Reputatie 7
Badge +14

@San2022 Geweldig om te zien dat het je gelukt is, lekker bezig en super bedankt voor het delen van jouw oplossing; dit gaat een hoop gebruikers helpen! 😄👍👍