Beantwoord

Cannot call +31 numbers

  • 4 November 2022
  • 5 reacties
  • 65 Bekeken

  • is een nieuwe Poster
  • 3 reacties

Hi everyone! Yesterday I’ve connected landline number. I have my own router (I don’t use T-Mobile modem) and I installed IP Phone (Yealink T31G) using settings provided by T-Mobile.

And when I started to test it I found very strange behaviour - I cannot call any numbers in +31XXXXXXXXX format. It fails immediately or after some time-out. But everything works fine if I call in local format - 0XXXXXXXXX. If I call from my mobile phone to landline - +31XXXXXXXXX number is displayed, so I would expect it’s supported, but when I click redial - it adds some IP address (with “@” symbol) at the end and fails. The same happens if I create a record in the phone book with the same number (+31) and try to call from there.

As a result now I need to create contacts in the phone with 2 different variants of the same number:

  • 0XXXXXXXXX - to be able to call that contact from IP Phone
  • +31XXXXXXXXX - to be able to detect a contact for incoming calls
icon

Beste antwoord door yalerta 4 November 2022, 14:04

Bekijk origineel

5 reacties

Reputatie 7
Badge +14

Hi @Romtje, welcome to the Community! 🙋‍♂️

I honestly have no clue as to what might be the root cause here, but I’ll gladly ask our local expert. @yalerta Do you perhaps have an idea? Thanks in advance! 

Reputatie 7
Badge +17

Try 0031 instead of +31?

Reputatie 7
Badge +2

Just looked in to this manual but I could not find any setting wich should look like something as “Call Prefix”

A call prefix makes it possible to dial numbers in your local area so you don't have to dial those area nummers.

On page 86 of the manual I found “clearing local settings”. Maybe thats an option?

I have no knowledge if this issue is due to the connection to the Tmobile Sip/Voip connection.

Thanks everyone for your answers!

@eric Indeed, the proper way to call international numbers is to use 00 instead of +. I’ve replaced + with 00 and it started to make a call properly.

@yalerta I found setting you mentioned - it’s under Settings > Dial Plan > Replace Rule. I have added a rule to convert +31 numbers to local one (basically replaces “+31” with “0”). Now I don’t need to store both numbers - full numbers are automatically converted to local ones. I could add an additional rule to convert all international numbers to proper format (replacing “+” with “00”), but I’m not going to call abroad from the landline anyway.

Reputatie 7
Badge +4

Hi @Romtje, I'm really glad to see that it's working again after the tips! 😁 If you have any other questions, please let us know. For now: enjoy your weekend. 

Reageer