Zyxel T50 NTP server clock settings

  • 9 August 2021
  • 6 reacties
  • 68 Bekeken

Hello, and sorry for writing in English. I have an issue with my router (VMG8825-T50) clock not being correct with the actual time. This somehow seems to be affecting my Home Assistant set up where that system clock is also wrong which messes up automations, etc. 

Does anyone have any idea on how to fix this? I thought is the most reliable NTP server. Please feel free to respond in Dutch. 

See an example of the situation here:



Beste antwoord door yalerta 9 August 2021, 19:23

Bekijk origineel

6 reacties

Reputatie 7
Badge +19

Hello @dawn_chorus 

I don't have the Zyxel but are the default settings for time not working correctly?

Hello @dawn_chorus 

I don't have the Zyxel but are the default settings for time not working correctly?

I did not change the default settings, so it was set as in the photo above. I just now tried to change the “First Time Server Address” to and that seems to have solved it for now but not sure if the time will drift apart later again. 

Reputatie 6
Badge +2

@dawn_chorus   (time server from SIDN managing the .nl domain)

The system where Home assistant is running on seems to have another time server?

Reputatie 6
Badge +2

Set the HA time zone correct?


Set the HA time zone correct?



The HA time zone is set correctly but I noticed my automations were being delayed by random amount of time (for example, 10:22:14 instead of 10:00:00). I then noticed that the internal system clock of HA seems to be running slow. When I restart HA the time is correct but it slowly drifts behind. As seen in this screenshot:


I thought this might somehow be related to the Zyxel router NTP but now the Zyxel seems to be functioning correctly but HA is still not right.

Reputatie 6
Badge +2


So you should check the clock settings and or timeserver from the pc/nas/server/rpi or whatever HA is running on.

In my case a Synology DSM