Beantwoord

Router geeft geen internet meer door LAN (Wifi werkt nog wel)


Goedemiddag,

Dit probleem is sinds gisteren voor het eerst voorgekomen. De router vertikt het om werkend internet te geven door alle LAN poorten. Poort 3 & 4 zijn sowieso al onbruikbaar behalve voor de TV box, wie dat ook maar bedacht heeft.

Protocol die ik heb gedaan om zeker van te zijn dat het de router is:

- Andere LAN kabel.
- Alle LAN poorten geprobeerd.
- Op 3 verschillende systemen

* Windows 10 x64 Professional
* Ubuntu 16.10
* Debian 9

Al deze systemen gaven aan dat ze geen internet konden krijgen via de LAN.

- De router volledig gereset (10 seconden resetknop ingedrukt gehouden).
- Statisch IP adres op mijn systeem en in de router
- Alle poorten open gezet doormiddel van DMZ (demilitarized zone)

* Na de volledige fabrieksreset bleek de LAN het even te doen voor ongeveer 20 minuten en toen kwam er weer het gele driehoekje in Windows.

Conclusie: Het blijkt dat de router geen normale DHCP configuratie meer uit kan geven, zelfs na de fabrieksreset. Dit is nooit eerder voorgekomen sinds ik het glasvezel abonnement heb.

Ik hoop dat we hier een oplossing op kunnen vinden. Natuurlijk is het niet extreem erg maar merk tijdens het streamen en gamen dat hij toch soms lagt over het draadloze netwerk.

Groet,

Jamie

Toelichting afbeeldingen:

Afbeelding 1

Hier begint het ip adres met 169, dit is een indicatie dat de router faalt om een normaal DHCP protocol op te zetten waardoor hij niet automatisch ip adressen kan uitdelen aan apparaten via de LAN poorten.

Afbeelding 2

Hier kun je zien dat de router wel een normaal ip adres uitdeelt maar die komt om een of andere reden niet aan bij het systeem dat op de LAN poort is aangesloten.
icon

Beste antwoord door tmoesel 8 november 2017, 17:35

Clevo_d2:7c:6d zal the ethernetpoort van je PC zijn. Ik gebruik zelf zeer weinig Windows, kan nit uit ervaring zeggen onder wat voor omstandigheden de 169.254.x.x wordt aangenomen. Zichtbaar wordt steeds een DHCP4 request gedaan, maar de Draktek geeft dus niks terug. Frappant is wel dat 10.32.112.1 adres op het ethernetLAN; wellcht van TV of vastetelfonie? Is dit de bedoeling op LAN1 poort? Of is er een andere apparaat/instantie die gateway router speelt?
Om het simpeler te maken zou je IPv6 uit kunnen zetten en ook WiFi uitzetten. Dan kan de Draytek eigenlijk geen reden hebben om geen IPv4 adress uit te delen aan je PC, maar wellicht ziet ie een ander euvel op het LAN waardoor DHCP4server niet werkt. Als je wat langer monitort, zul ook ARP van Draytek moeten zien. Als dat niet komt is geen goed teken voor zover ik weet.
Bekijk origineel

16 reacties

Reputatie 6
Badge +11
Router type en firmware versie(s) ?
Router info:

Reputatie 7
Badge +10
Zou je eens met wirreshark kunnen zien wat er gebeurd met de DHCP ?
Wt heb je verder in je netwerk staan ? als je 3 apparaten aan de kabel heb aangesloten moet er nog iets anders tussen zitten.....
Zou je eens met wirreshark kunnen zien wat er gebeurd met de DHCP ?
Wt heb je verder in je netwerk staan ? als je 3 apparaten aan de kabel heb aangesloten moet er nog iets anders tussen zitten.....


Ik heb geen 3 apparaten aangesloten maar heb 3 laptops die ik geprobeerd heb op dezelfde LAN poort. De linux laptops gaven allebei aan geen DHCP te kunnen ontvangen en ook daar de melding ''unidentified network''.

Er was een vergelijkbare post van iemand waarbij ook op dezelfde dag precies hetzelfde probleem ontstond. Bleek bij hem aan zijn Steam Link te liggen, ik heb dat soort apparaten niet.

Ik zal Wireshark even downloaden en post de resultaten hieronder.
Zou je eens met wirreshark kunnen zien wat er gebeurd met de DHCP ?
Wt heb je verder in je netwerk staan ? als je 3 apparaten aan de kabel heb aangesloten moet er nog iets anders tussen zitten.....


Oke ik heb het netwerkverkeer van beide LAN en Wireless gecaptured.

Weet niet precies hoe ik het moet kopieren en plakken dus ik heb gewoon printscreens gemaakt, hopelijk kan je er wat mee.

Dit is de LAN:



En de Wireless (2.4GHz)



Ik had het er ook nog over met mijn leraar en die suggereerde dat de interne switch ook eventueel kapot zou kunnen zijn van mijn router. Hij zei dat het ook door een firmware update zou kunnen, maar de huidige firmware bestaat al sinds januari 2017 dus dat lijkt mij sterk.
Reputatie 6
Badge +11
Clevo_d2:7c:6d zal the ethernetpoort van je PC zijn. Ik gebruik zelf zeer weinig Windows, kan nit uit ervaring zeggen onder wat voor omstandigheden de 169.254.x.x wordt aangenomen. Zichtbaar wordt steeds een DHCP4 request gedaan, maar de Draktek geeft dus niks terug. Frappant is wel dat 10.32.112.1 adres op het ethernetLAN; wellcht van TV of vastetelfonie? Is dit de bedoeling op LAN1 poort? Of is er een andere apparaat/instantie die gateway router speelt?
Om het simpeler te maken zou je IPv6 uit kunnen zetten en ook WiFi uitzetten. Dan kan de Draytek eigenlijk geen reden hebben om geen IPv4 adress uit te delen aan je PC, maar wellicht ziet ie een ander euvel op het LAN waardoor DHCP4server niet werkt. Als je wat langer monitort, zul ook ARP van Draytek moeten zien. Als dat niet komt is geen goed teken voor zover ik weet.
Reputatie 7
Badge +10
Ik zie inderdaad helemaal geen verkeer meer komen vanaf het modem. (ook al is de capture time wat klein) Wat je zou kunnen proberen is 2 computers aansluiten en kijken of deze elkaar kunnen zien aan de hand van een capture.
169 wordt door windows toegewezen als ik geen normale IP krijg. Dan wijst windows een lokaal IP adres toe maar het probleem heeft zichzelf al opgelost.

IPv6 uitschakelen bleek niks te doen, hetzelfde geldt voor alle apparaten de verbinding mee verbreken en alleen een laptop op de LAN doen.

De stroom viel laatst uit en toen opeens deed mijn LAN het weer. Heel apart maar het lijkt alsof de router zichzelf een soft reset heeft gegeven waardoor nu alles weer goed is.
Reputatie 6
Badge +11
OK, een simpel uit-aan van de modemrouter verhelpt het probleem in dit geval. De vraag blijft waarom de modemrouter in een dergelijke deadlock toestand m.b.t. het LAN gedeelte geraakt.
Is dit probleem nu ook echt opgelost? Ik heb namelijk hetzelfde probleem, maar bij mij herhaalt dit probleem zich dagelijks. Heb al 3 nieuwe modems ontvangen en alle oplossingen al geprobeerd... Bij mij lost een reset het ook wel op, maar ik ben ondertussen 12 keer per dag mijn router aan het resetten...
Reputatie 6
Badge +11
@NoobishPro
De kans dat T-Mobile (de Thuis afdeling of subcontracters o.i.d.) dit technisch gaat oplossen is nihil mijn inziens, ook met het oog op de voorgenomen overname van Tele2, wat vooral om de vasteverbindingen lijkt te gaan.
Het probleem lijkt in ethernet switching op te treden, door whatever oorzaak. Je kan kijken of je een seriele kabel aan de Draytek kan solderen/verbinden, en kijken of je op de 1 of andere manier kan inloggen. Maar veel sneller is investeren in eigen routing oplossing voor nu en nadat je contract is afgelopen en je kan overstappen zonder langdurig gesukkel van de klantenservice te ervaren. Voor mij zou 1x per 12 dagen al niet werkbaar zijn, als je thuiswerkt kun je nog makkelijk even resetten, maar een modemrouter die zijn LAN links in een deadlock o.i.d laat zitten zie ik als goedkoop-is-duurkoop (kwa provider/abo dan).
Wellicht kun je hier wat mee of andere fora zoals tweakers etc:
https://forum.t-mobile.nl/t-mobile-thuis-algemeen-490/draytek-vervangen-met-je-eigen-router-297061
Hmnja, bedankt tmoesel...
Als tweaker was ik mij hier natuurlijk al bewust van... Maar goed, ik zie het zo;
T-mobile fucked up. Ik kan niet genieten van de beloofde (en voor betaalde) diensten. Dit wil dus zeggen dat ik helemaal niet hoef te wachten tot mijn contract is verlopen. Ik kan gewoon switchen naar KPN. Als dit binnen februari niet is opgelost ga ik dat denk ik nog doen ook.

Ik bedoel, ik kan wel een bak met geld naar nieuwe hardware smijten, maar dan los ik iets op wat niet aan mij zou moeten zijn om op te lossen, know what I mean?
Reputatie 6
Badge +11
@NoobishPro
Misschien ook al bekend, maar bij KPN krijg je de ExperiaBoxV10 waarmee in met recente firmware ook problemen zijn in het (W)LAN gebeuren wat al lang sleept. Ik verwees naar 'eigen router' info mede ook daarom. Een kastje met b.v. DECT, TV, WIFI etc alles in 1 is inderdaad nogal prijzig. Voor sec routing is een single board computer van een paar 10tjes voldoende, ieder zijn smaak.
@NoobishPro
Misschien ook al bekend, maar bij KPN krijg je de ExperiaBoxV10 waarmee in met recente firmware ook problemen zijn in het (W)LAN gebeuren wat al lang sleept. Ik verwees naar 'eigen router' info mede ook daarom. Een kastje met b.v. DECT, TV, WIFI etc alles in 1 is inderdaad nogal prijzig. Voor sec routing is een single board computer van een paar 10tjes voldoende, ieder zijn smaak.


Hey tmoesel,

Ik ben je er ook dankbaar voor hoor. Je doet hier een goed iets!
Dat van de experiabox wist ik niet. Misschien ook iets om in het achterhoofd te houden dan... *zucht*

Ik gebruik wel enkel internet, dus een alles-in-1 router hoef ik gelukkig niet te hebben.

Ik ga nog even een goedkoop netwerkkaartje halen om 100% uit te sluiten dat mijn pc niet de veroorzaker is. (Heb al op 3 adressen achter elkaar internet problemen)

Als dat het alsnog niet oplost, zal een eigen router misschien de oplossing zijn inderdaad... Betreft geen ondersteuning meer krijgen van T-mobile in die situatie, tja, hebben we toch niets aan he 😉
Reputatie 7
Badge +10
@tmoesel
Ik weet niet waar jij je info vandaan haalt maar een probleem oplossen heeft helemaal niets met de overname van tele2 te maken. T-Mobile is er zeker wel mee bezig. het probleem komt helaas niet zo vaak voor en is niet reproduceerbaar. echter is er wel een vermoeden dat dit word veroorzaakt door Valve steam
Het modem open maken en in gaan solderen is nog al een no go dit betekend dat je het modem moet vergoeden van 250 euro. kan je beter zelf een router halen.
Reputatie 6
Badge +7
Hi NoobishPro, ik heb zojuist toevallig gereageerd op een soortgelijk bericht van jou in een ander topic. Ik ga graag voor je aan de slag! Laat het mij daar even weten, dan houden we het gesprek op één plek.

Reageer