Beantwoord

Router HUAWEI HG659 en MAC adressen

  • 24 oktober 2018
  • 6 reacties
  • 882 Bekeken

Ik heb sinds (ongeveer) een maand de nieuwe HG659 router van Huawei via mijn T-Mobile Thuis - Internet abonnement.

Ik maak gebruik van een paar tools waarbij het belangrijk is dat de router bepaalde apparaten (waar ik GEEN vast IP-adres in kan zetten, met name Wifi-devices) via DHCP een vast IP-adres geeft. Dus registreer ik de apparaten met een DHCP-reservering in de router.

Ik ben al gestopt met het aanpassen van de namen van deze apparaten omdat om onduidelijke reden deze elke keer weer verdwenen zijn. Dus gebruik ik de door de Huawei gegenereerde namen, die deels bestaan uit het MAC-adres. Nu zie ik bij de meeste devices telkens twee varianten opduiken. Om even een voorbeeld te geven (MAC adres is deels afgeschermd):

1A:A6:F7:xx:xx:xx_Wireless
E8:AB:FA:xx:xx:xx_Wireless

Op de plaats van de 'xx:xx:xx' staan in de eerste en twee regel hetzelfde adres. Beiden verwijzen ook naar het zelfde apparaat. Alleen is 1 van beide maar actief. de ander is offline. Er is geen pijl op te trekken welke hij pakt. Het vervelende is nu dat ik voor het ene MAC-adres een reservering heb gemaakt en de andere nu actief is. Überhaupt snap ik niet waarom er een tweede MAC-adres aangemaakt wordt. Het E8 adres in bovenstaand voorbeeld is geregistreerd door Shenzhen Reecam Ltd. Het andere adres is totaal onbekend. Het ene apparaat uit de router verwijderen heeft geen zin. Hij komt net zo hard meteen weer in de lijst. Zo zijn er dus meer devices die een dubbele registratie krijgen met een MAC adres dat met 1A:A6:F7 begint.

Iemand anders hier ervaring mee/een oplossing voor?

Tevens poog ik een speedtest te doen en kom ik maar tot 100/100Mbit terwijl ik een 750/750Mbit abonnement heb!

Helaas ben ik dus niet tevreden met deze router. De mogelijkheden van instellen zijn te beperkt. Ik zou liever mijn eigen router (Synology RT1900AC) willen gebruiken.
icon

Beste antwoord door Devoraz 24 oktober 2018, 15:04

OK, ik denk dat ik de oorzaak van de 'dubbele' MAC-adressen zelf al gevonden heb. Dit is iets waar ik behoorlijk in moet duiken want het is niet gewenst maar is blijkbaar 'by design'.

Ik gebruik thuis ook Range Extenders van TP-Link. Op deze RE's is DHCP wel uitgeschakeld, maar blijkbaar past de extender toch het MAC-adres aan als hij voor een wifi-device een IP-adres moet opvragen bij de Router. Uiterst ongewenst (waarom kan dat niet met het oorspronkelijke MAC-adres) maar goed.... dat is dus een technische kwestie en kan dus helaas (nog) niet met instellingen opgelost worden.

De snelheid van mijn verbinding zou ik wel graag omhoog willen. Het was de laatste week goed, maar nu is het veel te langzaam.
Bekijk origineel

6 reacties

Reputatie 6
Badge +2
@Devoraz

Inderdaad ook even het manual doorgenomen, maar daar is inderdaad niet te vinden over die betreffende setting.

Wat DMZ betrefd, rustig even uitzoeken wat voor jou de beste optie is.
@Pieter_B

Die pagina van TP-link had ik ook gevonden, maar blijkbaar hebben mijn Range Extenders (RE200 AC750) deze mogelijkheid niet. Althans... ik heb de gehele setting doorgespit maar nergens een setting om de extender in WDS mode te zetten.

DMZ is zeker een optie maar gezien de omvang van mijn eigen netwerk liever nog even niet. 😉
Reputatie 6
Badge +2
@Devoraz

Weet niet in welke mode de extender staat, maar TP-link heeft hier een info webpagina voor gemaakt.
Kun je daar iets mee om toch die betreffende filtering uit te voeren?

Een eigen router is ook mogelijk, doen veel (technische) klanten hier waaronder mijzelf.
Heb de Draytek met daarachter een ASUS al vanaf dag 1.

Optie is om op de T-Mobile router een DMZ uitgang te maken naar je eigen router, of twee apparte subnetten aan te maken voor de beide routers. Bijv 192.168.1.1 voor de ene router en de andere eigen router 192.168.2.1.

T-Mobile router DMZ LAN => WAN eigen router LAN xxx.xxx.1.1 of
T-Mobile router xxx.xxx.1.1 LAN => WAN eigen router xxx.xxx.2.1 LAN (let op dubbele NAT in dit geval)

Hier ook een abo 750Mb en de snelheden hier liggen op +760Mb U/D (Linux machine)
@Sander

Dank voor je tips. Ik ben zelf ICT'er (Systeembeheerder) maar in mijn leven nog nooit gebruik gemaakt van Wifi Range Extenders. Daarom was het fenomeen 'Virtual Mac Address' mij onbekend.

  1. De netwerkkaart van al mijn PC's thuis, zijn 1 GBit kaarten.
  2. Ik gebruik geen UTP Optimizer of iets dergelijks. Was ik wel van plan maar toch voor een tweede kabel gekozen. 😉
  3. Zowel de desktop app als de browser geven op dit moment (bij instelling van gelijke servers) een waarde van rond de 500Mbit (Up en Down). Hangt ook heel erg af van de server die je kiest. Solcon, Dronten (zit zelf in Swifterbant) levert deze snelheden op. Andere servers meestal iets lager.
  4. Ik gebruik de standaard firewall instellingen van Windows 10, met hier en daar een extra beveiliging ten behoeve van bepaalde applicaties. Deze settings tijdelijk uitschakelen levert geen verandering op.
  5. Bij het testen wacht ik altijd tot de PC helemaal klaar is met laden. Het enige wat openstaat is een browser en de SpeedTest app. Mijn CPU (i7) heeft een utilization van 5% (Idle). Bij de dowload test zit hij tussen de 50% en 60%. Bij de upload test tussen de 30% en 40%.
  6. Er zit inderdaad een switch tussen mijn PC en de router, maar dat is een Gigabit switch waarvan de poort die naar de router gaat, evenals de poort waar mijn PC op zit, beiden op 1GB staan.


Zoals gezegd kom ik op mijn eigen PC 'maar' rond de 500MBit. Een fabrieksreset wil ik nog wel een keer overwegen, zodra ik instellingen heb veilig gesteld. Die 'dubbele' (virtuele) MAC-adressen komen niet van de Router, dus die verdwijnen daar niet mee. Die worden namelijk door de Range Extenders gegenereerd en daarna doorgegeven aan de Router. Voor dat probleem zal ik eens moeten gaan kijken naar Access Points, maar ja... die zijn wel wat duurder.
Reputatie 6
Badge +5
Hi @Devoraz

Mijn complimenten voor je technische speurtocht! Je hebt al veel uitgezocht: fantastisch!

Ik help/graag mee wat de oorzaak van de snelheidsproblemen kunnen zijn. Vergeef mij als je deze al uitgeprobeerd hebt! :)

Er zijn een aantal oorzaken waardoor je jouw maximale snelheid niet kan halen.
1. er wordt een netwerkkaart gebruikt die alleen maar 100 Mbit ondersteund (zoals broadcom of asheros chipset)
2. er wordt gebruik gemaakt van een UTP Optimizer of een andere vorm van het opsplitsen van de kabel.
3. er wordt gemeten vanuit een webbrowser in plaats van de speedtest.net desktop app.
4. software matige beperking zoals een firewall
5. CPU load is te hoog (Realtek offload naar de CPU waar een Intel nic zelf de afhandeling doet)
6. De computer is niet rechtstreeks aangesloten met een kabel, maar er zit bijvoorbeeld een 100Mbit switch tussen.

Kun je deze 6 punten nalopen en uitsluiten? Tot slot wil ik nog een fabrieksreset voorstellen, maar dan ben je wel je instellingen kwijt. Mogelijk verhelpt dit ook voor de dubbele MAC-adressen.

Ik hoor graag van je! Want die snelheid help ik je graag mee!
OK, ik denk dat ik de oorzaak van de 'dubbele' MAC-adressen zelf al gevonden heb. Dit is iets waar ik behoorlijk in moet duiken want het is niet gewenst maar is blijkbaar 'by design'.

Ik gebruik thuis ook Range Extenders van TP-Link. Op deze RE's is DHCP wel uitgeschakeld, maar blijkbaar past de extender toch het MAC-adres aan als hij voor een wifi-device een IP-adres moet opvragen bij de Router. Uiterst ongewenst (waarom kan dat niet met het oorspronkelijke MAC-adres) maar goed.... dat is dus een technische kwestie en kan dus helaas (nog) niet met instellingen opgelost worden.

De snelheid van mijn verbinding zou ik wel graag omhoog willen. Het was de laatste week goed, maar nu is het veel te langzaam.

Reageer