Beantwoord

Ubiquiti UniFi Security Gateway via dmz achter de zyxel


Hallo ik heb soortgelijke onderwerpen al gevonden op dit forum maar toch kom ik er niet uit dus probeer mijn situatie even te schetsen zodat jullie mij misschien kunnen helpen. Ik heb internet en Tv in mijn abonnement.

Ik heb van T-Mobile de Zyxel t50 modem

Zelf heb ik ubiquiti apparatuur 

Ubiquiti UniFi Security Gateway

Ubiquiti UniFi AC Pro

Ubiquiti UniFi Switch 8 - US-8-60W

En dan heb ik nu de controller software op mijn unraid server staan

Nu heb ik de USG aangeschaft in die wil ik graag als modem voor mijn netwerk gaan gebruiken, bridge mode in de zyxel gaat niet dus wilde ik dit via DMZ gaat doen maar ik krijg het niet werkend. Ik weet dat ik de ip in mijn usg moet aanpassen en wilde dit in de controller software doen maar daar zie ik de usg als disconnected

Nu heb ik de volgende tutorial gevonden :

https://community.ui.com/questions/How-to-add-a-usg-behind-an-isps-modem-without-bridging/3e28876f-1ef6-44be-b9f0-e26f6a32854d

maar daar staat weer niets over de dmz in de zyxel en weet ook niet of dit de goede manier is.

De tv's wilde ik dan gewoon via het zyxel modem laten lopen, als dit kan dan.

Mijn controller software zit dus in het huidige netwerk en die komt dan ook uiteindelijk in het nieuwe netwerk. Kan iemand mij misschien helpen met een stappen plan hoe alles aan te pakken?

icon

Beste antwoord door Pieter_B 16 June 2021, 12:26

Bekijk origineel

21 reacties

Reputatie 7
Badge +2

@Adrie1975 

Eerst even een paar vrager;

  • Heb je glasvezel of DSL?
  • Zit je al op het nieuwe TV platform of het oude?

Als je glasvezel hebt en evt. het nieuwe platform, zou dit topic informatie kunnen hebben

 

@Adrie1975

Eerst even een paar vrager;

  • Heb je glasvezel of DSL?
  • Zit je al op het nieuwe TV platform of het oude?

Als je glasvezel hebt en evt. het nieuwe platform, zou dit topic informatie kunnen hebben

 

@Pieter_B 

Dankje voor de snelle reactie, Dit topic heb ik doorgelezen en ook geprobeerd maar had daar best veel problemen met de tv, dan deed hij het weer een paar dagen en dan weer ineens niet daarom wilde ik het op deze manier proberen want wil wel graag die usg gebruiken. Ik heb glasvezel en het nieuwe tv platform.

Reputatie 7
Badge +2

@Adrie1975 

Hier gaat het dan wel om een UDM Pro, maar denk dat de basis van het geheel redelijk gelijkend is

Weet niet of je uit die topics wat details kunt halen, waarbij je TV wel goed gaat werken.

Note: Heb zelf geen IPTV, alleen maar na de pfSense alles van UniFi liggen.

Wie weet is er iemand binnen de community die wel een soortgelijke opzet heeft nog wat toevoegen

Ook deze had ik gevonden en geprobeerd maar ook daar problemen met de tv, Netwerk ging allemaal goed. Maar om van die tv problemen af te komen wilde ik dus die zyxel laten zitten puur voor de tv en de  ,rest wat voor mij ook veel belangrijker is, via de usg. 

Reputatie 7
Badge +2

@Adrie1975 

Wat je dan kan doen is de USG een fixed IP geven van bijv 192.168.1.3 en de betreffende LAN in een afzonderlijk subnet plaatsen van bijv. 192.168.10.1.

Binnen de Zyxel dan wel deze fixed IP even buiten de DHCP pool laten vallen, door de DHCP pool range om te zetten naar 192.168.1.10 - 192.168.1.254. Hiermee voorkom je dat je een overlap krijgt tussen fixed en pool.

Vanuit het subnet 10 is ook gewoon de Zyxel in subnet 1 bereikbaar, maar niet andersom .. tenzij je een WAN login toestaat op de USG, maar dat lijkt mij niet nodig als je USG de controller is van je netwerk.

Wifi zou je uit kunnen zetten op de Zyxel, zeker gezien de UniFi AC Pro die je hebt draaien.

Hopelijk is het zo een beetje duidelijk, waartbij je dan de Zyxel gebruikt voor je IPTV.

 

@Pieter_B 

Bedankt voor de uitleg ik ga het vanavond even proberen, iklaat het weten als het gelukt is

@Adrie1975

Wat je dan kan doen is de USG een fixed IP geven van bijv 192.168.1.3 en de betreffende LAN in een afzonderlijk subnet plaatsen van bijv. 192.168.10.1.

Binnen de Zyxel dan wel deze fixed IP even buiten de DHCP pool laten vallen, door de DHCP pool range om te zetten naar 192.168.1.10 - 192.168.1.254. Hiermee voorkom je dat je een overlap krijgt tussen fixed en pool.

Vanuit het subnet 10 is ook gewoon de Zyxel in subnet 1 bereikbaar, maar niet andersom .. tenzij je een WAN login toestaat op de USG, maar dat lijkt mij niet nodig als je USG de controller is van je netwerk.

Wifi zou je uit kunnen zetten op de Zyxel, zeker gezien de UniFi AC Pro die je hebt draaien.

Hopelijk is het zo een beetje duidelijk, waartbij je dan de Zyxel gebruikt voor je IPTV.

 

Nog 1 vraagje;

Ik gebruik ook DDNS om van buitenaf op mijn server te komen, moet ik dan de benodigde poorten forwarden op de zyxel en de ddns gegevens op de zyxel instellen of maak ik dan gebruik van DMZ?

Reputatie 7
Badge +2

@Adrie1975 

Je kan DDNS instellen op de Zyxel, zodat die je IP blijft doorrgeven aan de DDNS provider.

Afhankelijk waar je server in het netwerk hangt, zul je dan vanuit de Zyxel portforwarding moeten instellen. Hangt deze server achter de USG, zal je daar dus ook portforwarding op moeten doen. Dit is nodig, omdat je nu te maken hebt met double NAT .. wat op zich prima werkt hoor voor een server.

Wat je ook kan doen is, de server aan de Zyxel hangen met een fixed IP voor die betreffende server. Daarna deze IP in de DMZ plaatsen, dan heb je geen portforwarding nodig op de Zyxel (mijn voorkeur, buiten prive netwerk als het zonder  VLAN moet)

 

@Adrie1975

Je kan DDNS instellen op de Zyxel, zodat die je IP blijft doorrgeven aan de DDNS provider.

Afhankelijk waar je server in het netwerk hangt, zul je dan vanuit de Zyxel portforwarding moeten instellen. Hangt deze server achter de USG, zal je daar dus ook portforwarding op moeten doen. Dit is nodig, omdat je nu te maken hebt met double NAT .. wat op zich prima werkt hoor voor een server.

Wat je ook kan doen is, de server aan de Zyxel hangen met een fixed IP voor die betreffende server. Daarna deze IP in de DMZ plaatsen, dan heb je geen portforwarding nodig op de Zyxel (mijn voorkeur, buiten prive netwerk als het zonder  VLAN moet)

 

Super bedankt voor de nette uitleg ik ga vanavond en waarschijnlijk de komende dagen aan de slag, Ik zal het eind resultaat zowieso even plaatsen voor andere gebruikers

@Pieter_B 

Gisterenavond bezig geweest maar ik doe meteen iets niet goed denk ik dit is wat ik tot nu toe gedaan heb

Ik heb de usg gereset, daarnaar heb ik met een kabel vanuit de lan1 poort naar mijn laptop verbinding gemaakt.

  • ben naar 192.168.1.1 gegaan en kom dan in de interface van de usg waar ik het Lan ip heb aangepast naar 192.178.1.1 en ook dan de dhcp range naar 192.178.1.10-192.178.1.252
  • Even opnieuw ingelogd maar dan op 192.178.1.1 en kreeg weer netjes de interface
  • Lan1 kabel verwijderd en Lan1 van de zyxel aangesloten op de wan1 van de usg
  • Lan2 aangesloten op mijn laptop en dan via 192.168.1.1 ingelogd in de zyxel
  • Dhcp range veranderd naar 192.168.10-192.168.1.252
  • Statisch ip naar de usg met ip 192.168.1.4 ingesteld
  • usg van de stroom gehaald en opnieuw op laten starten
  • Lan1 van usg kabel naar mijn laptop (Geen internet)
  • Ingelogt via 192.178.1.1 interface van de usg met grote letters bovenaan dat ik verbonden ben met het internet maar dit is dus niet zo. Zie ook bij wan netjes het adres 192.168.1.4 en bij preferred dns staat 192.168.1.1 Mijn laptop kreeg wel het ip adres 192.178.1.10 maar geeft bij netwerkadapter aan onbekend netwerk
  • Ik heb op de laptoptop bij de netwerkadapter het ip4 adres handmatig aangepast naar 192.178.1.10 en dan ook de subnetmask naar 255.255.255.0 en gateway naar 192.178.1.1 en bij dns1 192.178.1.1
  • dan heb ik dus WEL internet
  • Toen heb ik nog geprobeerd om de unifi controller te instaleren op mijn laptop en daar herkent hij wel de usg maar kan hem niet adopten. Ik zat met de laptop ook op het nieuwe netwerk 192.178.x.x
  • Als ik mij switch dan aan de lan1 poort van de usg hang en verbind daar mijn pc of laptop of wat dan ook krijgen allemaal wel een ip toegewezen maar geen verbinding alleen als ik het handmatig invoer maar dit lijkt me dus niet de bedoeling.

Doe ik iets niet goed?

Reputatie 3

@Adrie1975 

Het is maar een suggestie maar heb je op de usg bij de dhcp instellingen naast de range ook de dns en gateway aangepast? Het klinkt een beetje alsof je laptop wel in 192.168.178.0/24 staat maar de gateway nog naar 192.168.1.1.

Reputatie 7
Badge +2

@Adrie1975

Als ik het verhaal lees en je stappen volg, heb je wel de DHCP pool aangepast naar 192.168.10 subnet.

Maar heb je ook je LAN subnet aangepast, dis 192.168.1 naar 192.168.10?

Lijkt erop dat je LAN en DHCP pool een subnet afwijking hebben zoals ik het verhaal lees.

 

Of zit er een typo met een 0 teveel in de DHCP pool?

En wat zegt ‘ipconfig’ op je windows als alles auto staat?

Reboot van de Zyxel gedaan, nadat je de static Ip hebt toegewezen?

 

Zit nog eens te kijken naar je gekozen IP range, die valt buiten de ‘private’ range. 192.168.x.x is de ‘private’ range. Gebruik dan ook vaak als ik wil afwijken van de overall basic een 10 of een 172 voor prive.

 

@Pieter_B

Sorry ik zie dat ik iets verkeerd getypt heb in de volgende regel 

  • Dhcp range veranderd naar 192.168.10-192.168.1.252

Ik heb dit wel goed gedaan volgens mij 

  • Dhcp range veranderd naar 192.168.1.10-192.168.1.252

maar dit moet ik straks als ik thuis ben even controleren, weet nu wel even waar ik allemaal goed op moet letten, ook @Marty_J  bedank dit zal ik straks ook controleren.

Reputatie 7
Badge +2

@Adrie1975 

Had nog een kleien toevoeging gedaan over je gekozen IP range, welke buiten het ‘private’ segment valt.

 

@Adrie1975

Had nog een kleien toevoeging gedaan over je gekozen IP range, welke buiten het ‘private’ segment valt.

 

@Pieter_B 

Deze snap ik even niet, maar ben even helemaal opnieuw begonnen zyxel reset en usg reset en gegevens die je eerder gepost had overgenomen. ik heb even afbeeldingen gemaakt ook van mij ipconfig (Als de kabel in de lan1 poort van de usg zit) maar nog steeds geen automatische internet verbinding alleen handmatig.

Excuses voor het ongemak, ik weet wel iets van netwerken af maar dit is geheel nieuw voor mij

Reputatie 7
Badge +2

@Adrie1975 

Denk dat we allemaal zien dat je Windows computer geen default Gateway krijgt … hmm wat eigenlijk de USG zou moeten zijn, dat is dan ook de reden dat je geen internet hebt. Je computer moet een default gateway krijgen om zijn requests te forwarden.

Probeer dit eens op de Windows machine .. is en blijft Windows (zelf hier alleen Linux en Mac machines)

Resetting Network Devices and Network Stack

Hi allemaal

Ik ben dit topic doorgelopen omdat ik dezelfde opstelling wil; alles achter de USG behalve de tv, met als reden om niet aan de slag te hoeven met VLANS.

Nu is de opstelling werkend op volgende manier:

Zyxel

192.168.1.1

DHCP 192.168.1.10-254,

statische DHCP naar de USG op 192.168.1.4

USG 

192.168.10.10

DHCP 192.168.10.11-192.168.10.254

 

 

Maar ik loop tegen 2 problemen aan:

  1. DHCP. Alle apparaten achter de usg krijgen een IP 192.168.10.xxx , dus in principe werkt dat. Maar zo nu en dan sluipt er toch een apparaat door. zo had ik vanochtend een sonos die ineens 192.168.222.xxx had toegewezen gekregen? en vorige week zat een heel regiment apparaten achter de USG ineens op 192.168.1.xxx. Waar zou dit aan kunnen liggen?
  1. De TV heeft wel internet maar is niet te bereiken voor bijvoorbeeld streamen vanaf smartphone. Ik denk dat dit komt omdat de tv op 192.168.1.xxx zit en de smartphone op 192.168.10.xxx. Als ik de TV in de switch zet, dan werkt het wel, maar ik heb weinig vrije poorten op de switch. Is het mogelijk de TV toch op de zyxel te houden?

 

 

Reputatie 7
Badge +20

Hallo @hansvanb 

Heb je een glasvezel of DSL verbinding? Indien je glasvezel hebt en je zit op het nieuwe tv platform dan zou je de USG rechtstreeks op de mediaconverter kunnen aansluiten zonder de Zyxel, je hoeft dan enkel VLAN 300 te configureren.

Indien het om DSL gaat, wat gebeurt er als je de DHCP server op de USG uitzet?

Beste @Waqqas ,

Bedankt voor je reactie!

Ik heb glasvezel en het nieuwe platform. Ik was begonnen het aan te sluiten zonder Zyxel mbv de handleiding van Bjarn Bronsveld, maar dat was toch best ingewikkeld allemaal en ik kreeg het dus ook niet werkend. Die setup kost ook 3 poorten op de switch (1 voor de mediaconverter, 2 van/naar de usg).

Bedoel jij nu dat ik de Zyxel uit mijn huidige setup kan halen, de mediaconverter op de USG aansluit en de USG op poort 1 van de switch, met alleen een fiber trunk en VLAN 300? Dus geen vlan 100 en vlan 640 ?

 

Reputatie 7
Badge +20

@hansvanb

Het nieuwe tv platform maakt geen gebruik van VLAN 640, tv werkt gewoon via internet.

Dit is voldoende voor internet en tv zonder de Zyxel, begin wel even met een fabrieksreset 🙂

Hi @Waqqas ,

Meteen geprobeerd en dit werkt - wow.

Nu er geen dubbele dhcp meer hoeft te draaien zal het IP probleem ook wel opgelost zijn vermoed ik.

 

thanks!

Reageer