Beantwoord

Data not working abroad with unlimited subscription

  • 18 September 2021
  • 13 reacties
  • 139 Bekeken

Apologies for writing in english, my dutch vocabulary is still not yet enough.

I have an unlimited subscription for the last few months. Today is the first time I travelled outside Netherlands (to Slovakia) with this phone (Android) and there’s no data connection. I have full signal as well as data service & roaming turned on. I tried restarting the phone and turning on/off airplane mode but it still didn’t work. This is on an Android device. I have another connection (not T-mobile) on another phone, so coverage is not the issue. Am I missing something obvious ?

P.S.- I don’t have. sim ejector with me, so I can’t physically remove the sim and put it back again.

icon

Beste antwoord door tintoretto 22 September 2021, 18:52

Bekijk origineel

13 reacties

Reputatie 7
Badge +20

Hi @tintoretto 

No worries. We can also assist you in English. I have checked to see if you have any barrings, but that’s not the case so you should be able to have service abroad. Can you manually select a different provider in your phone? You should be able to have service with O2, Orange or Sovalom Telecom. Can you please check if one of these work? 

Looking forward to your reply. 

I tried manually selecting O2 and only got 3G signal in some areas (H+) and after that it automatically selects Telekom SK 2G signal (Edge). On my other phone and sim, I can get O2 / orange 4G, so this is definitely a problem with the T-Mobile SIM.

Reputatie 7
Badge +19

Hello @tintoretto 

You can check in your mobile settings, mobile network if your networkmode is set for 4G.

Hello @tintoretto 

You can check in your mobile settings, mobile network if your networkmode is set for 4G.

Of course I checked that. As I mentioned, 4G data was working fine as long as I was in the Netherlands. It is only after arriving here that it stopped working. I tried switching between 2G, 2G/3G and 4G/3G/2G and it all ends up with the same result. Manually selecting to O2 3G works for a while until it switches back to Telekom 2G. When I choose the 4G network manually after searching, I get the error message that SIM is unable to connect to that network (for example O2 4G). The preferred data connection type is always selected as 4G/3G/2G.

Reputatie 7
Badge +20

Hi @tintoretto 

I have send you a private message with a couple of questions that you need to answer. This way our technical specialist can look into your issue. Looking forward to your reply.

Reputatie 7
Badge +19

@tintoretto

Does your mobile phone support the 4G bands which are being used in Slowakia?

Which phone do you have, maybe we can figure out?

Bands in Slovakia

Hi @tintoretto 

I have send you a private message with a couple of questions that you need to answer. This way our technical specialist can look into your issue. Looking forward to your reply.

Thanks, I replied to your message with the answers.

@tintoretto

Does your mobile phone support the 4G bands which are being used in Slowakia?

Which phone do you have, maybe we can figure out?

Bands in Slovakia

 

According to GSMArena, my phone has these bands - 1, 2, 3, 4, 5, 7, 8, 20, 28, 38, 40. So that shouldn’t be an issue.

Reputatie 7
Badge +20

@tintoretto 

Thank you for your message!

@tintoretto

Thank you for your message!

Today I got the 4G connection since a few hours. Could you please let mw know what was the issue so that I can prepare next time ?

Reputatie 7
Badge +11

I’m also curious how the issue has been resolved. To be continued :relaxed:

Reputatie 7
Badge +20

Hi @tintoretto 

I don’t have an update yet. Your case is with the technical department right now, but they haven’t provided me with updates yet. 

Hi @tintoretto 

I don’t have an update yet. Your case is with the technical department right now, but they haven’t provided me with updates yet. 

One more update from me. So, Yesterday I came to Poland and I think that’s why it started working. Today I was over at Slovakia again and as soon as Telekom SK was connected, the 4G connection went to 2G in my T-Mobile SIM. My other SIM could connect to 4G in both the countries. Now, I am back in Poland and I can connect to 4G.

Reageer